aboutsummaryrefslogtreecommitdiff
path: root/graphics/sane-backends
diff options
context:
space:
mode:
authorLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-19 20:36:41 +0000
committerLi-Wen Hsu <lwhsu@FreeBSD.org>2009-03-19 20:36:41 +0000
commitfc59e8024290a4f550eac8187ea80bb34b981e4f (patch)
treeb98b072a17d0ee25260831154281664c3b50b8b9 /graphics/sane-backends
parent8d79118138f0ed4c8ecf3290f666aa3e84989e89 (diff)
downloadports-fc59e8024290a4f550eac8187ea80bb34b981e4f.tar.gz
ports-fc59e8024290a4f550eac8187ea80bb34b981e4f.zip
Notes
Diffstat (limited to 'graphics/sane-backends')
-rw-r--r--graphics/sane-backends/Makefile6
-rw-r--r--graphics/sane-backends/files/patch-sanei_sanei_usb.c19
2 files changed, 21 insertions, 4 deletions
diff --git a/graphics/sane-backends/Makefile b/graphics/sane-backends/Makefile
index 992fa09418e3..43c3c551c164 100644
--- a/graphics/sane-backends/Makefile
+++ b/graphics/sane-backends/Makefile
@@ -41,15 +41,13 @@ USE_LDCONFIG= yes
.include "Makefile.man"
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 800069
-BROKEN= does not compile due to changes in USB stack
-.endif
-
.if defined(WITHOUT_USB)
CONFIGURE_ARGS+= --disable-libusb
.else
+.if ${OSVERSION} < 800069
LIB_DEPENDS+= usb-0.1.8:${PORTSDIR}/devel/libusb
.endif
+.endif
.if defined(WITHOUT_NLS)
CONFIGURE_ARGS+= --disable-translations
diff --git a/graphics/sane-backends/files/patch-sanei_sanei_usb.c b/graphics/sane-backends/files/patch-sanei_sanei_usb.c
new file mode 100644
index 000000000000..8c602a6cdaa4
--- /dev/null
+++ b/graphics/sane-backends/files/patch-sanei_sanei_usb.c
@@ -0,0 +1,19 @@
+--- sanei/sanei_usb.c.orig 2009-03-18 17:05:03.000000000 -0700
++++ sanei/sanei_usb.c 2009-03-18 17:05:06.000000000 -0700
+@@ -88,6 +88,7 @@
+ #endif /* HAVE_USBCALLS */
+
+ #if defined (__FreeBSD__)
++#include <sys/param.h>
+ #include <dev/usb/usb.h>
+ #endif /* __FreeBSD__ */
+ #if defined (__DragonFly__)
+@@ -252,7 +253,7 @@
+ *vendorID = vendor;
+ *productID = product;
+ }
+-#elif defined (__FreeBSD__) || defined (__DragonFly__)
++#elif (defined (__FreeBSD__) && __FreeBSD_version < 800064) || defined (__DragonFly__)
+ {
+ int controller;
+ int ctrl_fd;