aboutsummaryrefslogtreecommitdiff
path: root/graphics/sdl_image
diff options
context:
space:
mode:
authorMarcus von Appen <mva@FreeBSD.org>2015-02-07 08:21:46 +0000
committerMarcus von Appen <mva@FreeBSD.org>2015-02-07 08:21:46 +0000
commit37e718a0e18640782e500bd7a6eb096f9bcb89f3 (patch)
tree8ae14d26d40a7b08332da78aab120b21b052972d /graphics/sdl_image
parent0a4b45c2f6c617ac82489a6e5c82a5958b7f83c7 (diff)
downloadports-37e718a0e18640782e500bd7a6eb096f9bcb89f3.tar.gz
ports-37e718a0e18640782e500bd7a6eb096f9bcb89f3.zip
- Provide OPTION knobs for the LIB_DEPENDS of sdl_image and sdl2_image
PR: 195987 Submitted by: jbeich@
Notes
Notes: svn path=/head/; revision=378574
Diffstat (limited to 'graphics/sdl_image')
-rw-r--r--graphics/sdl_image/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/graphics/sdl_image/Makefile b/graphics/sdl_image/Makefile
index 84238bc32c74..91f340543b43 100644
--- a/graphics/sdl_image/Makefile
+++ b/graphics/sdl_image/Makefile
@@ -13,11 +13,6 @@ COMMENT= Simple library to load images of various formats as SDL surfaces
LICENSE= LGPL21
-LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
- libpng.so:${PORTSDIR}/graphics/png \
- libtiff.so:${PORTSDIR}/graphics/tiff \
- libwebp.so:${PORTSDIR}/graphics/webp
-
USES= gmake libtool pkgconfig pathfix
USE_SDL= sdl
GNU_CONFIGURE= yes
@@ -25,6 +20,18 @@ CPPFLAGS+= -I${LOCALBASE}/include
LIBS+= -L${LOCALBASE}/lib -lm
USE_LDCONFIG= yes
+OPTIONS_DEFINE= JPEG PNG TIFF WEBP
+OPTIONS_DEFAULT=JPEG PNG TIFF WEBP
+
+JPEG_LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg
+JPEG_CONFIGURE_ENABLE= jpg
+PNG_LIB_DEPENDS= libpng.so:${PORTSDIR}/graphics/png
+PNG_CONFIGURE_ENABLE= png
+TIFF_LIB_DEPENDS= libtiff.so:${PORTSDIR}/graphics/tiff
+TIFF_CONFIGURE_ENABLE= tif
+WEBP_LIB_DEPENDS= libwebp.so:${PORTSDIR}/graphics/webp
+WEBP_CONFIGURE_ENABLE= webp
+
post-install:
${INSTALL_PROGRAM} ${WRKSRC}/.libs/showimage ${STAGEDIR}${PREFIX}/bin