aboutsummaryrefslogtreecommitdiff
path: root/graphics/seejpeg
diff options
context:
space:
mode:
authorTrevor Johnson <trevor@FreeBSD.org>2000-10-24 20:46:49 +0000
committerTrevor Johnson <trevor@FreeBSD.org>2000-10-24 20:46:49 +0000
commit5c2c8b66ccbb7b8a4e9ac2cc017f3201a306f095 (patch)
treeebbdc4d45e7db84807705977829fb04ffe5614e0 /graphics/seejpeg
parent76f66d18b2d75d82d1a31871267216973ad48c09 (diff)
downloadports-5c2c8b66ccbb7b8a4e9ac2cc017f3201a306f095.tar.gz
ports-5c2c8b66ccbb7b8a4e9ac2cc017f3201a306f095.zip
Add a new port of seejpeg 1.10, an SVGAlib-based viewer for JPEG,
TARGA, GIF, BMP, and PPM files. PR: 22131 Submitted by: Donn Miller <dmmiller@cvzoom.net>
Notes
Notes: svn path=/head/; revision=34199
Diffstat (limited to 'graphics/seejpeg')
-rw-r--r--graphics/seejpeg/Makefile34
-rw-r--r--graphics/seejpeg/distinfo1
-rw-r--r--graphics/seejpeg/files/patch-aa52
-rw-r--r--graphics/seejpeg/pkg-comment1
-rw-r--r--graphics/seejpeg/pkg-descr9
-rw-r--r--graphics/seejpeg/pkg-plist1
6 files changed, 98 insertions, 0 deletions
diff --git a/graphics/seejpeg/Makefile b/graphics/seejpeg/Makefile
new file mode 100644
index 000000000000..5328468467f7
--- /dev/null
+++ b/graphics/seejpeg/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: seejpeg-1.10.tgz
+# Date created: 2000 Oct 19
+#
+# Whom: Donn Miller <dmmiller@cvzoom.net>
+# $FreeBSD$
+#
+
+PORTNAME= seejpeg
+PORTVERSION= 1.10
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SUNSITE}
+MASTER_SITE_SUBDIR= apps/graphics/viewers/svga
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= ports@FreeBSD.org
+
+LIB_DEPENDS= vga.1:${PORTSDIR}/graphics/svgalib \
+ gnugetopt.1:${PORTSDIR}/devel/libgnugetopt \
+ jpeg.9:${PORTSDIR}/graphics/jpeg
+
+ALL_TARGET= seejpeg
+
+MAN1= seejpeg.1
+MANCOMPRESSED= yes
+USE_GMAKE= yes
+
+post-extract:
+ ${CHMOD} 0644 ${WRKSRC}/Makefile
+
+post-patch:
+ ${MV} ${WRKSRC}/Makefile ${WRKSRC}/Makefile.prev
+ ${SED} "s/-O3/${CFLAGS}/g" ${WRKSRC}/Makefile.prev > ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/graphics/seejpeg/distinfo b/graphics/seejpeg/distinfo
new file mode 100644
index 000000000000..75af2a1de0d2
--- /dev/null
+++ b/graphics/seejpeg/distinfo
@@ -0,0 +1 @@
+MD5 (seejpeg-1.10.tgz) = 96a72df8ef223316eee0167c8da3fd1e
diff --git a/graphics/seejpeg/files/patch-aa b/graphics/seejpeg/files/patch-aa
new file mode 100644
index 000000000000..1f63ef8b85f9
--- /dev/null
+++ b/graphics/seejpeg/files/patch-aa
@@ -0,0 +1,52 @@
+--- Makefile.orig Sun Nov 7 00:55:19 1999
++++ Makefile Thu Oct 19 10:31:56 2000
+@@ -6,19 +6,19 @@
+ # $Id: Makefile,v 1.8 1999/11/07 05:55:19 evan Exp $
+
+ # The installation directories.
+-BIN= /usr/local/bin
+-MAN= /usr/local/man/man1
++BIN= ${LOCALBASE}/bin
++MAN= ${LOCALBASE}/man/man1
+
+ # See the README for a description of these options.
+ #OPTIONS= -DNO_32K_CASCADE -DTESTMODE=G640x480x32K -DBUG_WORKAROUND -DONLY_1_8_MODES
+ OPTIONS= -DBUG_WORKAROUND
+
+ # This should be the location of the JPEG v6 header files.
+-JPEG_HEADERS= -I /usr/local/include
++JPEG_HEADERS= -I ${LOCALBASE}/include
+ #JPEG_HEADERS= -I /usr/X11R6/include
+
+ # This should be the location of the JPEG v6 libraries.
+-JPEG_LIBS= -L /usr/local/lib
++JPEG_LIBS= -L ${LOCALBASE}/lib
+ #JPEG_LIBS= -L /usr/X11R6/lib
+
+ # These may be changed, if desired.
+@@ -29,13 +29,13 @@
+ # Editing of the rest of this Makefile shouldn't be necessary.
+
+ CFLAGS= $(JPEG_HEADERS) -I jpeglib $(CCOPTS) $(OPTIONS)
+-LIBS= -lvga $(JPEG_LIBS) -ljpeg -lm
++LIBS= -lvga $(JPEG_LIBS) -ljpeg -lgnugetopt -lm
+ LDOPTS= -s
+
+ SEEJPEG= seejpeg.o jpeg.o image.o display.o cmap.o \
+ jpeglib/rdbmp.o jpeglib/rdgif.o jpeglib/rdppm.o \
+ jpeglib/rdtarga.o
+-
++
+ default:
+ @echo "To build seejpeg, first obtain the library for v6 of libjpeg. This ought"
+ @echo "to be available from the same place that you obtained seejpeg. Having"
+@@ -54,7 +54,8 @@
+
+ install:
+ install -s -o root -g bin -m 4711 seejpeg $(BIN)
+- install -o root -g root -m 644 seejpeg.1 $(MAN)
++ install -o root -g wheel -m 644 seejpeg.1 $(MAN)
++ gzip ${LOCALBASE}/man/man1/seejpeg.1
+
+ clean:
+ rm -f *.o jpeglib/*.o *~ core seejpeg
diff --git a/graphics/seejpeg/pkg-comment b/graphics/seejpeg/pkg-comment
new file mode 100644
index 000000000000..0c8cb97d2412
--- /dev/null
+++ b/graphics/seejpeg/pkg-comment
@@ -0,0 +1 @@
+A console graphics viewer using the svga console graphics library
diff --git a/graphics/seejpeg/pkg-descr b/graphics/seejpeg/pkg-descr
new file mode 100644
index 000000000000..21d528a03830
--- /dev/null
+++ b/graphics/seejpeg/pkg-descr
@@ -0,0 +1,9 @@
+A console graphics viewer using the svga console graphics library.
+
+Seejpeg is another JPEG viewer which utilizes svgalib and contains
+limited GIF, PPM, BMP and TARGA viewing support.
+
+WWW:http://www.icewalk.com/softlib/app/app_00013.html
+
+- Donn
+dmmiller@zoominternet.net
diff --git a/graphics/seejpeg/pkg-plist b/graphics/seejpeg/pkg-plist
new file mode 100644
index 000000000000..37ff7d12916c
--- /dev/null
+++ b/graphics/seejpeg/pkg-plist
@@ -0,0 +1 @@
+bin/seejpeg