aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-08-17 14:24:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-08-17 14:24:43 +0000
commit3ef9d0f8b990200158b43c9eb86717f37d8f5f57 (patch)
tree58594823b92d1b1ad415b83031e13b7385f4c5b1 /graphics/sekrit-twc-zimg
parent40a14220f62dc54d567ca962acb528719bc1cccc (diff)
downloadports-3ef9d0f8b990200158b43c9eb86717f37d8f5f57.tar.gz
ports-3ef9d0f8b990200158b43c9eb86717f37d8f5f57.zip
graphics/sekrit-twc-zimg: update to 2.2
Notes
Notes: svn path=/head/; revision=420352
Diffstat (limited to 'graphics/sekrit-twc-zimg')
-rw-r--r--graphics/sekrit-twc-zimg/Makefile14
-rw-r--r--graphics/sekrit-twc-zimg/distinfo5
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-no-extra-deps139
-rw-r--r--graphics/sekrit-twc-zimg/pkg-plist1
4 files changed, 78 insertions, 81 deletions
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index 593c60ae741f..f35e07265975 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= zimg
-PORTVERSION= 2.1
+PORTVERSION= 2.2
DISTVERSIONPREFIX= release-
CATEGORIES= graphics
PKGNAMEPREFIX= ${GH_ACCOUNT}-
@@ -23,19 +23,25 @@ USES= autoreconf compiler:c++11-lib gmake libtool pathfix
EXTRACT_AFTER_ARGS= --exclude test/extra
PATHFIX_MAKEFILEIN= Makefile.am
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --disable-silent-rules --enable-testapp
+CONFIGURE_ARGS= --disable-silent-rules
CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528
+CPPFLAGS+= ${CPPFLAGS_${CHOSEN_COMPILER_TYPE}_${COMPILER_VERSION}}
+CPPFLAGS_clang_34= -include x86intrin.h # revert 575bd93
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
+PORTEXAMPLES= *
-OPTIONS_DEFINE= TEST
+OPTIONS_DEFINE= EXAMPLES TEST
OPTIONS_DEFINE_amd64= SIMD
OPTIONS_DEFINE_i386= SIMD
OPTIONS_DEFAULT_amd64= SIMD
OPTIONS_DEFAULT_i386= SIMD # runtime detection
+EXAMPLES_CONFIGURE_ENABLE= example
+EXAMPLES_MAKE_ARGS= exampledir="${EXAMPLESDIR}"
+
SIMD_CONFIGURE_ENABLE= x86simd
TEST_BUILD_DEPENDS= googletest>=1.6.0:devel/googletest
@@ -47,7 +53,7 @@ post-patch:
@${REINPLACE_CMD} -e 's/x86_64/&|amd64/g' \
${WRKSRC}/configure.ac
@${REINPLACE_CMD} -e 's/-O2 //' \
- -e '/zimg-test/ { s/+=/=/; s/^noinst_/bin_/; } ' \
+ -e '/dist_doc_DATA/d' \
${WRKSRC}/Makefile.am
pre-install-TEST-on: do-test
diff --git a/graphics/sekrit-twc-zimg/distinfo b/graphics/sekrit-twc-zimg/distinfo
index bd6c5fd44895..8a079108b6bd 100644
--- a/graphics/sekrit-twc-zimg/distinfo
+++ b/graphics/sekrit-twc-zimg/distinfo
@@ -1,2 +1,3 @@
-SHA256 (sekrit-twc-zimg-release-2.1_GH0.tar.gz) = 09093bbb4d73865362e1e346762a6efdc9acc3d2cab6a2ebf5f00ba5d90b17c3
-SIZE (sekrit-twc-zimg-release-2.1_GH0.tar.gz) = 171769
+TIMESTAMP = 1471300524
+SHA256 (sekrit-twc-zimg-release-2.2_GH0.tar.gz) = 573ef25858623d90158f829d1fa66d4ef429a005034cae7a9dc3e9d250b9abf7
+SIZE (sekrit-twc-zimg-release-2.2_GH0.tar.gz) = 175926
diff --git a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
index a5b16752006c..8910901bbebf 100644
--- a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
+++ b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
@@ -1,6 +1,6 @@
---- Makefile.am.orig 2016-01-22 18:12:28 UTC
+--- Makefile.am.orig 2016-08-17 04:57:11 UTC
+++ Makefile.am
-@@ -197,35 +197,16 @@ endif # TESTAPP
+@@ -242,29 +242,12 @@ endif # TESTAPP
if UNIT_TEST
TESTS = test/unit_test
@@ -9,42 +9,46 @@
-test_libmusl_m_la_CFLAGS = $(AM_CFLAGS) -Wno-sign-compare -Wno-unused-variable -Wno-unused-but-set-variable
-
--test_libmusl_m_la_SOURCES = test/extra/musl-libm/__cos.c \
-- test/extra/musl-libm/__rem_pio2.c \
-- test/extra/musl-libm/__rem_pio2_large.c \
-- test/extra/musl-libm/__sin.c \
-- test/extra/musl-libm/cos.c \
-- test/extra/musl-libm/fpu_wrapper.c \
-- test/extra/musl-libm/libm.h \
-- test/extra/musl-libm/mymath.h \
-- test/extra/musl-libm/pow.c \
-- test/extra/musl-libm/powf.c \
-- test/extra/musl-libm/sin.c
+-test_libmusl_m_la_SOURCES = \
+- test/extra/musl-libm/__cos.c \
+- test/extra/musl-libm/__rem_pio2.c \
+- test/extra/musl-libm/__rem_pio2_large.c \
+- test/extra/musl-libm/__sin.c \
+- test/extra/musl-libm/cos.c \
+- test/extra/musl-libm/fpu_wrapper.c \
+- test/extra/musl-libm/libm.h \
+- test/extra/musl-libm/mymath.h \
+- test/extra/musl-libm/pow.c \
+- test/extra/musl-libm/powf.c \
+- test/extra/musl-libm/sin.c
-
- test_unit_test_CPPFLAGS = -I$(srcdir)/src/zimg \
- -I$(srcdir)/test \
-- -I$(srcdir)/test/extra \
-- -I$(srcdir)/test/extra/googletest/googletest/include
-+ -I$(srcdir)/test/extra
-
- test_unit_test_SOURCES = test/main.cpp \
- test/colorspace/colorspace_test.cpp \
- test/depth/depth_convert_test.cpp \
- test/depth/dither_test.cpp \
-- test/extra/sha1/config.h \
-- test/extra/sha1/sha1.c \
-- test/extra/sha1/sha1.h \
- test/graph/audit_buffer.cpp \
- test/graph/audit_buffer.h \
- test/graph/basic_filter_test.cpp \
-@@ -247,7 +228,6 @@ test_unit_test_SOURCES += test/colorspac
-
+ test_unit_test_CPPFLAGS = \
+ -I$(srcdir)/src/zimg \
+ -I$(srcdir)/test \
+- -I$(srcdir)/test/extra \
+- -I$(srcdir)/test/extra/googletest/googletest/include
++ -I$(srcdir)/test/extra
+
+ test_unit_test_SOURCES = \
+ test/main.cpp \
+@@ -272,9 +255,6 @@ test_unit_test_SOURCES = \
+ test/colorspace/colorspace_test.cpp \
+ test/depth/depth_convert_test.cpp \
+ test/depth/dither_test.cpp \
+- test/extra/sha1/config.h \
+- test/extra/sha1/sha1.c \
+- test/extra/sha1/sha1.h \
+ test/graph/audit_buffer.cpp \
+ test/graph/audit_buffer.h \
+ test/graph/basic_filter_test.cpp \
+@@ -302,7 +282,6 @@ test_unit_test_SOURCES += \
endif #X86SIMD
--test_unit_test_LDADD = test/extra/googletest/googletest/lib/libgtest.la \
-- test/libmusl_m.la \
-+test_unit_test_LDADD = -lgtest -lmd -lpthread \
- libzimg.la
+ test_unit_test_LDADD = \
+- test/extra/googletest/googletest/lib/libgtest.la \
+- test/libmusl_m.la \
++ -lgtest -lmd -lpthread \
+ libzimg_internal.la
endif # UNIT_TEST
--- configure.ac.orig 2016-05-08 20:08:38 UTC
+++ configure.ac
@@ -59,55 +63,42 @@
--- test/graph/filter_validator.cpp.orig 2016-01-22 18:12:28 UTC
+++ test/graph/filter_validator.cpp
-@@ -13,7 +13,7 @@
+@@ -14,7 +14,14 @@
#include "gtest/gtest.h"
extern "C" {
-- #include "sha1/sha1.h"
++#ifdef _WIN32
+ #include "sha1/sha1.h"
++#else // assume openssl or libmd
+ #include <sha.h>
++ #define SHA1Init SHA1_Init
++ #define SHA1Update SHA1_Update
++ #define SHA1Final SHA1_Final
++#endif
}
#include "audit_buffer.h"
-@@ -35,14 +35,14 @@ void hash_buffer(const AuditBuffer<T> &b
- auto image_buffer = buf.as_read_buffer();
- SHA1_CTX sha_ctx;
-
-- SHA1Init(&sha_ctx);
-+ SHA1_Init(&sha_ctx);
-
- for (unsigned i = 0; i < height; ++i) {
- const unsigned char *ptr = zimg::graph::static_buffer_cast<const unsigned char>(image_buffer[p])[i];
-- SHA1Update(&sha_ctx, ptr, width * sizeof(T));
-+ SHA1_Update(&sha_ctx, ptr, width * sizeof(T));
- }
-
-- SHA1Final(digest, &sha_ctx);
-+ SHA1_Final(digest, &sha_ctx);
- }
-
- std::string hash_to_str(const unsigned char digest[20])
---- test/main.cpp.orig 2016-01-22 18:12:28 UTC
+--- test/main.cpp.orig 2016-08-17 04:57:11 UTC
+++ test/main.cpp
-@@ -3,22 +3,11 @@
- #include "common/libm_wrapper.h"
+@@ -1,8 +1,12 @@
+ #include <cstdio>
+ #include <cstdlib>
+-#include "common/libm_wrapper.h"
#include "gtest/gtest.h"
--#include "musl-libm/mymath.h"
--
--void wrap_libm()
--{
-- _zimg_sin = mysin;
-- _zimg_cos = mycos;
-- _zimg_pow = mypow;
-- _zimg_powf = mypowf;
--}
++
++#if !defined(_WIN32) && !defined(__GLIBC__)
++#define wrap_libm() // assume openlibm
++#else
++#include "common/libm_wrapper.h"
+ #include "musl-libm/mymath.h"
+
+ namespace {
+@@ -16,6 +20,7 @@ void wrap_libm()
+ }
- int main(int argc, char **argv)
- {
- int ret;
+ } // namespace
++#endif
-- wrap_libm();
--
- ::testing::InitGoogleTest(&argc, argv);
- ret = RUN_ALL_TESTS();
+ int main(int argc, char **argv)
diff --git a/graphics/sekrit-twc-zimg/pkg-plist b/graphics/sekrit-twc-zimg/pkg-plist
index d5b23ae4e832..14c87f3f5b3d 100644
--- a/graphics/sekrit-twc-zimg/pkg-plist
+++ b/graphics/sekrit-twc-zimg/pkg-plist
@@ -1,4 +1,3 @@
-bin/zimg-test
include/zimg++.hpp
include/zimg.h
lib/libzimg.a