aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-05-07 22:29:46 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-05-07 22:29:46 +0000
commit67a9073255c853a66ec40e20ec79b92c2b44bc85 (patch)
tree9d553fcb5181a65656f17c284dc5954946973eb4 /graphics/sekrit-twc-zimg
parent9f6655b0e0dc5c41080004b9e7d0f84295ae8364 (diff)
downloadports-67a9073255c853a66ec40e20ec79b92c2b44bc85.tar.gz
ports-67a9073255c853a66ec40e20ec79b92c2b44bc85.zip
Drop FreeBSD 10.3 support
Reviewed by: yuri (SoPlex), sunpoet (nghttp2), cpm (chromium), brooks (llvm*) Approved by: portmgr (rene) Differential Revision: https://reviews.freebsd.org/D15238
Notes
Notes: svn path=/head/; revision=469338
Diffstat (limited to 'graphics/sekrit-twc-zimg')
-rw-r--r--graphics/sekrit-twc-zimg/Makefile2
-rw-r--r--graphics/sekrit-twc-zimg/files/extra-patch-src_zimg_api_zimg.cpp62
2 files changed, 0 insertions, 64 deletions
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index f7362634e2db..5d2013750f90 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -19,8 +19,6 @@ CONFLICTS_INSTALL= zimg-[0-9]* # include/zimg.h
USES= autoreconf compiler:c++11-lib gmake libtool pathfix
EXTRACT_AFTER_ARGS= --exclude test/extra
-EXTRA_PATCHES+= ${EXTRA_PATCHES_${OPSYS}_${OSREL}}
-EXTRA_PATCHES_FreeBSD_10.3= ${PATCHDIR}/extra-patch-src_zimg_api_zimg.cpp
GNU_CONFIGURE= yes
CPPFLAGS+= -D_GLIBCXX_USE_C99 -D_GLIBCXX_USE_C99_MATH_TR1 \
-D_DECLARE_C99_LDBL_MATH # XXX ports/193528
diff --git a/graphics/sekrit-twc-zimg/files/extra-patch-src_zimg_api_zimg.cpp b/graphics/sekrit-twc-zimg/files/extra-patch-src_zimg_api_zimg.cpp
deleted file mode 100644
index 6530da67207e..000000000000
--- a/graphics/sekrit-twc-zimg/files/extra-patch-src_zimg_api_zimg.cpp
+++ /dev/null
@@ -1,62 +0,0 @@
-FreeBSD 10.3 lacks __cxa_thread_atexit, so revert
-https://github.com/sekrit-twc/zimg/commit/7e47d8d2a892
-
---- src/zimg/api/zimg.cpp.orig 2017-01-21 18:59:03 UTC
-+++ src/zimg/api/zimg.cpp
-@@ -1,6 +1,5 @@
- #include <cmath>
- #include <memory>
--#include <string>
- #include <tuple>
- #include <type_traits>
- #include <utility>
-@@ -31,7 +30,7 @@ constexpr unsigned API_VERSION_2_2 = ZIM
- #define STRIDE_ALIGNMENT_ASSERT(x) zassert_d(!(x) || (x) % zimg::ALIGNMENT == 0, "buffer stride not aligned")
-
- thread_local zimg_error_code_e g_last_error = ZIMG_ERROR_SUCCESS;
--thread_local std::string g_last_error_msg;
-+thread_local char g_last_error_msg[1024];
-
- constexpr unsigned VERSION_INFO[] = { 2, 4, 0 };
-
-@@ -43,19 +42,10 @@ T *assert_dynamic_type(U *ptr) noexcept
- return static_cast<T *>(ptr);
- }
-
--void clear_last_error_message() noexcept
--{
-- g_last_error_msg.clear();
-- g_last_error_msg.shrink_to_fit();
--}
--
- void record_exception_message(const zimg::error::Exception &e) noexcept
- {
-- try {
-- g_last_error_msg = e.what();
-- } catch (const std::bad_alloc &) {
-- clear_last_error_message();
-- }
-+ strncpy(g_last_error_msg, e.what(), sizeof(g_last_error_msg) - 1);
-+ g_last_error_msg[sizeof(g_last_error_msg) - 1] = '\0';
- }
-
- zimg_error_code_e handle_exception(std::exception_ptr eptr) noexcept
-@@ -438,7 +428,7 @@ unsigned zimg_get_api_version(unsigned *
- zimg_error_code_e zimg_get_last_error(char *err_msg, size_t n)
- {
- if (err_msg && n) {
-- std::strncpy(err_msg, g_last_error_msg.c_str(), n);
-+ strncpy(err_msg, g_last_error_msg, n);
- err_msg[n - 1] = '\0';
- }
-
-@@ -447,8 +437,8 @@ zimg_error_code_e zimg_get_last_error(ch
-
- void zimg_clear_last_error(void)
- {
-+ g_last_error_msg[0] = '\0';
- g_last_error = ZIMG_ERROR_SUCCESS;
-- clear_last_error_message();
- }
-
- unsigned zimg_select_buffer_mask(unsigned count)