aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2019-10-05 00:42:03 +0000
committerJan Beich <jbeich@FreeBSD.org>2019-10-05 00:42:03 +0000
commita5bfe8347515d2020aa15a9cf6447356e8682ae0 (patch)
tree826bc3725940616fbbb217b658b646de066808bd /graphics/sekrit-twc-zimg
parentd3f12d97c802e6e4f5c3d98a3e1e0e78a7131508 (diff)
downloadports-a5bfe8347515d2020aa15a9cf6447356e8682ae0.tar.gz
ports-a5bfe8347515d2020aa15a9cf6447356e8682ae0.zip
graphics/sekrit-twc-zimg: use bundled math library to unbreak some tests
[==========] 129 tests from 25 test suites ran. (29301 ms total) [ PASSED ] 127 tests. [ FAILED ] 2 tests, listed below: [ FAILED ] ColorspaceConversionTest.test_transfer_only_b67 [ FAILED ] ColorspaceConversionTest.test_rec2100_ictcp PR: 216537
Notes
Notes: svn path=/head/; revision=513800
Diffstat (limited to 'graphics/sekrit-twc-zimg')
-rw-r--r--graphics/sekrit-twc-zimg/Makefile3
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-no-extra-deps56
2 files changed, 6 insertions, 53 deletions
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index 18393b1eeb9b..9dd4e1a7209f 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -18,7 +18,8 @@ GH_ACCOUNT= sekrit-twc
CONFLICTS_INSTALL= zimg-[0-9]* # include/zimg.h
USES= autoreconf compiler:c++11-lib gmake libtool pathfix
-EXTRACT_AFTER_ARGS= --exclude test/extra
+EXCLUDE= googletest sha1
+EXTRACT_AFTER_ARGS= ${EXCLUDE:S,^,--exclude test/extra/,}
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
USE_LDCONFIG= yes
diff --git a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
index 7c1dce103bc5..ad28dec4d3d8 100644
--- a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
+++ b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
@@ -1,30 +1,6 @@
--- Makefile.am.orig 2017-12-21 02:35:58 UTC
+++ Makefile.am
-@@ -286,32 +286,13 @@ endif # TESTAPP
- if UNIT_TEST
- TESTS = test/unit_test
-
--check_LTLIBRARIES = test/libmusl_m.la
- check_PROGRAMS = test/unit_test
-
--test_libmusl_m_la_CFLAGS = $(AM_CFLAGS) -std=c99 -Wno-sign-compare -Wno-unused-variable -Wno-unused-but-set-variable
--
--test_libmusl_m_la_SOURCES = \
-- test/extra/musl-libm/__cos.c \
-- test/extra/musl-libm/__rem_pio2.c \
-- test/extra/musl-libm/__rem_pio2_large.c \
-- test/extra/musl-libm/__sin.c \
-- test/extra/musl-libm/cos.c \
-- test/extra/musl-libm/fpu_wrapper.c \
-- test/extra/musl-libm/expf.c \
-- test/extra/musl-libm/libm.h \
-- test/extra/musl-libm/log10f.c \
-- test/extra/musl-libm/logf.c \
-- test/extra/musl-libm/mymath.h \
-- test/extra/musl-libm/powf.c \
-- test/extra/musl-libm/sin.c
--
- test_unit_test_CPPFLAGS = \
+@@ -314,8 +313,7 @@ test_unit_test_CPPFLAGS = \
$(AM_CPPFLAGS) \
-I$(srcdir)/src/zimg \
-I$(srcdir)/test \
@@ -34,7 +10,7 @@
test_unit_test_SOURCES = \
test/main.cpp \
-@@ -320,9 +301,6 @@ test_unit_test_SOURCES = \
+@@ -324,9 +322,6 @@ test_unit_test_SOURCES = \
test/colorspace/gamma_test.cpp \
test/depth/depth_convert_test.cpp \
test/depth/dither_test.cpp \
@@ -44,13 +20,13 @@
test/graph/audit_buffer.cpp \
test/graph/audit_buffer.h \
test/graph/copy_filter_test.cpp \
-@@ -362,7 +340,6 @@ test_unit_test_SOURCES += \
+@@ -368,7 +363,7 @@ test_unit_test_SOURCES += \
endif # X86SIMD_AVX512
test_unit_test_LDADD = \
- test/extra/googletest/googletest/lib/libgtest.la \
-- test/libmusl_m.la \
+ -lgtest -lmd -lpthread \
+ test/libmusl_m.la \
libzimg_internal.la
endif # UNIT_TEST
--- configure.ac.orig 2016-05-08 20:08:38 UTC
@@ -81,27 +57,3 @@
}
#include "audit_buffer.h"
---- test/main.cpp.orig 2016-08-17 04:57:11 UTC
-+++ test/main.cpp
-@@ -1,8 +1,12 @@
- #include <cstdio>
- #include <cstdlib>
--#include "common/libm_wrapper.h"
-
- #include "gtest/gtest.h"
-+
-+#if !defined(_WIN32) && !defined(__GLIBC__)
-+#define wrap_libm() // assume openlibm
-+#else
-+#include "common/libm_wrapper.h"
- #include "musl-libm/mymath.h"
-
- namespace {
-@@ -16,6 +20,7 @@ void wrap_libm()
- }
-
- } // namespace
-+#endif
-
-
- int main(int argc, char **argv)