aboutsummaryrefslogtreecommitdiff
path: root/graphics/sekrit-twc-zimg
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-05-09 13:53:43 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-05-09 13:53:43 +0000
commitf42070c5aa527b8754ce3aa2111ff78d40e02363 (patch)
tree2c49747d8d6e90bac1a1931e01636f44b652d5bb /graphics/sekrit-twc-zimg
parent431faea61b9a4845d209f1649ce673c7629e353a (diff)
downloadports-f42070c5aa527b8754ce3aa2111ff78d40e02363.tar.gz
ports-f42070c5aa527b8754ce3aa2111ff78d40e02363.zip
graphics/sekrit-twc-zimg: update to 2.1
Notes
Notes: svn path=/head/; revision=414855
Diffstat (limited to 'graphics/sekrit-twc-zimg')
-rw-r--r--graphics/sekrit-twc-zimg/Makefile6
-rw-r--r--graphics/sekrit-twc-zimg/distinfo4
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-no-extra-deps14
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp11
-rw-r--r--graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp4
-rw-r--r--graphics/sekrit-twc-zimg/pkg-plist1
6 files changed, 23 insertions, 17 deletions
diff --git a/graphics/sekrit-twc-zimg/Makefile b/graphics/sekrit-twc-zimg/Makefile
index a522929d89e1..1fd96db1aabc 100644
--- a/graphics/sekrit-twc-zimg/Makefile
+++ b/graphics/sekrit-twc-zimg/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= zimg
-PORTVERSION= 2.0.4
+PORTVERSION= 2.1
DISTVERSIONPREFIX= release-
CATEGORIES= graphics
PKGNAMEPREFIX= ${GH_ACCOUNT}-
@@ -46,10 +46,6 @@ post-patch:
@${REINPLACE_CMD} -e 's/-O2 //' \
-e '/zimg-test/ { s/+=/=/; s/^noinst_/bin_/; } ' \
${WRKSRC}/Makefile.am
- @${REINPLACE_CMD} -e 's/nullptr_t/std::&/' \
- -e 's/off64_t/off_t/' \
- ${WRKSRC}/src/testcommon/json.* \
- ${WRKSRC}/src/testcommon/mmap.cpp
pre-install-TEST-on: do-test
diff --git a/graphics/sekrit-twc-zimg/distinfo b/graphics/sekrit-twc-zimg/distinfo
index fe97b9a513df..bd6c5fd44895 100644
--- a/graphics/sekrit-twc-zimg/distinfo
+++ b/graphics/sekrit-twc-zimg/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sekrit-twc-zimg-release-2.0.4_GH0.tar.gz) = e3b1f5b9f8ce750f96b9bc9801ff5d6aa931d35300d67711826e397df43c5245
-SIZE (sekrit-twc-zimg-release-2.0.4_GH0.tar.gz) = 174469
+SHA256 (sekrit-twc-zimg-release-2.1_GH0.tar.gz) = 09093bbb4d73865362e1e346762a6efdc9acc3d2cab6a2ebf5f00ba5d90b17c3
+SIZE (sekrit-twc-zimg-release-2.1_GH0.tar.gz) = 171769
diff --git a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
index 19197742cc02..a5b16752006c 100644
--- a/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
+++ b/graphics/sekrit-twc-zimg/files/patch-no-extra-deps
@@ -46,16 +46,16 @@
+test_unit_test_LDADD = -lgtest -lmd -lpthread \
libzimg.la
endif # UNIT_TEST
---- configure.ac.orig 2016-01-22 18:12:28 UTC
+--- configure.ac.orig 2016-05-08 20:08:38 UTC
+++ configure.ac
-@@ -29,8 +29,6 @@ AS_IF([test "x$enable_unit_test" = "xyes
- [x86_64], [],
- [AC_MSG_WARN([Could not determine how to enable IEEE-754 compliance on host. Tests may fail.])]
- )
+@@ -30,8 +30,6 @@ AS_IF([test "x$enable_unit_test" = "xyes
+ [i?86], [CFLAGS="$CFLAGS -mfpmath=sse -msse2" CXXFLAGS="$CXXFLAGS -mfpmath=sse -msse2"],
+ [x86_64], [],
+ [AC_MSG_WARN([Could not determine how to enable IEEE-754 compliance on host. Tests may fail.])])
- AC_CONFIG_SUBDIRS(test/extra/googletest/googletest)
- AC_SUBST([CONFIG_SUBDIRS], [test/extra/googletest/googletest])
- ],
- )
+ ])
+
--- test/graph/filter_validator.cpp.orig 2016-01-22 18:12:28 UTC
+++ test/graph/filter_validator.cpp
diff --git a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp
new file mode 100644
index 000000000000..20240082025c
--- /dev/null
+++ b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__avx2__test.cpp
@@ -0,0 +1,11 @@
+--- test/resize/resize_impl_avx2_test.cpp.orig 2016-05-08 20:08:38 UTC
++++ test/resize/resize_impl_avx2_test.cpp
+@@ -9,6 +9,8 @@
+ #include "gtest/gtest.h"
+ #include "graph/filter_validator.h"
+
++#include <cmath> // NAN
++
+ namespace {
+
+ void test_case(const zimg::resize::Filter &filter, bool horizontal, unsigned src_w, unsigned src_h, unsigned dst_w, unsigned dst_h,
diff --git a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
index 99afc2ea8336..7fc1daafe6ad 100644
--- a/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
+++ b/graphics/sekrit-twc-zimg/files/patch-test_resize_resize__impl__sse2__test.cpp
@@ -1,4 +1,4 @@
---- test/resize/resize_impl_sse2_test.cpp.orig 2016-01-22 18:12:28 UTC
+--- test/resize/resize_impl_sse2_test.cpp.orig 2016-05-08 20:08:38 UTC
+++ test/resize/resize_impl_sse2_test.cpp
@@ -7,6 +7,8 @@
#include "gtest/gtest.h"
@@ -6,6 +6,6 @@
+#include <cmath> // INFINITY
+
- namespace {;
+ namespace {
void test_case(const zimg::resize::Filter &filter, bool horizontal, unsigned src_w, unsigned src_h, unsigned dst_w, unsigned dst_h,
diff --git a/graphics/sekrit-twc-zimg/pkg-plist b/graphics/sekrit-twc-zimg/pkg-plist
index 6a89e85c2963..d5b23ae4e832 100644
--- a/graphics/sekrit-twc-zimg/pkg-plist
+++ b/graphics/sekrit-twc-zimg/pkg-plist
@@ -5,5 +5,4 @@ lib/libzimg.a
lib/libzimg.so
lib/libzimg.so.2
lib/libzimg.so.2.0.0
-lib/zimg/vszimg.so
libdata/pkgconfig/zimg.pc