aboutsummaryrefslogtreecommitdiff
path: root/graphics/separate/Makefile
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-02-16 22:39:17 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-02-16 22:39:17 +0000
commit9afb91ced919bf67e510fcd2fb28b3bb9ca7155f (patch)
treed5d59e9ccfb17b59f7c9841e2c591fdd6165b1d3 /graphics/separate/Makefile
parentca24d52577c0104c8b1bb2f88355d2524a8d4161 (diff)
downloadports-9afb91ced919bf67e510fcd2fb28b3bb9ca7155f.tar.gz
ports-9afb91ced919bf67e510fcd2fb28b3bb9ca7155f.zip
Notes
Diffstat (limited to 'graphics/separate/Makefile')
-rw-r--r--graphics/separate/Makefile54
1 files changed, 54 insertions, 0 deletions
diff --git a/graphics/separate/Makefile b/graphics/separate/Makefile
new file mode 100644
index 000000000000..3a62344ef62d
--- /dev/null
+++ b/graphics/separate/Makefile
@@ -0,0 +1,54 @@
+# New ports collection makefile for: separate
+# Date created: 30 January 2008
+# Whom: Pietro Cerutti <gahr@gahr.ch>
+#
+# $FreeBSD$
+#
+
+PORTNAME= separate
+PORTVERSION= 20070727
+CATEGORIES= graphics
+MASTER_SITES= http://www.gahr.ch/FreeBSD/distfiles/
+
+MAINTAINER= gahr@gahr.ch
+COMMENT= A CMYK plugin for The GIMP
+
+BUILD_DEPENDS= gccmakedep:${PORTSDIR}/devel/gccmakedep \
+ gimp-2.4:${PORTSDIR}/graphics/gimp
+LIB_DEPENDS= lcms.1:${PORTSDIR}/graphics/lcms
+
+WRKSRC= ${WRKDIR}/${PORTNAME}+
+
+USE_ZIP= yes
+
+GIMP_PLUGINS_DIR= libexec/gimp/2.2/plug-ins/
+TARGETS= separate separate_import icc_colorspace
+
+.for PLUGIN in ${TARGETS}
+PLIST_FILES+= ${GIMP_PLUGINS_DIR}/${PLUGIN}
+.endfor
+
+PORTDOCS= README*
+PORTEXAMPLES= quickproof.scm quicksave.scm
+
+MAKE_ENV+= TARGETS="${TARGETS}"
+
+do-install:
+.for PLUGIN in ${TARGETS}
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PLUGIN} ${PREFIX}/${GIMP_PLUGINS_DIR}/
+.endfor
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README_ICC_COLORSPACE ${DOCSDIR}
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample-scripts/for_GIMP2.3+/quickproof.scm ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/sample-scripts/for_GIMP2.3+/quicksave.scm ${EXAMPLESDIR}
+.endif
+ @${CAT} pkg-message
+
+.include <bsd.port.mk>