aboutsummaryrefslogtreecommitdiff
path: root/graphics/silgraphite
diff options
context:
space:
mode:
authorSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-31 16:03:16 +0000
committerSunpoet Po-Chuan Hsieh <sunpoet@FreeBSD.org>2020-01-31 16:03:16 +0000
commit0e947f2406de9708f47a12dfc10c9f07f96ffe28 (patch)
tree01777772fce766a4194c0a3f31f9a74a78e901d5 /graphics/silgraphite
parent9520d117eae707a713085b4d127ed0eafaa25cb8 (diff)
downloadports-0e947f2406de9708f47a12dfc10c9f07f96ffe28.tar.gz
ports-0e947f2406de9708f47a12dfc10c9f07f96ffe28.zip
Fix build on 13-CURRENT
PR: 243310 Reported by: salvadore, stephen Tested by: salvadore
Notes
Notes: svn path=/head/; revision=524720
Diffstat (limited to 'graphics/silgraphite')
-rw-r--r--graphics/silgraphite/Makefile3
-rw-r--r--graphics/silgraphite/files/patch-engine-include-graphite-Segment.h11
-rw-r--r--graphics/silgraphite/files/patch-engine-src-segment-Segment.cpp11
3 files changed, 22 insertions, 3 deletions
diff --git a/graphics/silgraphite/Makefile b/graphics/silgraphite/Makefile
index 67e83d82266f..470d21781216 100644
--- a/graphics/silgraphite/Makefile
+++ b/graphics/silgraphite/Makefile
@@ -10,9 +10,6 @@ MASTER_SITES= SF
MAINTAINER= sunpoet@FreeBSD.org
COMMENT= Font engine for complex non-Roman writing systems
-# /usr/include/c++/v1/type_traits:3699:9: error: no matching constructor for initialization of 'gr3ooo::Segment'
-BROKEN_FreeBSD_13= no matching constructor for initialization of 'gr3ooo::Segment'
-
LICENSE= CPL05 LGPL21+
LICENSE_COMB= dual
LICENSE_FILE_CPL05= ${WRKSRC}/license/License_CPLv05.txt
diff --git a/graphics/silgraphite/files/patch-engine-include-graphite-Segment.h b/graphics/silgraphite/files/patch-engine-include-graphite-Segment.h
new file mode 100644
index 000000000000..0050e320f8a6
--- /dev/null
+++ b/graphics/silgraphite/files/patch-engine-include-graphite-Segment.h
@@ -0,0 +1,11 @@
+--- engine/include/graphite/Segment.h.orig 2009-01-29 08:33:19 UTC
++++ engine/include/graphite/Segment.h
+@@ -64,7 +64,7 @@ class Segment (public)
+ virtual ~Segment();
+
+ // Basic copy constructor:
+- Segment(Segment & seg);
++ Segment(const Segment & seg);
+
+ // For making modified copies of segments:
+ static Segment * LineContextSegment(Segment & seg, bool fStartLine, bool fEndLine);
diff --git a/graphics/silgraphite/files/patch-engine-src-segment-Segment.cpp b/graphics/silgraphite/files/patch-engine-src-segment-Segment.cpp
new file mode 100644
index 000000000000..1849253dc822
--- /dev/null
+++ b/graphics/silgraphite/files/patch-engine-src-segment-Segment.cpp
@@ -0,0 +1,11 @@
+--- engine/src/segment/Segment.cpp.orig 2008-08-21 14:24:32 UTC
++++ engine/src/segment/Segment.cpp
+@@ -433,7 +433,7 @@ void Segment::InitWhiteSpaceSegment(int nNewDepth)
+ /*----------------------------------------------------------------------------------------------
+ Basic copy method.
+ ----------------------------------------------------------------------------------------------*/
+-Segment::Segment(Segment & seg)
++Segment::Segment(const Segment & seg)
+ {
+ int islout;
+