aboutsummaryrefslogtreecommitdiff
path: root/graphics/simpleviewer
diff options
context:
space:
mode:
authorMatthias Andree <mandree@FreeBSD.org>2021-04-10 21:16:19 +0000
committerMatthias Andree <mandree@FreeBSD.org>2021-04-12 00:33:37 +0000
commit5e0d6d767e15724b7b0af5cc222b461ecc7dba06 (patch)
tree6430dc38d9685a580fd0877a7e39d55782788f2e /graphics/simpleviewer
parent09382aa3f55946c41765cd39520e4acdf9677b38 (diff)
downloadports-5e0d6d767e15724b7b0af5cc222b461ecc7dba06.tar.gz
ports-5e0d6d767e15724b7b0af5cc222b461ecc7dba06.zip
graphics/simpleviewer: make compatible with OpenEXR/Imath 3.0
Diffstat (limited to 'graphics/simpleviewer')
-rw-r--r--graphics/simpleviewer/Makefile5
-rw-r--r--graphics/simpleviewer/files/patch-CMakeLists.txt20
2 files changed, 22 insertions, 3 deletions
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index 1a604e46b207..eabf2da9c04f 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -2,7 +2,7 @@
PORTNAME= simpleviewer
PORTVERSION= 3.1.7
-PORTREVISION= 8
+PORTREVISION= 9
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/andreyu/simple-viewer-gl/get/
DISTNAME= v${PORTVERSION} # version tag, has no embedded ${PORTNAME}
@@ -56,7 +56,8 @@ LCMS2_CMAKE_OFF= -DDISABLE_LCMS2_SUPPORT:STRING=1
LIBEXIF_LIB_DEPENDS= libexif.so:graphics/libexif
LIBEXIF_CMAKE_OFF= -DDISABLE_EXIF_SUPPORT:STRING=1
-OPENEXR_LIB_DEPENDS= libIlmImf.so:graphics/openexr
+OPENEXR_LIB_DEPENDS= libOpenEXR.so:graphics/openexr \
+ libImath.so:math/Imath
OPENEXR_CMAKE_OFF= -DDISABLE_OPENEXR_SUPPORT:STRING=1
TIFF_LIB_DEPENDS= libtiff.so:graphics/tiff
diff --git a/graphics/simpleviewer/files/patch-CMakeLists.txt b/graphics/simpleviewer/files/patch-CMakeLists.txt
index 80beeb9abcd1..24b62436eeaf 100644
--- a/graphics/simpleviewer/files/patch-CMakeLists.txt
+++ b/graphics/simpleviewer/files/patch-CMakeLists.txt
@@ -1,4 +1,4 @@
---- CMakeLists.txt.orig 2018-09-10 11:03:52 UTC
+--- CMakeLists.txt.orig 2019-11-13 08:52:44 UTC
+++ CMakeLists.txt
@@ -27,7 +27,7 @@ message(STATUS "***************************")
if(CMAKE_BUILD_TYPE STREQUAL "Release")
@@ -9,6 +9,24 @@
else()
message(STATUS "* Debug Build *")
add_definitions("-DDEBUG" )
+@@ -250,7 +250,7 @@ set(DISABLE_OPENEXR_SUPPORT "0" CACHE STRING "Disable
+ if (DISABLE_OPENEXR_SUPPORT EQUAL 0)
+ pkg_check_modules(OPENEXR QUIET OpenEXR)
+ if(OPENEXR_FOUND)
+- pkg_check_modules(ILMBASE REQUIRED IlmBase)
++ pkg_check_modules(ILMBASE REQUIRED Imath)
+ if(ILMBASE_FOUND)
+ message(STATUS "(+) OpenEXR support enabled")
+ if(VERBOSE_PATHS)
+@@ -261,7 +261,7 @@ if (DISABLE_OPENEXR_SUPPORT EQUAL 0)
+ link_directories(${ILMBASE_LIBRARY_DIRS} ${OPENEXR_LIBRARY_DIRS})
+ include_directories(${ILMBASE_INCLUDE_DIRS} ${OPENEXR_INCLUDE_DIRS})
+ else()
+- message(STATUS "(-) ILMBase not found")
++ message(STATUS "(-) Imath not found")
+ endif()
+ else()
+ message(STATUS "(-) OpenEXR support dropped")
@@ -316,7 +316,6 @@ endif()
message(STATUS "***************************")