aboutsummaryrefslogtreecommitdiff
path: root/graphics/simpleviewer
diff options
context:
space:
mode:
authorPawel Pekala <pawel@FreeBSD.org>2014-04-28 19:20:42 +0000
committerPawel Pekala <pawel@FreeBSD.org>2014-04-28 19:20:42 +0000
commitbc78a491ad5cddbb6cd123ed8e969fb3e5116748 (patch)
treeba666a25774ee99fdc27c5ea2bc9081781166595 /graphics/simpleviewer
parent0a840855ba440b332b3fda65b14df256f6f04291 (diff)
downloadports-bc78a491ad5cddbb6cd123ed8e969fb3e5116748.tar.gz
ports-bc78a491ad5cddbb6cd123ed8e969fb3e5116748.zip
- Add staging support
- Convert to new LIB_DEPENDS format, USES=tar:bzip2
Notes
Notes: svn path=/head/; revision=352543
Diffstat (limited to 'graphics/simpleviewer')
-rw-r--r--graphics/simpleviewer/Makefile15
1 files changed, 6 insertions, 9 deletions
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index 1479670fa67b..cee7cc5e1746 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -13,11 +13,11 @@ COMMENT= Small and simple OpenGL image viewer with transparency support
LICENSE= GPLv2
-LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
- png15:${PORTSDIR}/graphics/png \
- gif.5:${PORTSDIR}/graphics/giflib
+LIB_DEPENDS= libjpeg.so:${PORTSDIR}/graphics/jpeg \
+ libpng15.so:${PORTSDIR}/graphics/png \
+ libgif.so:${PORTSDIR}/graphics/giflib
-USE_BZIP2= yes
+USES= tar:bzip2
USE_EFL= imlib2
USE_GL= glut
WRKSRC= ${WRKDIR}/sviewgl-src
@@ -26,13 +26,10 @@ MAKE_ARGS= CC=${CXX}
PLIST_FILES= bin/sviewgl
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
-
post-patch:
@${REINPLACE_CMD} -e 's,-O2,${CFLAGS}, ; s,/usr/include,${LOCALBASE}/include,g ; \
s,=-s,=-L${LOCALBASE}/lib,' ${WRKSRC}/Makefile
do-install:
- ${INSTALL_PROGRAM} ${WRKSRC}/sviewgl ${PREFIX}/bin
+ ${INSTALL_PROGRAM} ${WRKSRC}/sviewgl ${STAGEDIR}${PREFIX}/bin
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>