aboutsummaryrefslogtreecommitdiff
path: root/graphics/simpleviewer
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-18 17:40:29 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2017-05-18 17:40:29 +0000
commitca5013d665ef9ce30a046c017c374559694b9e38 (patch)
treeb6bde1c59f38cb0e908bccc7748751432831f8be /graphics/simpleviewer
parentc8ef2cd917ea61b0cf2e70d06206158068b903d4 (diff)
downloadports-ca5013d665ef9ce30a046c017c374559694b9e38.tar.gz
ports-ca5013d665ef9ce30a046c017c374559694b9e38.zip
- Update `graphics/simpleviewer' to version 2.92, the latest to date
- Explain why the DISTNAME lacks embedded ${PORTNAME} and hence the need for using DIST_SUBDIR (common case for Bitbucket-hosted projects) - Remove patches: all of them were integrated or reworked upstream - Enable OpenEXR support; there's no way to disable the check, thus doing so prevents unregistered dependency if user has it is installed already - Add missing `xinerama' to USE_XORG (notified by `stage-qa' check) - Minor wording improvement in the port description text while I'm here
Notes
Notes: svn path=/head/; revision=441188
Diffstat (limited to 'graphics/simpleviewer')
-rw-r--r--graphics/simpleviewer/Makefile14
-rw-r--r--graphics/simpleviewer/distinfo6
-rw-r--r--graphics/simpleviewer/files/patch-CMakeLists.txt18
-rw-r--r--graphics/simpleviewer/files/patch-sanitize-fontsize38
-rw-r--r--graphics/simpleviewer/files/patch-src_common_config.cpp10
-rw-r--r--graphics/simpleviewer/files/patch-src_viewer.cpp10
-rw-r--r--graphics/simpleviewer/pkg-descr2
7 files changed, 11 insertions, 87 deletions
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index e7b8f29e7d2e..ecd4ee77fa96 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -2,19 +2,19 @@
# $FreeBSD$
PORTNAME= simpleviewer
-PORTVERSION= 2.88
-PORTREVISION= 1
+PORTVERSION= 2.92
CATEGORIES= graphics
MASTER_SITES= https://bitbucket.org/andreyu/simple-viewer-gl/get/
-DISTNAME= v${PORTVERSION}
-DIST_SUBDIR= ${PORTNAME}
+DISTNAME= v${PORTVERSION} # version tag, thus no embedded ${PORTNAME}
+DIST_SUBDIR= ${PORTNAME} # and hence the need for ${DIST_SUBDIR}
MAINTAINER= ports@FreeBSD.org
COMMENT= Small and simple OpenGL image viewer with transparency support
LICENSE= GPLv2
-LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
+LIB_DEPENDS= libIlmImf.so:graphics/OpenEXR \
+ libImlib2.so:graphics/imlib2 \
libexif.so:graphics/libexif \
libfreetype.so:print/freetype2 \
libgif.so:graphics/giflib \
@@ -26,9 +26,9 @@ LIB_DEPENDS= libImlib2.so:graphics/imlib2 \
USES= cmake compiler:c++11-lang jpeg pkgconfig tar:bzip2
USE_GL= glu
-USE_XORG= ice sm x11 xcursor xext xrandr xxf86vm
+USE_XORG= ice sm x11 xcursor xext xinerama xrandr xxf86vm
-WRKSRC= ${WRKDIR}/andreyu-simple-viewer-gl-b9266979237d
+WRKSRC= ${WRKDIR}/andreyu-simple-viewer-gl-b3bd8710e176
PLIST_FILES= bin/sviewgl
diff --git a/graphics/simpleviewer/distinfo b/graphics/simpleviewer/distinfo
index d58f47ee9360..b5f12c77665f 100644
--- a/graphics/simpleviewer/distinfo
+++ b/graphics/simpleviewer/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1487875449
-SHA256 (simpleviewer/v2.88.tar.bz2) = 4d3835ae008b8a7cdd9379f82e72d338a9d5e3d0cb4ef491d888697727c92c56
-SIZE (simpleviewer/v2.88.tar.bz2) = 238105
+TIMESTAMP = 1494869203
+SHA256 (simpleviewer/v2.92.tar.bz2) = 9d8ff147a932da3f1e627a6e30f63609921b707642c560368396ce7e7b11f91c
+SIZE (simpleviewer/v2.92.tar.bz2) = 290889
diff --git a/graphics/simpleviewer/files/patch-CMakeLists.txt b/graphics/simpleviewer/files/patch-CMakeLists.txt
deleted file mode 100644
index a909743eda24..000000000000
--- a/graphics/simpleviewer/files/patch-CMakeLists.txt
+++ /dev/null
@@ -1,18 +0,0 @@
---- CMakeLists.txt.orig 2017-02-23 18:44:09 UTC
-+++ CMakeLists.txt
-@@ -71,11 +71,11 @@ endif()
-
- file( GLOB_RECURSE SOURCES "src/*.cpp" )
-
--add_executable( sviewgl ${SOURCES} )
-+link_directories(
-+ ${EXIF_LIBRARY_DIRS}
-+ )
-
--#link_directories(
-- #${FREETYPE_LIBRARY_DIRS}
-- #)
-+add_executable( sviewgl ${SOURCES} )
-
- target_link_libraries( sviewgl
- ${RT_LIBRARY}
diff --git a/graphics/simpleviewer/files/patch-sanitize-fontsize b/graphics/simpleviewer/files/patch-sanitize-fontsize
deleted file mode 100644
index 776c2cc32cc5..000000000000
--- a/graphics/simpleviewer/files/patch-sanitize-fontsize
+++ /dev/null
@@ -1,38 +0,0 @@
---- src/exifpopup.cpp.orig 2017-02-23 18:44:09 UTC
-+++ src/exifpopup.cpp
-@@ -32,7 +32,7 @@ void cExifPopup::setRatio(float ratio)
- // if (m_ratio != ratio)
- {
- m_ratio = ratio;
-- const int DesiredFontSize = 26;
-+ const int DesiredFontSize = 16;
- createFont(DesiredFontSize * ratio);
- }
- }
---- src/infobar.cpp.orig 2017-02-23 18:44:09 UTC
-+++ src/infobar.cpp
-@@ -48,11 +48,11 @@ void cInfoBar::setRatio(float scale)
- {
- m_scale = scale;
-
-- const int DesiredFontSize = 30;
-+ const int DesiredFontSize = 16;
- createFont(DesiredFontSize * scale);
- }
-
-- const float DesiredHeight = 36;
-+ const float DesiredHeight = 16 + 6;
- m_height = DesiredHeight * scale;
- }
-
---- src/pixelpopup.cpp.orig 2017-02-23 18:44:09 UTC
-+++ src/pixelpopup.cpp
-@@ -58,7 +58,7 @@ void cPixelPopup::setRatio(float ratio)
- const float Border = 10.0f;
- m_border = Border * ratio;
-
-- const int desiredFontSize = 30;
-+ const int desiredFontSize = 16;
- createFont(desiredFontSize * ratio);
-
- m_ratio = ratio;
diff --git a/graphics/simpleviewer/files/patch-src_common_config.cpp b/graphics/simpleviewer/files/patch-src_common_config.cpp
deleted file mode 100644
index bc00f1ff3990..000000000000
--- a/graphics/simpleviewer/files/patch-src_common_config.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/common/config.cpp.orig 2017-02-23 18:44:09 UTC
-+++ src/common/config.cpp
-@@ -11,6 +11,7 @@
- #include "../viewer.h"
- #include "Ini.h"
-
-+#include <cstdio>
- #include <cstdlib>
- #include <strings.h>
-
diff --git a/graphics/simpleviewer/files/patch-src_viewer.cpp b/graphics/simpleviewer/files/patch-src_viewer.cpp
deleted file mode 100644
index 4907b9c9abf8..000000000000
--- a/graphics/simpleviewer/files/patch-src_viewer.cpp
+++ /dev/null
@@ -1,10 +0,0 @@
---- src/viewer.cpp.orig 2017-02-23 18:44:09 UTC
-+++ src/viewer.cpp
-@@ -345,6 +345,7 @@ void cViewer::fnKeyboard(int key, int /*
- switch (key)
- {
- case GLFW_KEY_ESCAPE:
-+ case GLFW_KEY_Q:
- glfwSetWindowShouldClose(cRenderer::getWindow(), 1);
- break;
-
diff --git a/graphics/simpleviewer/pkg-descr b/graphics/simpleviewer/pkg-descr
index dfff20833305..b9ba38761bb6 100644
--- a/graphics/simpleviewer/pkg-descr
+++ b/graphics/simpleviewer/pkg-descr
@@ -3,7 +3,7 @@ Simple Viewer is small and simple OpenGL based image viewer. Its features:
- Lightweight and fast: utilizes hardware-accelerated video card
- GIF animation, embedded ICC profiles, and Exif tags support
- Very simple interface, minimum dependencies
- - Suitable for default image viewer of desktop
+ - Suitable as default (general-purpose) desktop image viewer
- Desktop independent: does not require any specific desktop environment
- Open source, licensed under GNU GPLv2