aboutsummaryrefslogtreecommitdiff
path: root/graphics/simpleviewer
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-19 16:35:56 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2020-06-19 16:35:56 +0000
commitfda5637ec5b5e44fee5f30ffadca51deacac9723 (patch)
treefd47925d8557ab4b36f4f2c77e315b4839393c96 /graphics/simpleviewer
parent2a3693c671fb8b479cdd28f7dc6e0416f0ec5909 (diff)
downloadports-fda5637ec5b5e44fee5f30ffadca51deacac9723.tar.gz
ports-fda5637ec5b5e44fee5f30ffadca51deacac9723.zip
- Do not build and link against bundled LZ4 library
- Amend JPEG2000 option description and port description
Notes
Notes: svn path=/head/; revision=539668
Diffstat (limited to 'graphics/simpleviewer')
-rw-r--r--graphics/simpleviewer/Makefile5
-rw-r--r--graphics/simpleviewer/files/patch-CMakeLists.txt19
-rw-r--r--graphics/simpleviewer/pkg-descr7
3 files changed, 28 insertions, 3 deletions
diff --git a/graphics/simpleviewer/Makefile b/graphics/simpleviewer/Makefile
index 6b37cf026cf4..49e94474945c 100644
--- a/graphics/simpleviewer/Makefile
+++ b/graphics/simpleviewer/Makefile
@@ -16,6 +16,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libfreetype.so:print/freetype2 \
libglfw.so:graphics/glfw \
+ liblz4.so:archivers/liblz4 \
libpng.so:graphics/png
USES= cmake:insource compiler:c++11-lang gl jpeg pkgconfig \
@@ -66,6 +67,8 @@ WEBP_LIB_DEPENDS= libwebp.so:graphics/webp
WEBP_CMAKE_OFF= -DDISABLE_WEBP_SUPPORT:STRING=1
post-patch:
+ @${REINPLACE_CMD} -e '/#include/s,lz4/,,' \
+ ${WRKSRC}/src/formats/formatage.cpp
@${REINPLACE_CMD} -e 's,%%DATADIR%%,${DATADIR},' \
${WRKSRC}/src/main.cpp
@@ -83,3 +86,5 @@ do-install-EXAMPLES-on:
${INSTALL_DATA} ${WRKSRC}/config.example ${STAGEDIR}${EXAMPLESDIR}
.include <bsd.port.mk>
+
+JPEG2000_DESC+= via OpenJPEG
diff --git a/graphics/simpleviewer/files/patch-CMakeLists.txt b/graphics/simpleviewer/files/patch-CMakeLists.txt
index ae7d97f43135..80beeb9abcd1 100644
--- a/graphics/simpleviewer/files/patch-CMakeLists.txt
+++ b/graphics/simpleviewer/files/patch-CMakeLists.txt
@@ -9,3 +9,22 @@
else()
message(STATUS "* Debug Build *")
add_definitions("-DDEBUG" )
+@@ -316,7 +316,6 @@ endif()
+ message(STATUS "***************************")
+
+ add_subdirectory(third-party/imgui)
+-add_subdirectory(third-party/lz4)
+
+ include_directories("src")
+
+@@ -349,8 +348,8 @@ else()
+ add_executable(sviewgl ${SVIEW_SOURCES})
+ endif()
+
+-add_dependencies(sviewgl ImGui LZ4)
+-target_link_libraries(sviewgl ImGui LZ4)
++add_dependencies(sviewgl ImGui)
++target_link_libraries(sviewgl ImGui lz4)
+
+ if(OPENGL_FOUND)
+ target_link_libraries(sviewgl ${OPENGL_LIBRARY})
diff --git a/graphics/simpleviewer/pkg-descr b/graphics/simpleviewer/pkg-descr
index b9ba38761bb6..b03d62b0b0f3 100644
--- a/graphics/simpleviewer/pkg-descr
+++ b/graphics/simpleviewer/pkg-descr
@@ -1,10 +1,11 @@
Simple Viewer is small and simple OpenGL based image viewer. Its features:
+ - Supported formats: PNG, JPEG, PSD, XCF, SVG, GIF, TIFF, TARGA,
+ ICO, BMP, PNM, DDS, BMP, XWD, SCR (ZX-Spectrum screen), XPM, WebP
- Lightweight and fast: utilizes hardware-accelerated video card
- GIF animation, embedded ICC profiles, and Exif tags support
- - Very simple interface, minimum dependencies
+ - Very simple interface, minimum dependencies, does not require any
+ specific desktop environment
- Suitable as default (general-purpose) desktop image viewer
- - Desktop independent: does not require any specific desktop environment
- - Open source, licensed under GNU GPLv2
WWW: https://bitbucket.org/andreyu/simple-viewer-gl