aboutsummaryrefslogtreecommitdiff
path: root/graphics/sng
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:08:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2014-06-27 14:08:51 +0000
commitf3aa64f50bbb0a6534e33ffde1934e1182184e1d (patch)
tree8f23372c8c91de3d5749cfd7c8a79d10e0e063a3 /graphics/sng
parent0e437a90edd8b6f90e8fd339c691c81779abf915 (diff)
downloadports-f3aa64f50bbb0a6534e33ffde1934e1182184e1d.tar.gz
ports-f3aa64f50bbb0a6534e33ffde1934e1182184e1d.zip
Notes
Diffstat (limited to 'graphics/sng')
-rw-r--r--graphics/sng/Makefile7
-rw-r--r--graphics/sng/distinfo4
-rw-r--r--graphics/sng/files/patch-sng.h10
-rw-r--r--graphics/sng/files/patch-sngc.c10
-rw-r--r--graphics/sng/files/patch-sngd.c37
-rw-r--r--graphics/sng/pkg-descr2
6 files changed, 19 insertions, 51 deletions
diff --git a/graphics/sng/Makefile b/graphics/sng/Makefile
index bf64dba9e6cd..e2a6dc1c35c5 100644
--- a/graphics/sng/Makefile
+++ b/graphics/sng/Makefile
@@ -2,12 +2,11 @@
# $FreeBSD$
PORTNAME= sng
-PORTVERSION= 1.0.5
-PORTREVISION= 1
+PORTVERSION= 1.0.6
CATEGORIES= graphics
-MASTER_SITES= SF/${PORTNAME}/${PORTVERSION}/
+MASTER_SITES= SF/${PORTNAME}/
-MAINTAINER= ports@FreeBSD.org
+MAINTAINER= ports@robakdesign.com
COMMENT= Compiler/decompiler for Scriptable Network Graphics
BUILD_DEPENDS= ${LOCALBASE}/lib/X11/rgb.txt:${PORTSDIR}/x11/rgb
diff --git a/graphics/sng/distinfo b/graphics/sng/distinfo
index c787d043f6e8..17bed811235c 100644
--- a/graphics/sng/distinfo
+++ b/graphics/sng/distinfo
@@ -1,2 +1,2 @@
-SHA256 (sng-1.0.5.tar.gz) = 533839f659c44e8c50137011a9bdcb174a2080ad8f470ebfa150cc722b7eed49
-SIZE (sng-1.0.5.tar.gz) = 118893
+SHA256 (sng-1.0.6.tar.gz) = 0657c821fd92ff4ccedc4a353ecef0c2d89b24d421cf515fc49a2e04b130d513
+SIZE (sng-1.0.6.tar.gz) = 130592
diff --git a/graphics/sng/files/patch-sng.h b/graphics/sng/files/patch-sng.h
new file mode 100644
index 000000000000..b5f1e2cb42d8
--- /dev/null
+++ b/graphics/sng/files/patch-sng.h
@@ -0,0 +1,10 @@
+--- sng.h.orig 2014-06-05 17:01:34.835466603 +0100
++++ sng.h 2014-06-05 17:02:02.186256070 +0100
+@@ -1,5 +1,7 @@
+ /* sng.h -- interface to the SNG compiler */
+
++#include "libpng15/pngpriv.h"
++
+ typedef struct color_item_t
+ {
+ unsigned char r, g, b;
diff --git a/graphics/sng/files/patch-sngc.c b/graphics/sng/files/patch-sngc.c
deleted file mode 100644
index 14992c786307..000000000000
--- a/graphics/sng/files/patch-sngc.c
+++ /dev/null
@@ -1,10 +0,0 @@
---- sngc.c.orig 2010-11-05 18:29:14.000000000 +0100
-+++ sngc.c 2012-05-04 07:33:36.000000000 +0200
-@@ -11,6 +11,7 @@
- #include <ctype.h>
- #define PNG_INTERNAL
- #include "png.h"
-+#include "pngpriv.h"
-
- #include "sng.h"
-
diff --git a/graphics/sng/files/patch-sngd.c b/graphics/sng/files/patch-sngd.c
index 559068050313..d30759b4c24b 100644
--- a/graphics/sng/files/patch-sngd.c
+++ b/graphics/sng/files/patch-sngd.c
@@ -1,14 +1,6 @@
---- sngd.c.orig 2012-05-04 08:20:04.000000000 +0200
-+++ sngd.c 2012-05-04 08:42:54.000000000 +0200
-@@ -10,6 +10,7 @@
- #define PNG_INTERNAL
- #include "config.h" /* for RGBTXT */
- #include "png.h"
-+#include "pngpriv.h"
- #include "sng.h"
-
- png_structp png_ptr;
-@@ -726,8 +727,8 @@
+--- sngd.c.orig 2014-06-05 17:02:15.635246968 +0100
++++ sngd.c 2014-06-05 17:02:31.866045210 +0100
+@@ -738,8 +738,8 @@
}
#ifdef PNG_FLOATING_POINT_SUPPORTED
#ifndef MNG_INTERFACE
@@ -19,26 +11,3 @@
#else
fprintf(fpout, " width: %g\n", info_ptr->scal.pixel_width);
fprintf(fpout, " height: %g\n", info_ptr->scal.pixel_height);
-@@ -794,17 +795,17 @@
- fprintf(fpout, "tRNS {\n");
- switch (info_ptr->color_type) {
- case PNG_COLOR_TYPE_GRAY:
-- fprintf(fpout, " gray: %u;\n", info_ptr->trans_values.gray);
-+ fprintf(fpout, " gray: %u;\n", info_ptr->trans_color.gray);
- break;
- case PNG_COLOR_TYPE_RGB:
- fprintf(fpout, " red: %u; green: %u; blue: %u;\n",
-- info_ptr->trans_values.red,
-- info_ptr->trans_values.green,
-- info_ptr->trans_values.blue);
-+ info_ptr->trans_color.red,
-+ info_ptr->trans_color.green,
-+ info_ptr->trans_color.blue);
- break;
- case PNG_COLOR_TYPE_PALETTE:
- for (i = 0; i < info_ptr->num_trans; i++)
-- fprintf(fpout, " %u", info_ptr->trans[i]);
-+ fprintf(fpout, " %u", info_ptr->trans_alpha[i]);
- break;
- case PNG_COLOR_TYPE_GRAY_ALPHA:
- case PNG_COLOR_TYPE_RGB_ALPHA:
diff --git a/graphics/sng/pkg-descr b/graphics/sng/pkg-descr
index 949be2fc3f93..9e0933e6019f 100644
--- a/graphics/sng/pkg-descr
+++ b/graphics/sng/pkg-descr
@@ -5,4 +5,4 @@ view and edit exotic PNG chunks not supported by graphics editors; also,
since SNG is easy to generate from scripts, sng may be useful at the end
of a pipeline that programmatically generates PNG images.
-WWW: http://sng.sourceforge.net/
+WWW: http://sng.sourceforge.net