aboutsummaryrefslogtreecommitdiff
path: root/graphics/ssocr
diff options
context:
space:
mode:
authorEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-01 13:44:34 +0000
committerEmanuel Haupt <ehaupt@FreeBSD.org>2016-12-01 13:44:34 +0000
commitba78f16f46ce90bec2b3e7df6590e0cccab716a8 (patch)
treefb715e5d881a55ccbf80a49ef4c81c5575c79eae /graphics/ssocr
parenta5718b5cd7b0ecf75ecb0b9f25e81fbc55cb02e1 (diff)
downloadports-ba78f16f46ce90bec2b3e7df6590e0cccab716a8.tar.gz
ports-ba78f16f46ce90bec2b3e7df6590e0cccab716a8.zip
Add ssocr 2.16.3, a CLI to recognize digits of a seven segment display.
Notes
Notes: svn path=/head/; revision=427500
Diffstat (limited to 'graphics/ssocr')
-rw-r--r--graphics/ssocr/Makefile27
-rw-r--r--graphics/ssocr/distinfo3
-rw-r--r--graphics/ssocr/files/patch-Makefile10
-rw-r--r--graphics/ssocr/pkg-descr7
4 files changed, 47 insertions, 0 deletions
diff --git a/graphics/ssocr/Makefile b/graphics/ssocr/Makefile
new file mode 100644
index 000000000000..3a6104919b72
--- /dev/null
+++ b/graphics/ssocr/Makefile
@@ -0,0 +1,27 @@
+# Created by: Emanuel Haupt <ehaupt@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= ssocr
+PORTVERSION= 2.16.3
+CATEGORIES= graphics
+MASTER_SITES= http://www.unix-ag.uni-kl.de/~auerswal/ssocr/ \
+ LOCAL/ehaupt
+
+MAINTAINER= ehaupt@FreeBSD.org
+COMMENT= CLI to recognize digits of a seven segment display
+
+LICENSE= GPLv3
+LICENSE_FILE= ${WRKSRC}/COPYING
+
+LIB_DEPENDS= libImlib2.so:graphics/imlib2
+
+USES= tar:bzip2 gmake
+
+PLIST_FILES= bin/ssocr man/man1/ssocr.1.gz
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${PREFIX}/bin ${STAGEDIR}${MANPREFIX}/man/man1
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_MAN} ${WRKSRC}/${PORTNAME}.1 ${STAGEDIR}${MAN1PREFIX}/man/man1
+
+.include <bsd.port.mk>
diff --git a/graphics/ssocr/distinfo b/graphics/ssocr/distinfo
new file mode 100644
index 000000000000..20d836eaafd1
--- /dev/null
+++ b/graphics/ssocr/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1480597440
+SHA256 (ssocr-2.16.3.tar.bz2) = 915ca0d5871ac8eb67b8445c94a9b6fbf8640052b5a855b0fa32f33575936a0d
+SIZE (ssocr-2.16.3.tar.bz2) = 33542
diff --git a/graphics/ssocr/files/patch-Makefile b/graphics/ssocr/files/patch-Makefile
new file mode 100644
index 000000000000..719fe732b533
--- /dev/null
+++ b/graphics/ssocr/files/patch-Makefile
@@ -0,0 +1,10 @@
+--- Makefile.orig 2016-12-01 13:14:44 UTC
++++ Makefile
+@@ -1,5 +1,5 @@
+-CFLAGS := -D_FORTIFY_SOURCE=2 -Wall -W -Wextra -pedantic -Werror -pedantic-errors $(shell imlib2-config --cflags) -O3
+-LDLIBS := -lm $(shell imlib2-config --libs)
++CFLAGS += -D_FORTIFY_SOURCE=2 $(shell imlib2-config --cflags)
++LDLIBS += -lm $(shell imlib2-config --libs)
+ PREFIX := /usr/local
+ BINDIR := $(PREFIX)/bin
+ MANDIR := $(PREFIX)/share/man/man1
diff --git a/graphics/ssocr/pkg-descr b/graphics/ssocr/pkg-descr
new file mode 100644
index 000000000000..7feae1f5ff1b
--- /dev/null
+++ b/graphics/ssocr/pkg-descr
@@ -0,0 +1,7 @@
+Seven Segment Optical Character Recognition or ssocr for short is a program to
+recognize digits of a seven segment display. An image of one row of digits is
+used for input and the recognized number is written to the standard output. The
+program runs on GNU/Linux, Mac OS X (using Homebrew to install Imlib2), and even
+on Windows (using Cygwin). It uses Imlib2 to access image data.
+
+WWW: https://www.unix-ag.uni-kl.de/~auerswal/ssocr/