aboutsummaryrefslogtreecommitdiff
path: root/graphics/sswf/Makefile
diff options
context:
space:
mode:
authorEric Anholt <anholt@FreeBSD.org>2005-10-17 08:47:32 +0000
committerEric Anholt <anholt@FreeBSD.org>2005-10-17 08:47:32 +0000
commitc0039ba7ab9151b76e2492e4dcddb0c7f779e561 (patch)
treeea3e4805b826edb5ade4db573bab24c06d545315 /graphics/sswf/Makefile
parentd4ef594a6c80a474a96065c2c8b3eb1b82a88a20 (diff)
downloadports-c0039ba7ab9151b76e2492e4dcddb0c7f779e561.tar.gz
ports-c0039ba7ab9151b76e2492e4dcddb0c7f779e561.zip
Notes
Diffstat (limited to 'graphics/sswf/Makefile')
-rw-r--r--graphics/sswf/Makefile28
1 files changed, 28 insertions, 0 deletions
diff --git a/graphics/sswf/Makefile b/graphics/sswf/Makefile
new file mode 100644
index 000000000000..b13e762c61b9
--- /dev/null
+++ b/graphics/sswf/Makefile
@@ -0,0 +1,28 @@
+# Ports collection makefile for: sswf
+# Date created: Oct 17, 2005
+# Whom: anhot
+#
+# $FreeBSD$
+#
+
+PORTNAME= sswf
+PORTVERSION= 1.7.2
+CATEGORIES= graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= sswf
+DISTNAME= sswf-${PORTVERSION}-src
+
+MAINTAINER= anholt@FreeBSD.org
+COMMENT= A library and script language tool to create Flash movies
+
+LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg
+
+WRKSRC= ${WRKDIR}/sswf-${PORTVERSION}
+USE_ICONV= yes
+GNU_CONFIGURE= yes
+INSTALLS_SHLIB= yes
+USE_LIBTOOL_VER=15
+CFLAGS+= -I${LOCALBASE}/include
+CONFIGURE_ENV= LDFLAGS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>