aboutsummaryrefslogtreecommitdiff
path: root/graphics/svgbob
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-08-14 10:53:15 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-08-14 10:53:15 +0000
commit024d6916f9a805387a7b2d7ebffca6e633692b45 (patch)
tree9e8151603ee9e7cb2d5d9683df5a4ac01fd2e102 /graphics/svgbob
parent8e857624db774ce3291df3ee24220834242a3060 (diff)
Notes
Diffstat (limited to 'graphics/svgbob')
-rw-r--r--graphics/svgbob/Makefile3
-rw-r--r--graphics/svgbob/files/patch-src_main.rs41
2 files changed, 3 insertions, 41 deletions
diff --git a/graphics/svgbob/Makefile b/graphics/svgbob/Makefile
index 2b8a043f73f7..7213b9042786 100644
--- a/graphics/svgbob/Makefile
+++ b/graphics/svgbob/Makefile
@@ -41,6 +41,9 @@ CARGO_CRATES= ansi_term-0.11.0 \
winapi-i686-pc-windows-gnu-0.4.0 \
winapi-x86_64-pc-windows-gnu-0.4.0
+# ignore #![deny(warnings)]
+RUSTFLAGS+= --cap-lints warn
+
WRKSRC_SUBDIR= svgbob_cli
PLIST_FILES= bin/svgbob
diff --git a/graphics/svgbob/files/patch-src_main.rs b/graphics/svgbob/files/patch-src_main.rs
deleted file mode 100644
index 9e48588b27aa..000000000000
--- a/graphics/svgbob/files/patch-src_main.rs
+++ /dev/null
@@ -1,41 +0,0 @@
-error: the item `exit` is imported redundantly
- --> src/main.rs:86:25
- |
-16 | use std::process::exit;
- | ------------------ the item `exit` is already imported here
-...
-86 | use std::process::exit;
- | ^^^^^^^^^^^^^^^^^^
- |
-
---- src/main.rs.orig 2019-04-12 08:16:01 UTC
-+++ src/main.rs
-@@ -1,4 +1,3 @@
--#![deny(warnings)]
- #[macro_use]
- extern crate clap;
-
-@@ -83,7 +82,6 @@ fn main() {
- }
- Err(e) => {
- use std::io::Write;
-- use std::process::exit;
-
- writeln!(
- &mut std::io::stderr(),
-@@ -124,7 +122,6 @@ fn main() {
- if let Some(file) = args.value_of("output") {
- if let Err(e) = svg::save(file, &svg) {
- use std::io::Write;
-- use std::process::exit;
-
- writeln!(
- &mut std::io::stderr(),
-@@ -148,7 +145,6 @@ where
- Ok(a) => Some(a),
- Err(e) => {
- use std::io::Write;
-- use std::process::exit;
-
- writeln!(
- &mut std::io::stderr(),