aboutsummaryrefslogtreecommitdiff
path: root/graphics/swappy
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-06-25 04:24:02 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-06-25 04:24:02 +0000
commit2beea6a9fecdfe98252f323fa3ae06129d8b7cd5 (patch)
tree64ea50e1a69eeddb4f265ee5e0fcd9d39c9db6f3 /graphics/swappy
parenta3a00447708a786f0a3401b331870fe3569cfaad (diff)
downloadports-2beea6a9fecdfe98252f323fa3ae06129d8b7cd5.tar.gz
ports-2beea6a9fecdfe98252f323fa3ae06129d8b7cd5.zip
x11/swappy: move to graphics/
Notes
Notes: svn path=/head/; revision=540367
Diffstat (limited to 'graphics/swappy')
-rw-r--r--graphics/swappy/Makefile41
-rw-r--r--graphics/swappy/distinfo9
-rw-r--r--graphics/swappy/pkg-descr5
3 files changed, 55 insertions, 0 deletions
diff --git a/graphics/swappy/Makefile b/graphics/swappy/Makefile
new file mode 100644
index 000000000000..c0cc3068e15c
--- /dev/null
+++ b/graphics/swappy/Makefile
@@ -0,0 +1,41 @@
+# $FreeBSD$
+
+PORTNAME= swappy
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.1.0
+CATEGORIES= graphics
+
+PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
+PATCHFILES+= b59700f47085.patch:-p1 # https://github.com/jtheoof/swappy/pull/42
+PATCHFILES+= f82390dcec74.patch:-p1 # https://github.com/jtheoof/swappy/pull/42
+PATCHFILES+= d7df51363873.patch:-p1 # https://github.com/jtheoof/swappy/pull/42
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Snapshot editing for Wayland (a la Snappy on macOS)
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= compiler:c11 gnome meson pkgconfig
+USE_GITHUB= yes
+USE_GNOME= cairo gdkpixbuf2 gtk30
+GH_ACCOUNT= jtheoof
+PLIST_FILES= bin/${PORTNAME}
+
+OPTIONS_DEFINE= CLIPBOARD ICONSFONT MANPAGES NOTIFY
+OPTIONS_DEFAULT=CLIPBOARD ICONSFONT MANPAGES NOTIFY
+
+CLIPBOARD_DESC= Copy to clipboard support
+CLIPBOARD_RUN_DEPENDS= wl-copy:x11/wl-clipboard
+
+ICONSFONT_DESC= Install Font Awesome to properly render icons
+ICONSFONT_RUN_DEPENDS= font-awesome>0:x11-fonts/font-awesome
+
+MANPAGES_BUILD_DEPENDS= scdoc:textproc/scdoc
+MANPAGES_MESON_ENABLED= man-pages
+MANPAGES_PLIST_FILES= man/man1/${PORTNAME}.1.gz
+
+NOTIFY_LIB_DEPENDS= libnotify.so:devel/libnotify
+NOTIFY_MESON_ENABLED= libnotify
+
+.include <bsd.port.mk>
diff --git a/graphics/swappy/distinfo b/graphics/swappy/distinfo
new file mode 100644
index 000000000000..e31838e8e1cf
--- /dev/null
+++ b/graphics/swappy/distinfo
@@ -0,0 +1,9 @@
+TIMESTAMP = 1592881518
+SHA256 (jtheoof-swappy-v1.1.0_GH0.tar.gz) = b17cd548209947f10c4f8391f2a9dd4de16544abda00fc2290b4fd3815d70a50
+SIZE (jtheoof-swappy-v1.1.0_GH0.tar.gz) = 644656
+SHA256 (b59700f47085.patch) = 3569b4b290256124c253736448fa53f98ac908eadf1a39ed74e0c1bd3bf0e26b
+SIZE (b59700f47085.patch) = 717
+SHA256 (f82390dcec74.patch) = d77b60de58eefae58e8bdc95bdd8ebb418c13b1f841c1522d2262b36a4a919ba
+SIZE (f82390dcec74.patch) = 1116
+SHA256 (d7df51363873.patch) = 98d0a1ea34145bba6640c9ba191abe7c7ecba921c07d1413db3ff6a926aa25e5
+SIZE (d7df51363873.patch) = 2355
diff --git a/graphics/swappy/pkg-descr b/graphics/swappy/pkg-descr
new file mode 100644
index 000000000000..3176b63283f7
--- /dev/null
+++ b/graphics/swappy/pkg-descr
@@ -0,0 +1,5 @@
+A Wayland native snapshot and editor tool, inspired by Snappy on
+macOS. Works great with grim, slurp and sway. But can easily work with
+other screen copy tools that can output a final PNG image to stdout.
+
+WWW: https://github.com/jtheoof/swappy