aboutsummaryrefslogtreecommitdiff
path: root/graphics/swfmill
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-02-01 05:28:00 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-02-01 05:28:00 +0000
commit1f3a193b8f0c76d7f3394cc9a652696e1d195c02 (patch)
tree6ff8044a980df8f013c1ad2071d94b1fb5d072f1 /graphics/swfmill
parent63e76b312d355bd9593fbd6d33ddc357e1c6261b (diff)
downloadports-1f3a193b8f0c76d7f3394cc9a652696e1d195c02.tar.gz
ports-1f3a193b8f0c76d7f3394cc9a652696e1d195c02.zip
graphics/swfmill: unbreak with clang 4.0
gSWFParseXML.cpp:19:10: error: ordered comparison between pointer and zero ('iconv_t' (aka '__tag_iconv_t *') and 'int') if (cd < 0) { ~~ ^ ~ gSWFWriteXML.cpp:15:10: error: ordered comparison between pointer and zero ('iconv_t' (aka '__tag_iconv_t *') and 'int') if (cd < 0) { ~~ ^ ~ Reported by: antoine (via exp-run)
Notes
Notes: svn path=/head/; revision=432981
Diffstat (limited to 'graphics/swfmill')
-rw-r--r--graphics/swfmill/Makefile2
-rw-r--r--graphics/swfmill/files/patch-src_codegen_parsexml.xsl11
-rw-r--r--graphics/swfmill/files/patch-src_codegen_writexml.xsl11
3 files changed, 23 insertions, 1 deletions
diff --git a/graphics/swfmill/Makefile b/graphics/swfmill/Makefile
index ab1f3bd7f961..69d6f42836ea 100644
--- a/graphics/swfmill/Makefile
+++ b/graphics/swfmill/Makefile
@@ -3,7 +3,7 @@
PORTNAME= swfmill
PORTVERSION= 0.3.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= graphics
MASTER_SITES= http://swfmill.org/releases/
diff --git a/graphics/swfmill/files/patch-src_codegen_parsexml.xsl b/graphics/swfmill/files/patch-src_codegen_parsexml.xsl
new file mode 100644
index 000000000000..15222ae2e414
--- /dev/null
+++ b/graphics/swfmill/files/patch-src_codegen_parsexml.xsl
@@ -0,0 +1,11 @@
+--- src/codegen/parsexml.xsl.orig 2013-10-30 17:33:35 UTC
++++ src/codegen/parsexml.xsl
+@@ -19,7 +19,7 @@ char *fromXmlChar(const Context *ctx, co
+ if (ctx-&gt;convertEncoding) {
+ size_t len = strlen((const char *)from_str);
+ iconv_t cd = iconv_open(ctx-&gt;swf_encoding, "UTF-8");
+- if (cd &lt; 0) {
++ if (cd == NULL) {
+ fprintf(stderr, "iconv_open failed.\n");
+ char *buf = new char[1];
+ buf[0] = '\0';
diff --git a/graphics/swfmill/files/patch-src_codegen_writexml.xsl b/graphics/swfmill/files/patch-src_codegen_writexml.xsl
new file mode 100644
index 000000000000..48f689e25996
--- /dev/null
+++ b/graphics/swfmill/files/patch-src_codegen_writexml.xsl
@@ -0,0 +1,11 @@
+--- src/codegen/writexml.xsl.orig 2013-10-30 17:33:35 UTC
++++ src/codegen/writexml.xsl
+@@ -15,7 +15,7 @@ xmlChar *toXmlChar(const Context *ctx, c
+ if (ctx-&gt;convertEncoding) {
+ size_t len = strlen(from_str);
+ iconv_t cd = iconv_open("UTF-8", ctx-&gt;swf_encoding);
+- if (cd &lt; 0) {
++ if (cd == NULL) {
+ fprintf(stderr, "iconv_open failed.\n");
+ return xmlCharStrdup("");
+ }