aboutsummaryrefslogtreecommitdiff
path: root/graphics/swftools/Makefile
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2005-03-02 05:32:02 +0000
committerMichael Johnson <ahze@FreeBSD.org>2005-03-02 05:32:02 +0000
commit39fc922b37a143210a6e6d00f2495c3860fce254 (patch)
tree9bd212e002d5b42cb416a9f6dc86cc2ceb901ac0 /graphics/swftools/Makefile
parent39bd1e45ecce60f64f66714013c749bf316ba577 (diff)
downloadports-39fc922b37a143210a6e6d00f2495c3860fce254.tar.gz
ports-39fc922b37a143210a6e6d00f2495c3860fce254.zip
Notes
Diffstat (limited to 'graphics/swftools/Makefile')
-rw-r--r--graphics/swftools/Makefile17
1 files changed, 12 insertions, 5 deletions
diff --git a/graphics/swftools/Makefile b/graphics/swftools/Makefile
index 894b14ff4c96..874dd0dfe836 100644
--- a/graphics/swftools/Makefile
+++ b/graphics/swftools/Makefile
@@ -7,16 +7,16 @@
#
PORTNAME= swftools
-PORTVERSION= 0.6.2
+PORTVERSION= 0.6.3
CATEGORIES= graphics
MASTER_SITES= http://www.quiss.org/swftools/
MAINTAINER= ports@FreeBSD.org
COMMENT= SWF manipulation and generation utilities
-LIB_DEPENDS= mp3lame.0:${PORTSDIR}/audio/lame \
- t1.5:${PORTSDIR}/devel/t1lib \
+LIB_DEPENDS= t1.5:${PORTSDIR}/devel/t1lib \
jpeg.9:${PORTSDIR}/graphics/jpeg \
+ ungif.5:${PORTSDIR}/graphics/libungif \
freetype.9:${PORTSDIR}/print/freetype2 \
fontconfig.1:${PORTSDIR}/x11-fonts/fontconfig
@@ -27,14 +27,21 @@ GNU_CONFIGURE= yes
CONFIGURE_TARGET= --build=${MACHINE_ARCH}-portbld-freebsd${OSREL}
CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}" LDFLAGS="${LDFLAGS}"
-MAN1= font2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 swfbbox.1 swfc.1 \
- swfcombine.1 swfdump.1 swfextract.1 swfstrings.1 wav2swf.1
+MAN1= font2swf.1 gif2swf.1 jpeg2swf.1 pdf2swf.1 png2swf.1 \
+ swfbbox.1 swfc.1 swfcombine.1 swfdump.1 swfextract.1 \
+ swfstrings.1 wav2swf.1
CPPFLAGS= `pkg-config --cflags-only-I fontconfig freetype2` \
-I${LOCALBASE}/include
LDFLAGS= `pkg-config --libs-only-L fontconfig freetype2` \
-L${LOCALBASE}/lib
+.if defined(WITH_LAME) || exists(${LOCALBASE}/lib/libmp3lame.a)
+LIB_DEPENDS+= mp3lame.0:${PORTSDIR}/audio/lame
+.else
+CONFIGURE_ARGS+= --disable-lame
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's| -O | |g ; \
s|/usr/local/include|${LOCALBASE}/include|g ; \