aboutsummaryrefslogtreecommitdiff
path: root/graphics/tesseract
diff options
context:
space:
mode:
authorPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-06 15:00:54 +0000
committerPiotr Kubaj <pkubaj@FreeBSD.org>2019-12-06 15:00:54 +0000
commit536e266abd563e71c0c2a220a7d9e59f04e712e5 (patch)
tree14c0f4ce222a65ab302015a2b6bd509173cbffe0 /graphics/tesseract
parentb337db09164bbde1e84aabd630bbe0475999a4b3 (diff)
downloadports-536e266abd563e71c0c2a220a7d9e59f04e712e5.tar.gz
ports-536e266abd563e71c0c2a220a7d9e59f04e712e5.zip
graphics/tesseract: fix libomp dependency
Use devel/openmp only on 12.0. PR: 242292 Submitted by: jonc@chen.org.nz
Notes
Notes: svn path=/head/; revision=519148
Diffstat (limited to 'graphics/tesseract')
-rw-r--r--graphics/tesseract/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/tesseract/Makefile b/graphics/tesseract/Makefile
index b79ecbff6b08..8b27baf13077 100644
--- a/graphics/tesseract/Makefile
+++ b/graphics/tesseract/Makefile
@@ -44,13 +44,18 @@ OPTIONS_DEFAULT_i386=OPENMP
OPTIONS_SUB= yes
OPENMP_CONFIGURE_ENABLE=openmp
-OPENMP_LIB_DEPENDS=libomp.so:devel/openmp
TOOLS_DESC= Include training tools
TOOLS_LIB_DEPENDS=libicui18n.so:devel/icu \
libfontconfig.so:x11-fonts/fontconfig
TOOLS_USE= GNOME=cairo,glib20,pango
+.include <bsd.port.pre.mk>
+
+.if ${OSREL:R} >= 12 && ${OSVERSION} < 1201000
+OPENMP_LIB_DEPENDS=libomp.so:devel/openmp
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|-O3 -DNDEBUG||' ${WRKSRC}/configure.ac
@@ -64,4 +69,4 @@ post-install-DOCS-on:
post-install-TOOLS-on:
@cd ${WRKSRC} && ${MAKE} DESTDIR=${STAGEDIR} training-install
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>