aboutsummaryrefslogtreecommitdiff
path: root/graphics/tifmerge
diff options
context:
space:
mode:
authorAlex Kozlov <ak@FreeBSD.org>2013-02-19 09:13:07 +0000
committerAlex Kozlov <ak@FreeBSD.org>2013-02-19 09:13:07 +0000
commit71e273895fca2bf18dae4c108a644cbb29d4f008 (patch)
treef477f6bbe92956247e4fcc541e1c3fd7a16db310 /graphics/tifmerge
parentf548a5333b935f2429e4247040e4e42c185ee557 (diff)
downloadports-71e273895fca2bf18dae4c108a644cbb29d4f008.tar.gz
ports-71e273895fca2bf18dae4c108a644cbb29d4f008.zip
- Use USE_DOS2UNIX [1]
- Use NO_WRKSUBDIR [1] - Switch to PLIST_FILES - General Makefile improvements PR: ports/176194 [1] Submitted by: Christoph Mallon <christoph.mallon@gmx.de>
Notes
Notes: svn path=/head/; revision=312548
Diffstat (limited to 'graphics/tifmerge')
-rw-r--r--graphics/tifmerge/Makefile26
-rw-r--r--graphics/tifmerge/files/Makefile2
-rw-r--r--graphics/tifmerge/pkg-plist4
3 files changed, 15 insertions, 17 deletions
diff --git a/graphics/tifmerge/Makefile b/graphics/tifmerge/Makefile
index 1c243471a944..86e26ee71333 100644
--- a/graphics/tifmerge/Makefile
+++ b/graphics/tifmerge/Makefile
@@ -1,12 +1,9 @@
-# New ports collection makefile for: tifmerge
-# Date created: 29 April 1999
-# Whom: G. Adam Stanislav <adam@whizkidtech.net>
-#
+# Created by: G. Adam Stanislav <adam@whizkidtech.net>
# $FreeBSD$
-#
PORTNAME= tifmerge
PORTVERSION= 1.0
+PORTREVISION= 1
CATEGORIES= graphics
MASTER_SITES= http://www.whizkidtech.redprince.net/fports/
DISTNAME= tiff
@@ -14,26 +11,31 @@ DISTNAME= tiff
MAINTAINER= ports@FreeBSD.org
COMMENT= Library to merge TIFF files into multi-page TIFF files
-EXTRACT_DEPENDS= tuc:${PORTSDIR}/converters/tuc
-
+USE_DOS2UNIX= *.[ch]
USE_LDCONFIG= yes
USE_ZIP= yes
+NO_WRKSUBDIR= yes
DIST_SUBDIR= tifmerge
+
+PLIST_FILES= lib/libtifmerge.a \
+ include/tifmerge.h \
+ lib/libtifmerge.so \
+ lib/libtifmerge.so.1
+
MAN3= tifmerge.3
post-extract:
- @${MKDIR} ${WRKSRC}
- @tuc ${WRKDIR}/TIFMERGE.H ${WRKSRC}/tifmerge.h
- @tuc ${WRKDIR}/TIFMERGE.C ${WRKSRC}/tifmerge.c
+ @${MV} ${WRKSRC}/TIFMERGE.H ${WRKSRC}/tifmerge.h
+ @${MV} ${WRKSRC}/TIFMERGE.C ${WRKSRC}/tifmerge.c
@${CP} ${FILESDIR}/Makefile ${WRKSRC}
@${SED} -e 's|@PREFIX@|${PREFIX}|g' ${FILESDIR}/tifmerge.3 > \
${WRKSRC}/tifmerge.3
do-install:
- ${INSTALL_DATA} ${WRKSRC}/libtifmerge.so.1 ${PREFIX}/lib
+ ${INSTALL_LIB} ${WRKSRC}/libtifmerge.so.1 ${PREFIX}/lib
${LN} -fs ${PREFIX}/lib/libtifmerge.so.1 ${PREFIX}/lib/libtifmerge.so
${INSTALL_DATA} ${WRKSRC}/libtifmerge.a ${PREFIX}/lib
${INSTALL_DATA} ${WRKSRC}/tifmerge.h ${PREFIX}/include
- ${INSTALL_DATA} ${WRKSRC}/tifmerge.3 ${PREFIX}/man/man3
+ ${INSTALL_MAN} ${WRKSRC}/tifmerge.3 ${MAN3PREFIX}/man/man3
.include <bsd.port.mk>
diff --git a/graphics/tifmerge/files/Makefile b/graphics/tifmerge/files/Makefile
index 143ef1a520d5..a508cf6dad6e 100644
--- a/graphics/tifmerge/files/Makefile
+++ b/graphics/tifmerge/files/Makefile
@@ -2,7 +2,7 @@ LIB= tifmerge
SHLIB_MAJOR= 1
SHLIB_MINOR= 0
-NOPROFILE= yes
+NO_PROFILE= yes
SRCS= tifmerge.c
diff --git a/graphics/tifmerge/pkg-plist b/graphics/tifmerge/pkg-plist
deleted file mode 100644
index f2bf248d0117..000000000000
--- a/graphics/tifmerge/pkg-plist
+++ /dev/null
@@ -1,4 +0,0 @@
-include/tifmerge.h
-lib/libtifmerge.a
-lib/libtifmerge.so
-lib/libtifmerge.so.1