aboutsummaryrefslogtreecommitdiff
path: root/graphics/timeless
diff options
context:
space:
mode:
authorJohn Marino <marino@FreeBSD.org>2014-07-05 19:15:41 +0000
committerJohn Marino <marino@FreeBSD.org>2014-07-05 19:15:41 +0000
commit3d1b7d9e5448aa037558521193225af85b71c455 (patch)
treedda573c015329ad03b6dd29c596e752f5b6e968f /graphics/timeless
parent47bd638a443e6057aba40cf758a2573b1128a483 (diff)
downloadports-3d1b7d9e5448aa037558521193225af85b71c455.tar.gz
ports-3d1b7d9e5448aa037558521193225af85b71c455.zip
graphics/timeless: stage and explicit linking with -lm (dports)
Notes
Notes: svn path=/head/; revision=360804
Diffstat (limited to 'graphics/timeless')
-rw-r--r--graphics/timeless/Makefile9
1 files changed, 7 insertions, 2 deletions
diff --git a/graphics/timeless/Makefile b/graphics/timeless/Makefile
index 99ef4874a435..ff9324d53341 100644
--- a/graphics/timeless/Makefile
+++ b/graphics/timeless/Makefile
@@ -12,9 +12,14 @@ MAINTAINER= ports@FreeBSD.org
COMMENT= FreeBSD/SDL port of Tran's Timeless Demo with Sound
USE_SDL= sdl mixer
+LDFLAGS+= -lm
-PLIST_FILES= bin/${PORTNAME} %%DATADIR%%/time.s3m
+PLIST_FILES= bin/timeless %%DATADIR%%/time.s3m
PLIST_DIRS= %%DATADIR%%
-NO_STAGE= yes
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}
+ ${INSTALL_PROGRAM} ${WRKSRC}/timeless ${STAGEDIR}${PREFIX}/bin
+ ${INSTALL_DATA} ${WRKSRC}/time.s3m ${STAGEDIR}${DATADIR}
+
.include <bsd.port.mk>