aboutsummaryrefslogtreecommitdiff
path: root/graphics/timg
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-15 14:40:28 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2021-03-15 14:40:28 +0000
commit8efbe89c6e4be1b4643516b5fd510b3e93bacf73 (patch)
treeda5a57328ad5e4a927db5870636a956800b73980 /graphics/timg
parent47a026edac0cbca36fe433558e888aabae5f18c5 (diff)
downloadports-8efbe89c6e4be1b4643516b5fd510b3e93bacf73.tar.gz
ports-8efbe89c6e4be1b4643516b5fd510b3e93bacf73.zip
graphics/timg: update to 1.2.0
ChangeLog: https://github.com/hzeller/timg/releases/tag/v1.2.0 PR: 254304 Submitted by: uzsolt@uzsolt.hu (maintainer)
Notes
Notes: svn path=/head/; revision=568461
Diffstat (limited to 'graphics/timg')
-rw-r--r--graphics/timg/Makefile25
-rw-r--r--graphics/timg/distinfo6
-rw-r--r--graphics/timg/files/patch-Makefile21
-rw-r--r--graphics/timg/files/patch-timg.cc28
-rw-r--r--graphics/timg/pkg-descr11
5 files changed, 24 insertions, 67 deletions
diff --git a/graphics/timg/Makefile b/graphics/timg/Makefile
index 9999cf891018..ea48220e34e5 100644
--- a/graphics/timg/Makefile
+++ b/graphics/timg/Makefile
@@ -1,27 +1,32 @@
# $FreeBSD$
PORTNAME= timg
-PORTVERSION= 0.9.8
+PORTVERSION= 1.2.0
DISTVERSIONPREFIX= v
CATEGORIES= graphics
MAINTAINER= uzsolt@uzsolt.hu
-COMMENT= Terminal Image Viewer
+COMMENT= Terminal Image and Video Viewer
LICENSE= GPLv2
-LIB_DEPENDS= libMagick++-6.so:graphics/ImageMagick6
+BUILD_DEPENDS= pkgconf>0:devel/pkgconf \
+ ffmpeg>0:multimedia/ffmpeg
+LIB_DEPENDS= libavutil.so:multimedia/ffmpeg \
+ libexif.so:graphics/libexif \
+ libGraphicsMagick.so:graphics/GraphicsMagick \
+ libpng16.so:graphics/png \
+ libturbojpeg.so:graphics/libjpeg-turbo
-USES= compiler:c++11-lang gmake
+USES= cmake compiler:c++11-lang
USE_GITHUB= yes
GH_ACCOUNT= hzeller
-ALL_TARGET= ${PORTNAME}
-WRKSRC_SUBDIR= src
+# timg requires libavutil, contained in multimedia/ffmpeg
+# isn't splitted libavcodec, libavutil, etc.
+CMAKE_ON+= WITH_VIDEO_DECODING WITH_VIDEO_DEVICE
+CMAKE_OFF+= TIMG_VERSION_FROM_GIT
-PLIST_FILES= bin/timg
-
-post-install:
- @${STRIP_CMD} ${STAGEDIR}${PREFIX}/bin/${PORTNAME}
+PLIST_FILES= bin/timg man/man1/timg.1.gz
.include <bsd.port.mk>
diff --git a/graphics/timg/distinfo b/graphics/timg/distinfo
index 7b68e17fb724..1f616e67e819 100644
--- a/graphics/timg/distinfo
+++ b/graphics/timg/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1593323068
-SHA256 (hzeller-timg-v0.9.8_GH0.tar.gz) = 436e2c3b5f43e906786ca150d11e521281d558329a7bc00198fe30d6907ee8c4
-SIZE (hzeller-timg-v0.9.8_GH0.tar.gz) = 92611
+TIMESTAMP = 1615796137
+SHA256 (hzeller-timg-v1.2.0_GH0.tar.gz) = b0fa8b4571247833167b73d6fe5aab733160c09f56389b97c9e516d0f0f2a5de
+SIZE (hzeller-timg-v1.2.0_GH0.tar.gz) = 1024378
diff --git a/graphics/timg/files/patch-Makefile b/graphics/timg/files/patch-Makefile
deleted file mode 100644
index 5c6a906279c9..000000000000
--- a/graphics/timg/files/patch-Makefile
+++ /dev/null
@@ -1,21 +0,0 @@
---- Makefile.orig 2020-04-30 05:40:03 UTC
-+++ Makefile
-@@ -1,13 +1,14 @@
--MAGICK_CXXFLAGS=$(shell GraphicsMagick++-config --cppflags)
--MAGICK_LDFLAGS=$(shell GraphicsMagick++-config --ldflags --libs)
--CXXFLAGS=$(MAGICK_CXXFLAGS) -Wall -O3 -fPIC
-+MAGICK_CXXFLAGS=$(shell Magick++-config --cppflags)
-+MAGICK_LDFLAGS=$(shell Magick++-config --ldflags --libs)
-+CXXFLAGS?=-Wall -O3 -fPIC
-+CXXFLAGS+=$(MAGICK_CXXFLAGS)
- PREFIX?=/usr/local
-
- timg : timg.o terminal-canvas.o
- $(CXX) -o $@ $^ $(MAGICK_LDFLAGS)
-
- install: timg
-- install $^ $(PREFIX)/bin
-+ install $^ $(DESTDIR)$(PREFIX)/bin
-
- uninstall:
- rm -f $(PREFIX)/bin/timg
diff --git a/graphics/timg/files/patch-timg.cc b/graphics/timg/files/patch-timg.cc
deleted file mode 100644
index 325db30b9bcb..000000000000
--- a/graphics/timg/files/patch-timg.cc
+++ /dev/null
@@ -1,28 +0,0 @@
---- timg.cc.orig 2020-04-30 05:40:03 UTC
-+++ timg.cc
-@@ -66,9 +66,9 @@ void CopyToCanvas(const Magick::Image &img, TerminalCa
- if (c.alphaQuantum() >= 255)
- continue;
- result->SetPixel(x, y,
-- ScaleQuantumToChar(c.redQuantum()),
-- ScaleQuantumToChar(c.greenQuantum()),
-- ScaleQuantumToChar(c.blueQuantum()));
-+ MagickCore::ScaleQuantumToChar(c.redQuantum()),
-+ MagickCore::ScaleQuantumToChar(c.greenQuantum()),
-+ MagickCore::ScaleQuantumToChar(c.blueQuantum()));
- }
- }
- }
-@@ -271,9 +271,9 @@ void DisplayScrolling(const Magick::Image &img, int sc
- if (src.alphaQuantum() >= 255)
- continue;
- RGBCol &dest = fast_image[y * img_width + x];
-- dest.r = ScaleQuantumToChar(src.redQuantum());
-- dest.g = ScaleQuantumToChar(src.greenQuantum());
-- dest.b = ScaleQuantumToChar(src.blueQuantum());
-+ dest.r = MagickCore::ScaleQuantumToChar(src.redQuantum());
-+ dest.g = MagickCore::ScaleQuantumToChar(src.greenQuantum());
-+ dest.b = MagickCore::ScaleQuantumToChar(src.blueQuantum());
- }
- }
-
diff --git a/graphics/timg/pkg-descr b/graphics/timg/pkg-descr
index cbe247267956..513e7e3b1725 100644
--- a/graphics/timg/pkg-descr
+++ b/graphics/timg/pkg-descr
@@ -1,9 +1,10 @@
-timg - Terminal Image Viewer
+timg - Terminal Image and Video Viewer
-A viewer that uses 24-Bit color capabilities and unicode
-character blocks to display images in the terminal.
-Displays regular images, plays animated gifs or allows to
-scroll static images.
+A user-friendly viewer that uses 24-Bit color capabilities
+and unicode character blocks to display images, animations
+and videos in the terminal.
+Displays regular images, plays animated gifs, scrolls
+static images and plays videos.
Very useful for if you want to have a quick visual check
without starting a bulky image viewer or in an SSH session.