aboutsummaryrefslogtreecommitdiff
path: root/graphics/tkpng/Makefile
diff options
context:
space:
mode:
authorAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:17:49 +0000
committerAndrew Pantyukhin <sat@FreeBSD.org>2006-10-08 11:17:49 +0000
commit6b81740d8e2b9352e1eb21c8e7f5b6b38b600a95 (patch)
treec50609f7880a40bffffc0227ed927ae810ba9bf6 /graphics/tkpng/Makefile
parent5f47704cf648af962a9df101a548023bd4b0a944 (diff)
Notes
Diffstat (limited to 'graphics/tkpng/Makefile')
-rw-r--r--graphics/tkpng/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/tkpng/Makefile b/graphics/tkpng/Makefile
new file mode 100644
index 000000000000..2c681d2f3bb6
--- /dev/null
+++ b/graphics/tkpng/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: tkpng
+# Date created: 08 October 2006
+# Whom: Andrew Pantyukhin <infofarmer@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= tkpng
+PORTVERSION= 0.7
+CATEGORIES= graphics tk84
+MASTER_SITES= SF
+DISTNAME= ${PORTNAME}${PORTVERSION}-src
+EXTRACT_SUFX= .tgz
+
+MAINTAINER= infofarmer@FreeBSD.org
+COMMENT= PNG support for Tcl/Tk
+
+LIB_DEPENDS= tk${USE_TK}.1:${PORTSDIR}/x11-toolkits/tk${USE_TK}
+
+USE_TK= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --with-tcl=${LOCALBASE}/lib/tcl${TK_VER} \
+ --with-tk=${LOCALBASE}/lib/tk${TK_VER} \
+ --with-tclinclude=${LOCALBASE}/include/tcl${TK_VER}/generic \
+ --with-tkinclude=${LOCALBASE}/include/tk${TK_VER}/generic \
+ --exec-prefix=${PREFIX} --enable-shared
+CPPFLAGS= -I${LOCALBASE}/include/tk${TK_VER}/generic -I${X11BASE}/include
+CONFIGURE_ENV= CPPFLAGS="${CPPFLAGS}"
+TKPKG= ${PORTNAME}${PORTVERSION}
+PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG} TKLIBVER=${TKLIBVER}
+USE_LDCONFIG= ${PREFIX}/lib/${TKPKG}
+WRKSRC= ${WRKDIR}/${TKPKG}
+
+post-install:
+ @${LN} -sf ${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so \
+ ${PREFIX}/lib/${TKPKG}/lib${TKPKG}.so.0
+
+.include <bsd.port.mk>