aboutsummaryrefslogtreecommitdiff
path: root/graphics/tkpng
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-10-18 14:03:11 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-10-18 14:03:11 +0000
commit6d551848149df8faadcdccf242b1722b149b5e7f (patch)
treed72781bed9ed7475ec6cf7531386b6c3cc215ab9 /graphics/tkpng
parent8fdb9a217fd4f4a26ac16511b643cd4717577e76 (diff)
downloadports-6d551848149df8faadcdccf242b1722b149b5e7f.tar.gz
ports-6d551848149df8faadcdccf242b1722b149b5e7f.zip
- Convert to USES+=tk
- STAGE-clean - Bring PLIST into Makefile
Notes
Notes: svn path=/head/; revision=330747
Diffstat (limited to 'graphics/tkpng')
-rw-r--r--graphics/tkpng/Makefile19
-rw-r--r--graphics/tkpng/pkg-plist3
2 files changed, 11 insertions, 11 deletions
diff --git a/graphics/tkpng/Makefile b/graphics/tkpng/Makefile
index 05d21a8cb465..79889c01eb40 100644
--- a/graphics/tkpng/Makefile
+++ b/graphics/tkpng/Makefile
@@ -15,18 +15,21 @@ COMMENT= PNG support for Tcl/Tk
LICENSE= BSD
LICENSE_FILE= ${WRKSRC}/license.terms
-USE_TK= 84+
+USES+= tk
GNU_CONFIGURE= yes
-NO_STAGE= yes
-.include <bsd.port.pre.mk>
CONFIGURE_ARGS= --with-tcl=${TCL_LIBDIR} \
--with-tk=${TK_LIBDIR} \
- --with-tclinclude=${TCL_INCLUDEDIR}/generic \
- --with-tkinclude=${TK_INCLUDEDIR}/generic \
- --exec-prefix=${PREFIX} --enable-shared
-CPPFLAGS+= -I${TK_INCLUDEDIR}/generic -I${LOCALBASE}/include
+ --with-tclinclude=${TCL_INCLUDEDIR} \
+ --with-tkinclude=${TK_INCLUDEDIR} \
+ --exec-prefix=${PREFIX} \
+ --enable-shared
+
TKPKG= ${PORTNAME}${PORTVERSION}
PLIST_SUB= VER=${PORTVERSION} TKPKG=${TKPKG} TKLIBVER=${TKLIBVER}
-.include <bsd.port.post.mk>
+PLIST_FILES= lib/${TKPKG}/lib${TKPKG}.so \
+ lib/${TKPKG}/pkgIndex.tcl
+PLIST_DIRS= lib/${TKPKG}
+
+.include <bsd.port.mk>
diff --git a/graphics/tkpng/pkg-plist b/graphics/tkpng/pkg-plist
deleted file mode 100644
index bac026bb8c96..000000000000
--- a/graphics/tkpng/pkg-plist
+++ /dev/null
@@ -1,3 +0,0 @@
-lib/%%TKPKG%%/lib%%TKPKG%%.so
-lib/%%TKPKG%%/pkgIndex.tcl
-@dirrm lib/%%TKPKG%%