aboutsummaryrefslogtreecommitdiff
path: root/graphics/togl
diff options
context:
space:
mode:
authorSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 16:01:31 +0000
committerSatoshi Taoka <taoka@FreeBSD.org>1999-09-24 16:01:31 +0000
commit030edd1b93c9ab19cf1bce82b7a841b55ac7e868 (patch)
tree951b0003784ca3f1da1aa139f30ec9ac587d61b3 /graphics/togl
parent33c11413f4421892ae9cb831369cbb1cdf4ca42e (diff)
downloadports-030edd1b93c9ab19cf1bce82b7a841b55ac7e868.tar.gz
ports-030edd1b93c9ab19cf1bce82b7a841b55ac7e868.zip
An OpenGL Widget for Tk
PR: 13296 Submitted by: Randall Hopper <aa8vb@ipass.net>
Notes
Notes: svn path=/head/; revision=21914
Diffstat (limited to 'graphics/togl')
-rw-r--r--graphics/togl/Makefile33
-rw-r--r--graphics/togl/distinfo1
-rw-r--r--graphics/togl/files/patch-aa50
-rw-r--r--graphics/togl/files/patch-ab11
-rw-r--r--graphics/togl/pkg-comment1
-rw-r--r--graphics/togl/pkg-descr23
-rw-r--r--graphics/togl/pkg-plist4
7 files changed, 123 insertions, 0 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
new file mode 100644
index 000000000000..5238a0a229e4
--- /dev/null
+++ b/graphics/togl/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: Togl
+# Version required: 1.5
+# Date created: Wed Aug 18 18:49:17 EDT 1999
+# Whom: Randall Hopper <aa8vb@ipass.net>
+#
+# $FreeBSD$
+#
+
+DISTNAME= Togl-1.5
+PKGNAME= togl-1.5
+CATEGORIES= graphics tk80
+MASTER_SITES= ftp://ftp.mesa3d.org/mesa/misc/ \
+ ftp://ftp.cs.umd.edu/pub/faculty/bederson/
+
+MAINTAINER= aa8vb@ipass.net
+
+LIB_DEPENDS= tk80.1:${PORTSDIR}/x11-toolkits/tk80 \
+ tcl80.1:${PORTSDIR}/lang/tcl80 \
+ MesaGL.14:${PORTSDIR}/graphics/Mesa3
+
+ALL_TARGET= default
+
+TOGL_INSTDIR= ${PREFIX}/lib/tk8.0/${DISTNAME}
+
+.include <bsd.port.pre.mk>
+
+do-install:
+ ${MKDIR} ${TOGL_INSTDIR}
+ ${INSTALL_DATA} ${WRKSRC}/libtogl.so.1.3 ${TOGL_INSTDIR}/Togl.so
+ ${ECHO} 'package ifneeded Togl 1.5 [list load [file join $$dir Togl.so]]'\
+ > ${PREFIX}/lib/tk8.0/${DISTNAME}/pkgIndex.tcl
+
+.include <bsd.port.post.mk>
diff --git a/graphics/togl/distinfo b/graphics/togl/distinfo
new file mode 100644
index 000000000000..da3e0de20b1c
--- /dev/null
+++ b/graphics/togl/distinfo
@@ -0,0 +1 @@
+MD5 (Togl-1.5.tar.gz) = c1660f93cab49af2fe6bc4e09610bf90
diff --git a/graphics/togl/files/patch-aa b/graphics/togl/files/patch-aa
new file mode 100644
index 000000000000..bc5ff3eef199
--- /dev/null
+++ b/graphics/togl/files/patch-aa
@@ -0,0 +1,50 @@
+--- ORIG/Makefile Wed Mar 11 23:11:26 1998
++++ Makefile Wed Aug 18 18:57:46 1999
+@@ -61,23 +61,28 @@
+ CC = cc
+
+ # Compiler options:
+-COPTS = -c -O
++COPTS = -c -O -w
+
+ # Shared library linker command:
+-SHLINK = cc -G
++SHLINK = cc -shared
+
+ # Name for the shared lib:
+-#SH_LIB = libtogl.so.1.3
+-SH_LIB =
++SH_LIB = libtogl.so.1.3
++#SH_LIB =
+
+-# Where to find tcl.h, tk.h, OpenGL/Mesa headers, etc:
+-INCLUDES = -I/usr/local/include -I/usr/include/tcl
++# Where to find tc.hl, tk.h, OpenGL/Mesa headers, etc:
++INCLUDES = -I/usr/local/include/tcl8.0 \
++ -I/usr/local/include/tk8.0 \
++ -I/usr/local/include/tk8.0/generic \
++ -I/usr/X11R6/include \
++ -I/usr/include/tcl
+
+ # Where to find libtcl.a, libtk.a, OpenGL/Mesa libraries:
+-LIBDIRS = -L/usr/local/lib
++LIBDIRS = -L/usr/local/lib \
++ -L/usr/X11R6/lib
+
+ # Libraries to link with (-ldl for Linux only?):
+-LIBS = -ltk -ltcl -lGLU -lGL -L/usr/X11/lib -lX11 -lXmu -lXext -lXt -lm -ldl
++LIBS = -ltk80 -ltcl80 -lGLU -lGL -lX11 -lXmu -lXext -lXt -lm
+
+ TK_FLAGS =
+
+@@ -144,8 +149,8 @@
+ $(CC) $(CFLAGS) togl.c
+
+
+-#$(SH_LIB): togl.o
+-# $(SHLINK) $(LFLAGS) togl.o $(LIBS) -o $@
++$(SH_LIB): togl.o
++ $(SHLINK) $(LFLAGS) togl.o $(LIBS) -o $@
+
+
+
diff --git a/graphics/togl/files/patch-ab b/graphics/togl/files/patch-ab
new file mode 100644
index 000000000000..2f47b40f9ffa
--- /dev/null
+++ b/graphics/togl/files/patch-ab
@@ -0,0 +1,11 @@
+--- ORIG/togl.c Fri Aug 21 23:06:00 1998
++++ togl.c Wed Aug 18 18:41:24 1999
+@@ -118,7 +118,7 @@
+ #elif TK_MAJOR_VERSION==8 && TK_MINOR_VERSION==0 && TK_RELEASE_SERIAL==2
+ # include "tkInt8.0p2.h"
+ #else
+- Sorry, you will have to edit togl.c to include the right tkInt.h file
++# include "tkInt.h"
+ #endif
+ #elif defined(WIN32)
+ #if TK_MAJOR_VERSION<8
diff --git a/graphics/togl/pkg-comment b/graphics/togl/pkg-comment
new file mode 100644
index 000000000000..580e1040b0d4
--- /dev/null
+++ b/graphics/togl/pkg-comment
@@ -0,0 +1 @@
+A Tk OpenGL widget
diff --git a/graphics/togl/pkg-descr b/graphics/togl/pkg-descr
new file mode 100644
index 000000000000..2c1987b94caa
--- /dev/null
+++ b/graphics/togl/pkg-descr
@@ -0,0 +1,23 @@
+Togl is a Tk widget for OpenGL rendering. Togl is based on OGLTK,
+originally written by Benjamin Bederson at the University of New Mexico
+(who has since moved to the University of Maryland). Togl adds the new
+features:
+ - color-index mode support including color allocation functions
+ - support for requesting stencil, accumulation, alpha buffers, etc
+ - multiple OpenGL drawing widgets
+ - OpenGL extension testing from Tcl
+ - simple, portable font support
+ - overlay plane support
+
+Togl allows one to create and manage a special Tk/OpenGL widget with Tcl
+and render into it with a C program. That is, a typical Togl program will
+have Tcl code for managing the user interface and a C program for
+computations and OpenGL rendering.
+Togl is copyrighted by Brian Paul (brian_paul@avid.com) and Benjamin
+Bederson (bederson@cs.umd.edu). See the LICENSE file for details.
+
+The Togl WWW page is available from:
+ Wisconsin at http://www.mesa3d.org/brianp/Togl.html
+ Maryland at http://www.cs.umd.edu/~bederson/Togl.html
+
+WWW: http://www.mesa3d.org/brianp/Togl.html
diff --git a/graphics/togl/pkg-plist b/graphics/togl/pkg-plist
new file mode 100644
index 000000000000..6bc36d9d7b00
--- /dev/null
+++ b/graphics/togl/pkg-plist
@@ -0,0 +1,4 @@
+lib/tk8.0/Togl-1.5/Togl.so
+lib/tk8.0/Togl-1.5/pkgIndex.tcl
+@dirrm lib/tk8.0/Togl-1.5
+