aboutsummaryrefslogtreecommitdiff
path: root/graphics/togl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-05-25 11:05:59 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-05-25 11:05:59 +0000
commit70ed28d4b8ed06494467d332018d99a5fcdf7507 (patch)
tree0857dbf8c222646cf724c29aa0bc0d4698b57a0f /graphics/togl
parenta3b670146b84d1fb6e33b86a3fe1856395d31ddd (diff)
downloadports-70ed28d4b8ed06494467d332018d99a5fcdf7507.tar.gz
ports-70ed28d4b8ed06494467d332018d99a5fcdf7507.zip
- Append to instead of overwrite CONFIGURE_ARGS
- Fix build with Tk 8.6 - While at it, trim Makefile header and switch to OPTIONSng Reported by: miwi (Tcl/Tk 8.6 exp-run latecomers) Approved by: portmgr
Notes
Notes: svn path=/head/; revision=319044
Diffstat (limited to 'graphics/togl')
-rw-r--r--graphics/togl/Makefile16
1 files changed, 7 insertions, 9 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index 52c03edfe6e5..b77e4d2769f8 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: Togl
-# Date created: Wed Aug 18 18:49:17 EDT 1999
-# Whom: Randall Hopper <aa8vb@ipass.net>
-#
+# Created by: Randall Hopper <aa8vb@ipass.net>
# $FreeBSD$
-#
PORTNAME= togl
PORTVERSION= 1.7
@@ -13,7 +9,7 @@ MASTER_SITES= SF/${PORTNAME}/Togl/${PORTVERSION}
DISTNAME= Togl-${PORTVERSION}
MAINTAINER= ports@FreeBSD.org
-COMMENT= A Tk OpenGL widget
+COMMENT= Tk OpenGL widget
USE_XORG= x11 xt xmu
USE_GL= gl
@@ -23,7 +19,7 @@ USE_TK_BUILD= 84+
USE_TK= 84+
USE_GMAKE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ARGS= --with-tk=${TK_LIBDIR} \
+CONFIGURE_ARGS+=--with-tk=${TK_LIBDIR} \
--with-tcl=${TCL_LIBDIR} \
--with-tclinclude=${TCL_INCLUDEDIR}
MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
@@ -36,6 +32,8 @@ PLIST_SUB= TOGL_INSTDIR="${TOGL_INSTDIR:S,^${PREFIX}/,,}"
CPPFLAGS+= -I${TK_INCLUDEDIR}
LDFLAGS+= -L${TK_LIBDIR}
+.include <bsd.port.options.mk>
+
post-patch:
@${REINPLACE_CMD} -e 's|wish |${WISH:T} |' ${WRKSRC}/*.tcl
@@ -47,11 +45,11 @@ do-install:
${LN} -s ${TOGL_INSTDIR}/libTogl1.7.so ${TOGL_INSTDIR}/libtogl.so.1
${LN} -s ${TOGL_INSTDIR}/libTogl1.7.so ${PREFIX}/lib/libtogl.so
${LN} -s ${TOGL_INSTDIR}/libTogl1.7.so ${PREFIX}/lib/libtogl.so.1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
${INSTALL_DATA} ${WRKSRC}/Togl.html ${DOCSDIR}
.endif
-.if !defined(NOPORTEXAMPLES)
+.if ${PORT_OPTIONS:MEXAMPLES}
@${MKDIR} ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/Makefile ${EXAMPLESDIR}
${INSTALL_DATA} ${WRKSRC}/ben.rgb ${EXAMPLESDIR}