aboutsummaryrefslogtreecommitdiff
path: root/graphics/togl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2013-07-24 06:53:48 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2013-07-24 06:53:48 +0000
commitc4b15c6d2025c2f817013bd98b46e3b1452c1422 (patch)
treeb6a3af48eb564a9ebc61b4fa795af9cf29d239be /graphics/togl
parentc48d9a5373a9fa2c89f0c9bb6ba05ce03e9a9e7e (diff)
downloadports-c4b15c6d2025c2f817013bd98b46e3b1452c1422.tar.gz
ports-c4b15c6d2025c2f817013bd98b46e3b1452c1422.zip
- Make graphics/togl's libraries location independent from the Tcl/Tk version
used to build it - Fix cad/netgen to use this new location Reported by: bapt
Notes
Notes: svn path=/head/; revision=323569
Diffstat (limited to 'graphics/togl')
-rw-r--r--graphics/togl/Makefile10
-rw-r--r--graphics/togl/pkg-plist12
2 files changed, 8 insertions, 14 deletions
diff --git a/graphics/togl/Makefile b/graphics/togl/Makefile
index 7851a6234e73..5d9cb11228c4 100644
--- a/graphics/togl/Makefile
+++ b/graphics/togl/Makefile
@@ -13,21 +13,15 @@ COMMENT= Tk OpenGL widget
USE_XORG= x11 xt xmu
USE_GL= gl
-USE_TCL_BUILD= 84+
-USE_TCL= 84+
-USE_TK_BUILD= 84+
-USE_TK= 84+
+USE_TK= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS+=--with-tk=${TK_LIBDIR} \
--with-tcl=${TCL_LIBDIR} \
--with-tclinclude=${TCL_INCLUDEDIR}
-MAKE_ENV= PTHREAD_LIBS="${PTHREAD_LIBS}" \
- PTHREAD_CFLAGS="${PTHREAD_CFLAGS}"
USE_LDCONFIG= yes
-TOGL_INSTDIR= ${PREFIX}/lib/tk${TK_VER}/${DISTNAME}
-PLIST_SUB= TOGL_INSTDIR="${TOGL_INSTDIR:S,^${PREFIX}/,,}"
+TOGL_INSTDIR= ${PREFIX}/lib/${DISTNAME}
CPPFLAGS+= -I${TK_INCLUDEDIR}
LDFLAGS+= -L${TK_LIBDIR}
diff --git a/graphics/togl/pkg-plist b/graphics/togl/pkg-plist
index 986d7f9aa838..1095ce1f5de3 100644
--- a/graphics/togl/pkg-plist
+++ b/graphics/togl/pkg-plist
@@ -1,10 +1,10 @@
lib/libtogl.so
lib/libtogl.so.1
-lib/tk%%TK_VER%%/Togl-1.7/togl.h
-lib/tk%%TK_VER%%/Togl-1.7/togl_ws.h
-lib/tk%%TK_VER%%/Togl-1.7/libTogl1.7.so
-lib/tk%%TK_VER%%/Togl-1.7/pkgIndex.tcl
-lib/tk%%TK_VER%%/Togl-1.7/libtogl.so.1
+lib/Togl-1.7/togl.h
+lib/Togl-1.7/togl_ws.h
+lib/Togl-1.7/libTogl1.7.so
+lib/Togl-1.7/pkgIndex.tcl
+lib/Togl-1.7/libtogl.so.1
%%PORTDOCS%%%%DOCSDIR%%/Togl.html
%%EXAMPLESDIR%%/Makefile
%%EXAMPLESDIR%%/ben.rgb
@@ -27,4 +27,4 @@ lib/tk%%TK_VER%%/Togl-1.7/libtogl.so.1
%%EXAMPLESDIR%%/tree2.rgba
@dirrm %%EXAMPLESDIR%%
%%PORTDOCS%%@dirrm %%DOCSDIR%%
-@dirrm lib/tk%%TK_VER%%/Togl-1.7
+@dirrm lib/Togl-1.7