aboutsummaryrefslogtreecommitdiff
path: root/graphics/tumble
diff options
context:
space:
mode:
authorFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-07-22 19:45:54 +0000
committerFernando ApesteguĂ­a <fernape@FreeBSD.org>2018-07-22 19:45:54 +0000
commitf3ffeb88decebc1772686e8f94880980a70dcdd7 (patch)
treefe817b912873a005e31a1f01caf154e036fec366 /graphics/tumble
parent4d4db978e31f35cc3b04543127615f3003034e4b (diff)
downloadports-f3ffeb88decebc1772686e8f94880980a70dcdd7.tar.gz
ports-f3ffeb88decebc1772686e8f94880980a70dcdd7.zip
graphics/tumble: Update to 0.36
* Also reorder some sections of the Makefile * Remove patch included in upstream PR: 229917 Reported by: ndowens.fbsd@yandex.com Approved by: tcberner (mentor) Differential Revision: https://reviews.freebsd.org/D16389
Notes
Notes: svn path=/head/; revision=475120
Diffstat (limited to 'graphics/tumble')
-rw-r--r--graphics/tumble/Makefile15
-rw-r--r--graphics/tumble/distinfo5
-rw-r--r--graphics/tumble/files/patch-parser.y20
3 files changed, 11 insertions, 29 deletions
diff --git a/graphics/tumble/Makefile b/graphics/tumble/Makefile
index 3ad99cb3c0e8..19236fd3a7e2 100644
--- a/graphics/tumble/Makefile
+++ b/graphics/tumble/Makefile
@@ -2,11 +2,9 @@
# $FreeBSD$
PORTNAME= tumble
-PORTVERSION= 0.33
-PORTREVISION= 6
+PORTVERSION= 0.36
+DISTVERSIONPREFIX= v
CATEGORIES= graphics print
-MASTER_SITES= http://tumble.brouhaha.com/download/ \
- http://www.sourcefiles.org/Graphics/Tools/Conversion/
MAINTAINER= ports@FreeBSD.org
COMMENT= Creates a PDF file from image files
@@ -14,15 +12,18 @@ COMMENT= Creates a PDF file from image files
LICENSE= GPLv2
LICENSE_FILE= ${WRKSRC}/COPYING
+NOT_FOR_ARCHS= powerpc sparc64
+NOT_FOR_ARCHS_REASON= Only works on little endian systems
+
LIB_DEPENDS= libtiff.so:graphics/tiff \
libnetpbm.so:graphics/netpbm
USES= bison gmake jpeg localbase:ldflags
-CFLAGS+= -I${LOCALBASE}/include/netpbm
+USE_GITHUB= yes
+GH_ACCOUNT= brouhaha
-NOT_FOR_ARCHS= powerpc sparc64
-NOT_FOR_ARCHS_REASON= Only works on little endian systems
+CFLAGS+= -I${LOCALBASE}/include/netpbm
PORTDOCS= README
PLIST_FILES= bin/tumble
diff --git a/graphics/tumble/distinfo b/graphics/tumble/distinfo
index fee9915ef84f..2f5cfef7a8ca 100644
--- a/graphics/tumble/distinfo
+++ b/graphics/tumble/distinfo
@@ -1,2 +1,3 @@
-SHA256 (tumble-0.33.tar.gz) = d579d572b4335d8c4008695fee9f32051194499987c340b14f17b294ece7643e
-SIZE (tumble-0.33.tar.gz) = 42983
+TIMESTAMP = 1532266375
+SHA256 (brouhaha-tumble-v0.36_GH0.tar.gz) = 7b9e0788416b8129203831da7eef5310b671325503e79aa22fd91e822b54b978
+SIZE (brouhaha-tumble-v0.36_GH0.tar.gz) = 51945
diff --git a/graphics/tumble/files/patch-parser.y b/graphics/tumble/files/patch-parser.y
deleted file mode 100644
index 499b51c0e3a6..000000000000
--- a/graphics/tumble/files/patch-parser.y
+++ /dev/null
@@ -1,20 +0,0 @@
---- parser.y.orig 2003-12-09 16:45:41 UTC
-+++ parser.y
-@@ -110,7 +110,7 @@ image_ranges:
-
-
- input_file_clause:
-- FILE_KEYWORD STRING ';' { input_set_file ($2) } ;
-+ FILE_KEYWORD STRING ';' { input_set_file ($2); } ;
-
- image_clause:
- IMAGE INTEGER ';' { range_t range = { $2, $2 }; input_images (range); } ;
-@@ -119,7 +119,7 @@ images_clause:
- IMAGES image_ranges ';' ;
-
- rotate_clause:
-- ROTATE INTEGER ';' { input_set_rotation ($2) } ;
-+ ROTATE INTEGER ';' { input_set_rotation ($2); } ;
-
- unit:
- /* empty */ /* default to INCH */ { $$ = 1.0; }