aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-30 10:14:01 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2011-11-30 10:14:01 +0000
commit0f4c8ffe532f9a8792fff420b58484afdbac59e1 (patch)
tree28c06bf94852ef56f57fd970cd54b9cdd2677b64 /graphics/ufraw
parent803b50bffd0fadad1edb59509b0030b1c933323d (diff)
downloadports-0f4c8ffe532f9a8792fff420b58484afdbac59e1.tar.gz
ports-0f4c8ffe532f9a8792fff420b58484afdbac59e1.zip
Notes
Diffstat (limited to 'graphics/ufraw')
-rw-r--r--graphics/ufraw/Makefile56
-rw-r--r--graphics/ufraw/pkg-plist3
2 files changed, 35 insertions, 24 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index 76aa36322bd7..d6c7637d4d27 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ufraw
PORTVERSION= 0.18
-PORTREVISION= 0
+PORTREVISION= 1
CATEGORIES= graphics gnome
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTNAME}-${PORTVERSION}
@@ -19,13 +19,12 @@ LICENSE= GPLv2
LIB_DEPENDS= jpeg.11:${PORTSDIR}/graphics/jpeg \
tiff.4:${PORTSDIR}/graphics/tiff \
png.6:${PORTSDIR}/graphics/png \
- gtkimageview.0:${PORTSDIR}/x11-toolkits/gtkimageview \
lcms.1:${PORTSDIR}/graphics/lcms
GNU_CONFIGURE= yes
+CONFIGURE_ARGS= --disable-silent-rules --enable-extras
USE_GETTEXT= yes
USE_GMAKE= yes
-USE_GNOME= gtk20 glib20 gnomehack intltool intlhack libartlgpl2 pkgconfig
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib ${PTHREAD_LIBS}
@@ -35,48 +34,59 @@ MAN1= ufraw.1
OPTIONS= CONTRAST "Enable contrast setting" on \
DST "Use local time for timestamps" off \
- EXIV2 "EXIF support via exiv2 library" on \
+ EXIV2 "Enable EXIF support via exiv2 library" on \
+ LENSFUN "Enable LensFun library support" off \
FITS "Enable FITS output support" off \
- GIMP "Install GIMP UFRaw plugin" on \
- LENSFUN "Build with LensFun library support" on
+ GIMP "Install GIMP UFRaw plugin" off \
+ GTK "Build the Gtk+2 GUI" on
.include <bsd.port.pre.mk>
-.if !defined(WITHOUT_EXIV2)
-LIB_DEPENDS+= exiv2.10:${PORTSDIR}/graphics/exiv2
-.else
-PC_FALSE+= exiv2
+.if defined(WITH_CONTRAST)
+CONFIGURE_ARGS+= --enable-contrast
.endif
-.if !defined(WITHOUT_GIMP)
-LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
-PLIST_SUB+= GIMP=""
+.if defined(WITH_DST)
+CONFIGURE_ARGS+= --enable-dst-correction
+.endif
+
+.if defined(WITH_EXIV2)
+LIB_DEPENDS+= exiv2.10:${PORTSDIR}/graphics/exiv2
.else
-PC_FALSE+= gimp
-PLIST_SUB+= GIMP="@comment "
+PC_FALSE+= exiv2
.endif
-.if !defined(WITHOUT_LENSFUN) || exists(${LOCALBASE}/lib/lensfun.so.2)
+.if defined(WITH_LENSFUN)
LIB_DEPENDS+= lensfun.2:${PORTSDIR}/graphics/lensfun
+.else
+PC_FALSE+= lensfun
.endif
-.if defined(WITH_FITS) || exists(${LOCALBASE}/lib/libcfitsio.so)
+.if defined(WITH_FITS)
LIB_DEPENDS+= cfitsio.0:${PORTSDIR}/astro/cfitsio
+.else
+PC_FALSE+= cfitsio
.endif
-.if !defined(WITHOUT_CONTRAST)
-CONFIGURE_ARGS+= --enable-contrast
+.if defined(WITH_GIMP)
+LIB_DEPENDS+= gimp-2.0.0:${PORTSDIR}/graphics/gimp-app
+PLIST_SUB+= GIMP=""
+.else
+PC_FALSE+= gimp
+PLIST_SUB+= GIMP="@comment "
.endif
-.if defined(WITH_DST)
-CONFIGURE_ARGS+= --enable-dst-correction
+.if defined(WITH_GTK)
+LIB_DEPENDS+= gtkimageview.0:${PORTSDIR}/x11-toolkits/gtkimageview
+PLIST_FILES+= bin/ufraw
.endif
post-patch:
@${REINPLACE_CMD} -e '18s|^$$|#include <sys/types.h>|' \
${WRKSRC}/dcraw.h
- @${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir|' \
- ${WRKSRC}/Makefile.in
+# Avoid conflict with `graphics/dcraw' and rename the binary
+ @${REINPLACE_CMD} -e '/@schemasdir/s|datadir|sysconfdir| ; \
+ s|dcraw\$$(EXEEXT)|${PORTNAME}-&|' ${WRKSRC}/Makefile.in
.for i in ${PC_FALSE}
@${REINPLACE_CMD} -e '/PKG_CONFIG.*${i}/s|$$PKG_CONFIG|${FALSE}|' \
${WRKSRC}/configure
diff --git a/graphics/ufraw/pkg-plist b/graphics/ufraw/pkg-plist
index 51e0e690476c..60fa418b5113 100644
--- a/graphics/ufraw/pkg-plist
+++ b/graphics/ufraw/pkg-plist
@@ -1,5 +1,6 @@
-bin/ufraw
+bin/nikon-curve
bin/ufraw-batch
+bin/ufraw-dcraw
%%GIMP%%libexec/gimp/2.2/plug-ins/ufraw-gimp
share/locale/ca/LC_MESSAGES/ufraw.mo
share/locale/cs/LC_MESSAGES/ufraw.mo