aboutsummaryrefslogtreecommitdiff
path: root/graphics/ufraw
diff options
context:
space:
mode:
authorRodrigo Osorio <rodrigo@FreeBSD.org>2018-07-01 21:42:49 +0000
committerRodrigo Osorio <rodrigo@FreeBSD.org>2018-07-01 21:42:49 +0000
commit4c8c252a4c33964daef086565f9c57b31a6ae690 (patch)
treed26d7d0ccb37b5a4c8a739102bd5eefcc63cb8f2 /graphics/ufraw
parent603abc0541331f7e7df414d28e9c4beb51d0b819 (diff)
downloadports-4c8c252a4c33964daef086565f9c57b31a6ae690.tar.gz
ports-4c8c252a4c33964daef086565f9c57b31a6ae690.zip
Fix graphics/ufraw build for 12.0
Fix code issues who causes build failures due to missing spaces between literal and identifier. Bump PORTREVISION. PR: 229271 Submitted by: <w.schwarzenfeld@utanet.at>
Notes
Notes: svn path=/head/; revision=473684
Diffstat (limited to 'graphics/ufraw')
-rw-r--r--graphics/ufraw/Makefile2
-rw-r--r--graphics/ufraw/files/patch-dcraw.cc20
-rw-r--r--graphics/ufraw/files/patch-ufraw__developer.c11
3 files changed, 31 insertions, 2 deletions
diff --git a/graphics/ufraw/Makefile b/graphics/ufraw/Makefile
index a6cc5a7ae7dd..4d5d93d090bb 100644
--- a/graphics/ufraw/Makefile
+++ b/graphics/ufraw/Makefile
@@ -3,7 +3,7 @@
PORTNAME= ufraw
PORTVERSION= 0.22
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= graphics
MAINTAINER= rodrigo@FreeBSD.org
diff --git a/graphics/ufraw/files/patch-dcraw.cc b/graphics/ufraw/files/patch-dcraw.cc
index 14ec6b243335..b0c1fae315fa 100644
--- a/graphics/ufraw/files/patch-dcraw.cc
+++ b/graphics/ufraw/files/patch-dcraw.cc
@@ -1,4 +1,4 @@
---- dcraw.cc.orig 2018-04-03 22:16:35 UTC
+--- dcraw.cc.orig 2018-06-23 21:54:05 UTC
+++ dcraw.cc
@@ -2287,7 +2287,7 @@ void CLASS quicktake_100_load_raw()
@@ -21,3 +21,21 @@
if (!(pix & 1) && HOLE(pix / raw_width)) pix += 2;
}
maximum = 0xff;
+@@ -8946,7 +8949,7 @@ void CLASS identify()
+ parse_fuji (get4());
+ if (thumb_offset > 120) {
+ fseek (ifp, 120, SEEK_SET);
+- is_raw += (i = get4()) && 1;
++ is_raw += (i = get4()) & 1;
+ if (is_raw == 2 && shot_select)
+ parse_fuji (i);
+ }
+@@ -10192,7 +10195,7 @@ void CLASS tiff_head (struct tiff_hdr *t
+ strncpy (th->desc, desc, 512);
+ strncpy (th->make, make, 64);
+ strncpy (th->model, model, 64);
+- strcpy (th->soft, "dcraw v"DCRAW_VERSION);
++ strcpy (th->soft, " dcraw v " DCRAW_VERSION);
+ t = localtime (&timestamp);
+ sprintf (th->date, "%04d:%02d:%02d %02d:%02d:%02d",
+ t->tm_year+1900,t->tm_mon+1,t->tm_mday,t->tm_hour,t->tm_min,t->tm_sec);
diff --git a/graphics/ufraw/files/patch-ufraw__developer.c b/graphics/ufraw/files/patch-ufraw__developer.c
new file mode 100644
index 000000000000..5e1e08163ee3
--- /dev/null
+++ b/graphics/ufraw/files/patch-ufraw__developer.c
@@ -0,0 +1,11 @@
+--- ufraw_developer.c.orig 2018-06-23 21:40:09 UTC
++++ ufraw_developer.c
+@@ -387,7 +387,7 @@ static double findExpCoeff(double b)
+ else a = b;
+ bg = a / (1 - exp(-a));
+ /* The limit on try is just to be sure there is no infinite loop. */
+- for (try = 0; abs(bg - b) > 0.001 || try < 100; try++) {
++ for (try = 0; fabs(bg - b) > 0.001 || try < 100; try++) {
+ a = a + (b - bg);
+ bg = a / (1 - exp(-a));
+ }