aboutsummaryrefslogtreecommitdiff
path: root/graphics/variety
diff options
context:
space:
mode:
authorMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
committerMathieu Arnold <mat@FreeBSD.org>2017-11-30 15:50:30 +0000
commit551be3c7231225ed9c26479af2b8914fb2ef0ea8 (patch)
treed296c82a71504382f4faefa0bf8d7be384ea1105 /graphics/variety
parent02f9c9be1699251467efc027f210049dfe14f9c5 (diff)
downloadports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.tar.gz
ports-551be3c7231225ed9c26479af2b8914fb2ef0ea8.zip
Convert Python ports to FLAVORS.
Ports using USE_PYTHON=distutils are now flavored. They will automatically get flavors (py27, py34, py35, py36) depending on what versions they support. There is also a USE_PYTHON=flavors for ports that do not use distutils but need FLAVORS to be set. A USE_PYTHON=noflavors can be set if using distutils but flavors are not wanted. A new USE_PYTHON=optsuffix that will add PYTHON_PKGNAMESUFFIX has been added to cope with Python ports that did not have the Python PKGNAMEPREFIX but are flavored. USES=python now also exports a PY_FLAVOR variable that contains the current python flavor. It can be used in dependency lines when the port itself is not python flavored. For example, deskutils/calibre. By default, all the flavors are generated. To only generate flavors for the versions in PYTHON2_DEFAULT and PYTHON3_DEFAULT, define BUILD_DEFAULT_PYTHON_FLAVORS in your make.conf. In all the ports with Python dependencies, the *_DEPENDS entries MUST end with the flavor so that the framework knows which to build/use. This is done by appending '@${PY_FLAVOR}' after the origin (or @${FLAVOR} if in a Python module with Python flavors, as the content will be the same). For example: RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}six>0:devel/py-six@${PY_FLAVOR} PR: 223071 Reviewed by: portmgr, python Sponsored by: Absolight Differential Revision: https://reviews.freebsd.org/D12464
Notes
Notes: svn path=/head/; revision=455210
Diffstat (limited to 'graphics/variety')
-rw-r--r--graphics/variety/Makefile24
1 files changed, 12 insertions, 12 deletions
diff --git a/graphics/variety/Makefile b/graphics/variety/Makefile
index 05e811ae91f2..c960c72f4ccb 100644
--- a/graphics/variety/Makefile
+++ b/graphics/variety/Makefile
@@ -14,19 +14,19 @@ COMMENT= Wallpaper changer
LICENSE= GPLv3
-BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.38:devel/py-python-distutils-extra \
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}python-distutils-extra>=2.38:devel/py-python-distutils-extra@${FLAVOR} \
intltool-update:textproc/intltool
-RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.3.2:www/py-beautifulsoup \
- ${PYTHON_PKGNAMEPREFIX}cairo>=1.10.0:graphics/py-cairo \
- ${PYTHON_PKGNAMEPREFIX}configobj>=5.0.6:devel/py-configobj \
- ${PYTHON_PKGNAMEPREFIX}pycurl>=7.19.5.1:ftp/py-pycurl \
- ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1_1:devel/py-dbus \
- ${PYTHON_PKGNAMEPREFIX}exiv2>=0.3.2_3:graphics/py-exiv2 \
- ${PYTHON_PKGNAMEPREFIX}gobject3>=3.14.0:devel/py-gobject3 \
- ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9:www/py-httplib2 \
- ${PYTHON_PKGNAMEPREFIX}pillow>=2.6.0:graphics/py-pillow \
- ${PYTHON_PKGNAMEPREFIX}lxml>=3.4.1_1:devel/py-lxml \
- ${PYTHON_PKGNAMEPREFIX}six>=1.8.0:devel/py-six \
+RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}beautifulsoup>=4.3.2:www/py-beautifulsoup@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}cairo>=1.10.0:graphics/py-cairo@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}configobj>=5.0.6:devel/py-configobj@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pycurl>=7.19.5.1:ftp/py-pycurl@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}dbus>=1.1.1_1:devel/py-dbus@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}exiv2>=0.3.2_3:graphics/py-exiv2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}gobject3>=3.14.0:devel/py-gobject3@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}httplib2>=0.9:www/py-httplib2@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}pillow>=2.6.0:graphics/py-pillow@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}lxml>=3.4.1_1:devel/py-lxml@${FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}six>=1.8.0:devel/py-six@${FLAVOR} \
ImageMagick>=6.9.0.4,1:graphics/ImageMagick \
bash>=4.3.33:shells/bash \
ca_root_nss>=3.17.4:security/ca_root_nss \