aboutsummaryrefslogtreecommitdiff
path: root/graphics/vigra
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-12-11 02:16:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-12-11 02:16:35 +0000
commit582861072cfab6232c8b5c4fd487a0cd84714311 (patch)
tree4c406134005292648d2558381c00a60294c0127a /graphics/vigra
parent5442a613d436707f81fea1c5735657d6452c4e84 (diff)
downloadports-582861072cfab6232c8b5c4fd487a0cd84714311.tar.gz
ports-582861072cfab6232c8b5c4fd487a0cd84714311.zip
graphics/vigra: unbreak consumers on 10.* for NUMPY=on
Passing -std=gnu++11 also matches Boost since r450557. /usr/local/lib/libvigraimpex.so: undefined reference to `operator delete(void*, unsigned int)' Reported by: antoine (via bug 223922 -exp run) Submitted by: rakuco (adapted from bug 219484 fix)
Notes
Notes: svn path=/head/; revision=455917
Diffstat (limited to 'graphics/vigra')
-rw-r--r--graphics/vigra/Makefile8
1 files changed, 7 insertions, 1 deletions
diff --git a/graphics/vigra/Makefile b/graphics/vigra/Makefile
index f6c3b63156d5..deae337e1e99 100644
--- a/graphics/vigra/Makefile
+++ b/graphics/vigra/Makefile
@@ -3,7 +3,7 @@
PORTNAME= vigra
DISTVERSION= 1.11.0
-PORTREVISION= 16
+PORTREVISION= 17
CATEGORIES= graphics
PATCH_SITES= https://github.com/${GH_ACCOUNT}/${GH_PROJECT}/commit/
@@ -50,6 +50,12 @@ NUMPY_BUILD_DEPENDS= nosetests:devel/py-nose \
NUMPY_RUN_DEPENDS= nosetests:devel/py-nose \
f2py:math/py-numpy
NUMPY_LIB_DEPENDS= libboost_python.so:devel/boost-python-libs
+# On FreeBSD < 11 libc++ lacks support for sized delete operators.
+# GCC dropped the builtin version of these operators in 6+ by
+# defaulting to gnu++14. Force c++11 instead.
+# For a more detailed discussion see:
+# https://bugs.freebsd.org/bugzilla/show_bug.cgi?id=219484
+NUMPY_CXXFLAGS= -std=gnu++11
PNG_CMAKE_BOOL= WITH_PNG
PNG_LIB_DPEENDS= libpng.so:graphics/png