aboutsummaryrefslogtreecommitdiff
path: root/graphics/vulkan-caps-viewer
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-09-01 00:59:31 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-09-01 00:59:31 +0000
commitf4861732341f8674383ef01101bbc514633ff779 (patch)
tree9268653d6b79f06a08992249ffa5c54d36798316 /graphics/vulkan-caps-viewer
parent1ba8cfdcdc11e2d1008bd9c316052602172c3d78 (diff)
downloadports-f4861732341f8674383ef01101bbc514633ff779.tar.gz
ports-f4861732341f8674383ef01101bbc514633ff779.zip
graphics/vulkan-caps-viewer: add new port
Client application to display hardware implementation details for GPUs supporting the new Vulkan API by Khronos. The hardware reports can be submitted to a public online database that allows comparing different devices, browsing available features, extensions, formats, etc. https://vulkan.gpuinfo.org/
Notes
Notes: svn path=/head/; revision=547227
Diffstat (limited to 'graphics/vulkan-caps-viewer')
-rw-r--r--graphics/vulkan-caps-viewer/Makefile53
-rw-r--r--graphics/vulkan-caps-viewer/distinfo5
-rw-r--r--graphics/vulkan-caps-viewer/pkg-descr8
3 files changed, 66 insertions, 0 deletions
diff --git a/graphics/vulkan-caps-viewer/Makefile b/graphics/vulkan-caps-viewer/Makefile
new file mode 100644
index 000000000000..dec196c99cd0
--- /dev/null
+++ b/graphics/vulkan-caps-viewer/Makefile
@@ -0,0 +1,53 @@
+# $FreeBSD$
+
+PORTNAME= vulkan-caps-viewer
+DISTVERSION= 2.2
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Vulkan Hardware Capability Viewer
+
+LICENSE= LGPL3 # based on license headers
+
+LIB_DEPENDS= libvulkan.so:graphics/vulkan-loader
+
+USES= compiler:c++14-lang pkgconfig qmake qt:5
+USE_GITHUB= yes
+USE_QT= qmake_build buildtools_build core gui network widgets
+GH_ACCOUNT= SaschaWillems
+GH_PROJECT= VulkanCapsViewer
+GH_TUPLE= KhronosGroup:Vulkan-Headers:v1.2.148-1-ga0f1f51:vkheaders/Vulkan-Headers
+LDFLAGS+= -Wl,--as-needed # avoid overlinking (GL, wayland)
+PLIST_FILES= bin/vulkanCapsViewer \
+ share/applications/vulkanCapsViewer.desktop \
+ share/icons/hicolor/256x256/apps/vulkanCapsViewer.png
+
+OPTIONS_DEFINE= WAYLAND X11
+OPTIONS_DEFAULT=WAYLAND X11
+
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland
+WAYLAND_USE= QT=wayland_build
+
+X11_USE= QT=x11extras
+
+post-patch:
+# Hint qmake how to install generated file
+ @${CP} ${WRKSRC}/gfx/android_icon_256.png \
+ ${WRKSRC}/vulkanCapsViewer.png
+# Avoid platform whitelists for generic non-Windows code
+ @${REINPLACE_CMD} -Ee 's/linux/unix/' \
+ -e '/bin|share/s,/usr,$$$$PREFIX,' \
+ ${WRKSRC}/vulkanCapsViewer.pro
+ @${REINPLACE_CMD} -e 's/__linux/__unix/' \
+ ${WRKSRC}/vulkancapsviewer.cpp \
+ ${WRKSRC}/Vulkan-Headers/include/vulkan/vulkan.hpp
+
+post-patch-WAYLAND-off:
+ @${REINPLACE_CMD} -i .nowayland '/qtHave/s/wayland/DISABLED&/' \
+ ${WRKSRC}/vulkanCapsViewer.pro
+
+post-patch-X11-off:
+ @${REINPLACE_CMD} -i .nox11 '/qtHave/s/x11/DISABLED&/' \
+ ${WRKSRC}/vulkanCapsViewer.pro
+
+.include <bsd.port.mk>
diff --git a/graphics/vulkan-caps-viewer/distinfo b/graphics/vulkan-caps-viewer/distinfo
new file mode 100644
index 000000000000..706dedc35cb3
--- /dev/null
+++ b/graphics/vulkan-caps-viewer/distinfo
@@ -0,0 +1,5 @@
+TIMESTAMP = 1596303729
+SHA256 (SaschaWillems-VulkanCapsViewer-2.2_GH0.tar.gz) = dd3b2ea1701585989af25735ed7341e9ffa7fbce97c3c1108fee97dc47e75e47
+SIZE (SaschaWillems-VulkanCapsViewer-2.2_GH0.tar.gz) = 827790
+SHA256 (KhronosGroup-Vulkan-Headers-v1.2.148-1-ga0f1f51_GH0.tar.gz) = 385971b93ce17c525de3cb3848069b569ad8e88a63252f36eb56378716e6e9af
+SIZE (KhronosGroup-Vulkan-Headers-v1.2.148-1-ga0f1f51_GH0.tar.gz) = 784080
diff --git a/graphics/vulkan-caps-viewer/pkg-descr b/graphics/vulkan-caps-viewer/pkg-descr
new file mode 100644
index 000000000000..1e1fe7174b19
--- /dev/null
+++ b/graphics/vulkan-caps-viewer/pkg-descr
@@ -0,0 +1,8 @@
+Client application to display hardware implementation details for GPUs
+supporting the new Vulkan API by Khronos.
+
+The hardware reports can be submitted to a public online database that
+allows comparing different devices, browsing available features,
+extensions, formats, etc.
+
+WWW: https://vulkan.gpuinfo.org/