aboutsummaryrefslogtreecommitdiff
path: root/graphics/vulkan-headers
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-12-23 20:12:14 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-12-23 20:12:14 +0000
commit8d2b2a2768019f243226836085a7808e469bd0b1 (patch)
tree54d3e64a25e92ecb389a9e72cff496e30d672de8 /graphics/vulkan-headers
parentbd5a415767e994a7e91270887bd9b2b5605ab08b (diff)
downloadports-8d2b2a2768019f243226836085a7808e469bd0b1.tar.gz
ports-8d2b2a2768019f243226836085a7808e469bd0b1.zip
devel/vulkan-*: move to graphics/ where vulkan-loader is
Vulkan isn't used for generic compute workloads unlike OpenCL. For example, waifu2x-ncnn-vulkan is still graphics-related.
Notes
Notes: svn path=/head/; revision=559022
Diffstat (limited to 'graphics/vulkan-headers')
-rw-r--r--graphics/vulkan-headers/Makefile20
-rw-r--r--graphics/vulkan-headers/distinfo3
-rw-r--r--graphics/vulkan-headers/files/patch-include_vulkan_vulkan.hpp56
-rw-r--r--graphics/vulkan-headers/pkg-descr5
-rw-r--r--graphics/vulkan-headers/pkg-plist30
5 files changed, 114 insertions, 0 deletions
diff --git a/graphics/vulkan-headers/Makefile b/graphics/vulkan-headers/Makefile
new file mode 100644
index 000000000000..72de9dc6b359
--- /dev/null
+++ b/graphics/vulkan-headers/Makefile
@@ -0,0 +1,20 @@
+# $FreeBSD$
+
+PORTNAME= vulkan-headers
+DISTVERSIONPREFIX=v
+DISTVERSION= 1.2.165
+CATEGORIES= graphics
+
+MAINTAINER= jbeich@FreeBSD.org
+COMMENT= Headers for the Vulkan graphics API
+
+LICENSE= APACHE20
+
+USES= cmake
+STRIP= # nothing to strip
+
+USE_GITHUB= yes
+GH_ACCOUNT= KhronosGroup
+GH_PROJECT= Vulkan-Headers
+
+.include <bsd.port.mk>
diff --git a/graphics/vulkan-headers/distinfo b/graphics/vulkan-headers/distinfo
new file mode 100644
index 000000000000..1840c3f1b1a3
--- /dev/null
+++ b/graphics/vulkan-headers/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1607927667
+SHA256 (KhronosGroup-Vulkan-Headers-v1.2.165_GH0.tar.gz) = 3f9435a93ba13d94d0c3265a47e0436579e46bb9ca085e9b16a753458e4d79d2
+SIZE (KhronosGroup-Vulkan-Headers-v1.2.165_GH0.tar.gz) = 861347
diff --git a/graphics/vulkan-headers/files/patch-include_vulkan_vulkan.hpp b/graphics/vulkan-headers/files/patch-include_vulkan_vulkan.hpp
new file mode 100644
index 000000000000..4639220cd3ac
--- /dev/null
+++ b/graphics/vulkan-headers/files/patch-include_vulkan_vulkan.hpp
@@ -0,0 +1,56 @@
+--- include/vulkan/vulkan.hpp.orig 2020-12-07 12:15:47 UTC
++++ include/vulkan/vulkan.hpp
+@@ -67,7 +67,7 @@
+ #endif
+
+ #if VULKAN_HPP_ENABLE_DYNAMIC_LOADER_TOOL == 1
+-# if defined( __linux__ ) || defined( __APPLE__ )
++# if defined( __unix__ ) || defined( __APPLE__ )
+ # include <dlfcn.h>
+ # elif defined( _WIN32 )
+ typedef struct HINSTANCE__ * HINSTANCE;
+@@ -92754,7 +92754,7 @@ namespace VULKAN_HPP_NAMESPACE
+ {
+ if ( !vulkanLibraryName.empty() )
+ {
+-# if defined( __linux__ ) || defined( __APPLE__ )
++# if defined( __unix__ ) || defined( __APPLE__ )
+ m_library = dlopen( vulkanLibraryName.c_str(), RTLD_NOW | RTLD_LOCAL );
+ # elif defined( _WIN32 )
+ m_library = ::LoadLibraryA( vulkanLibraryName.c_str() );
+@@ -92764,7 +92764,7 @@ namespace VULKAN_HPP_NAMESPACE
+ }
+ else
+ {
+-# if defined( __linux__ )
++# if defined( __unix__ )
+ m_library = dlopen( "libvulkan.so", RTLD_NOW | RTLD_LOCAL );
+ if ( m_library == nullptr )
+ {
+@@ -92807,7 +92807,7 @@ namespace VULKAN_HPP_NAMESPACE
+ {
+ if ( m_library )
+ {
+-# if defined( __linux__ ) || defined( __APPLE__ )
++# if defined( __unix__ ) || defined( __APPLE__ )
+ dlclose( m_library );
+ # elif defined( _WIN32 )
+ ::FreeLibrary( m_library );
+@@ -92820,7 +92820,7 @@ namespace VULKAN_HPP_NAMESPACE
+ template <typename T>
+ T getProcAddress( const char* function ) const VULKAN_HPP_NOEXCEPT
+ {
+-# if defined( __linux__ ) || defined( __APPLE__ )
++# if defined( __unix__ ) || defined( __APPLE__ )
+ return (T)dlsym( m_library, function );
+ # elif defined( _WIN32 )
+ return (T)::GetProcAddress( m_library, function );
+@@ -92832,7 +92832,7 @@ namespace VULKAN_HPP_NAMESPACE
+ bool success() const VULKAN_HPP_NOEXCEPT { return m_library != nullptr; }
+
+ private:
+-# if defined( __linux__ ) || defined( __APPLE__ )
++# if defined( __unix__ ) || defined( __APPLE__ )
+ void * m_library;
+ # elif defined( _WIN32 )
+ ::HINSTANCE m_library;
diff --git a/graphics/vulkan-headers/pkg-descr b/graphics/vulkan-headers/pkg-descr
new file mode 100644
index 000000000000..96ee63ffb24c
--- /dev/null
+++ b/graphics/vulkan-headers/pkg-descr
@@ -0,0 +1,5 @@
+Vulkan is a low-level cross-platform 3D graphics and compute API.
+
+This port provides the development headers for Vulkan applications.
+
+WWW: https://github.com/KhronosGroup/Vulkan-Headers
diff --git a/graphics/vulkan-headers/pkg-plist b/graphics/vulkan-headers/pkg-plist
new file mode 100644
index 000000000000..b2af760b236c
--- /dev/null
+++ b/graphics/vulkan-headers/pkg-plist
@@ -0,0 +1,30 @@
+include/vulkan/vk_icd.h
+include/vulkan/vk_layer.h
+include/vulkan/vk_platform.h
+include/vulkan/vk_sdk_platform.h
+include/vulkan/vulkan.h
+include/vulkan/vulkan.hpp
+include/vulkan/vulkan_android.h
+include/vulkan/vulkan_beta.h
+include/vulkan/vulkan_core.h
+include/vulkan/vulkan_directfb.h
+include/vulkan/vulkan_fuchsia.h
+include/vulkan/vulkan_ggp.h
+include/vulkan/vulkan_ios.h
+include/vulkan/vulkan_macos.h
+include/vulkan/vulkan_metal.h
+include/vulkan/vulkan_vi.h
+include/vulkan/vulkan_wayland.h
+include/vulkan/vulkan_win32.h
+include/vulkan/vulkan_xcb.h
+include/vulkan/vulkan_xlib.h
+include/vulkan/vulkan_xlib_xrandr.h
+share/vulkan/registry/cgenerator.py
+share/vulkan/registry/conventions.py
+share/vulkan/registry/generator.py
+share/vulkan/registry/genvk.py
+share/vulkan/registry/reg.py
+share/vulkan/registry/spec_tools/util.py
+share/vulkan/registry/validusage.json
+share/vulkan/registry/vk.xml
+share/vulkan/registry/vkconventions.py