aboutsummaryrefslogtreecommitdiff
path: root/graphics/vulkan-loader/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2018-09-03 17:43:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2018-09-03 17:43:50 +0000
commitfc090a966facfe899b046b73ce2e7f9eb784e9f8 (patch)
tree2757df8a0a866236352a0a37087b86c6ba971ac8 /graphics/vulkan-loader/Makefile
parenta94a04921ad79ad50fcb942d555f570667a2477c (diff)
downloadports-fc090a966facfe899b046b73ce2e7f9eb784e9f8.tar.gz
ports-fc090a966facfe899b046b73ce2e7f9eb784e9f8.zip
Add Vulkan SDK ports
https://www.khronos.org/vulkan/ PR: 222175 Tested by: Johannes Lundberg <johalun0@gmail.com> Submitted by: Greg V <greg@unrelenting.technology>
Notes
Notes: svn path=/head/; revision=478883
Diffstat (limited to 'graphics/vulkan-loader/Makefile')
-rw-r--r--graphics/vulkan-loader/Makefile47
1 files changed, 47 insertions, 0 deletions
diff --git a/graphics/vulkan-loader/Makefile b/graphics/vulkan-loader/Makefile
new file mode 100644
index 000000000000..4b225df77a61
--- /dev/null
+++ b/graphics/vulkan-loader/Makefile
@@ -0,0 +1,47 @@
+# $FreeBSD$
+
+PORTNAME= vulkan-loader
+DISTVERSIONPREFIX=sdk-
+DISTVERSION= 1.1.82.0
+CATEGORIES= graphics devel
+
+MAINTAINER= greg@unrelenting.technology
+COMMENT= Driver loader for the Vulkan graphics API
+
+LICENSE= APACHE20
+
+BUILD_DEPENDS= ${LOCALBASE}/include/vulkan/vulkan.h:devel/vulkan-headers
+
+USES= cmake:outsource compiler:c++11-lib pkgconfig python:3.4+,build
+USE_LDCONFIG= yes
+
+USE_GITHUB= yes
+GH_ACCOUNT= KhronosGroup
+GH_PROJECT= Vulkan-Loader
+
+CMAKE_ON= CMAKE_SKIP_RPATH
+CMAKE_OFF= BUILD_TESTS BUILD_WSI_MIR_SUPPORT
+
+OPTIONS_DEFINE= XLIB XCB WAYLAND
+OPTIONS_DEFAULT=XLIB XCB
+
+XLIB_DESC= Build Xlib WSI (Window System Integration) support
+XCB_DESC= Build XCB WSI (Window System Integration) support
+WAYLAND_DESC= Build Wayland WSI (Window System Integration) support
+
+XLIB_CMAKE_BOOL= BUILD_WSI_XLIB_SUPPORT
+XLIB_LIB_DEPENDS= libX11.so:x11/libX11 \
+ libXrandr.so:x11/libXrandr
+XCB_CMAKE_BOOL= BUILD_WSI_XCB_SUPPORT
+XCB_LIB_DEPENDS= libX11-xcb.so:x11/libX11 \
+ libxcb.so:x11/libxcb
+WAYLAND_CMAKE_BOOL= BUILD_WSI_WAYLAND_SUPPORT
+WAYLAND_LIB_DEPENDS= libwayland-egl.so:graphics/mesa-libs
+
+post-patch:
+# Non-x86 targets use C code, so don't abort without GNU as (e.g., on aarch64)
+.if !exists(/usr/bin/as) && ${MACHINE_ARCH} != i386 && ${MACHINE_ARCH} != amd64
+ @${REINPLACE_CMD} 's/-ATT//' ${WRKSRC}/loader/CMakeLists.txt
+.endif
+
+.include <bsd.port.mk>