aboutsummaryrefslogtreecommitdiff
path: root/graphics/waifu2x-converter-cpp
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2015-09-23 18:27:50 +0000
committerJan Beich <jbeich@FreeBSD.org>2015-09-23 18:27:50 +0000
commit8e3e878a3db2409e2e58a58705eff03ec0110447 (patch)
treee9c68cbd9d8f5c3124b2302ba5b8019e61faf165 /graphics/waifu2x-converter-cpp
parent0fdf645ce653b4e3015793b31cfb511d92d2310a (diff)
downloadports-8e3e878a3db2409e2e58a58705eff03ec0110447.tar.gz
ports-8e3e878a3db2409e2e58a58705eff03ec0110447.zip
graphics/waifu2x-converter-cpp: use proper regexp
Applying changes to the wrong line caused a regression.
Notes
Notes: svn path=/head/; revision=397630
Diffstat (limited to 'graphics/waifu2x-converter-cpp')
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index 2268756d2b27..2b7ed7791665 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -3,7 +3,7 @@
PORTNAME= waifu2x-converter-cpp
DISTVERSION= 1.0.0-237
DISTVERSIONSUFFIX= -gca65c93
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= graphics
MASTER_SITES= https://aur.archlinux.org/cgit/aur.git/plain/:manpage
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -54,9 +54,9 @@ post-patch:
@${REINPLACE_CMD} -e 's,-O2,,; /SYMBOL/s,-s,,' \
${WRKSRC}/CMakeLists.txt
@${REINPLACE_CMD} -e '/"models/s,","${DATADIR}/,' \
- -e '/CmdLine/s,${PORTVERSION:R},${DISTVERSIONFULL},' \
+ -e '/CmdLine/s,[^"]*"),${DISTVERSIONFULL}"),' \
${WRKSRC}/src/main.cpp
- @${REINPLACE_CMD} -e 's,[^"]*"),${PORTNAME}"),' \
+ @${REINPLACE_CMD} -e 's,${PORTNAME:C/-.*//},${PORTNAME},' \
-e 's,\(version\) [^"]*,\1 ${DISTVERSIONFULL},' \
${WRKDIR}/${PORTNAME}.1