aboutsummaryrefslogtreecommitdiff
path: root/graphics/waifu2x-converter-cpp
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-12-25 01:24:49 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-12-25 01:24:49 +0000
commitc835f150cdbac9783953e1dfd940b19cf8b4725f (patch)
tree576bb68691de975a96c6796837a560d82fe97f13 /graphics/waifu2x-converter-cpp
parentb15c3ba967e43db53d929ae6bfa476bd815c4780 (diff)
downloadports-c835f150cdbac9783953e1dfd940b19cf8b4725f.tar.gz
ports-c835f150cdbac9783953e1dfd940b19cf8b4725f.zip
graphics/waifu2x-converter-cpp: drop misleading manpage
The manpage only quotes --help and mentions CUDA, unsupported on FreeBSD.
Notes
Notes: svn path=/head/; revision=457202
Diffstat (limited to 'graphics/waifu2x-converter-cpp')
-rw-r--r--graphics/waifu2x-converter-cpp/Makefile19
1 files changed, 1 insertions, 18 deletions
diff --git a/graphics/waifu2x-converter-cpp/Makefile b/graphics/waifu2x-converter-cpp/Makefile
index 55ceca19da96..1b80d75f2a3c 100644
--- a/graphics/waifu2x-converter-cpp/Makefile
+++ b/graphics/waifu2x-converter-cpp/Makefile
@@ -3,11 +3,8 @@
PORTNAME= waifu2x-converter-cpp
DISTVERSION= 1.0.0-410
DISTVERSIONSUFFIX= -g5e5ac35
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= graphics
-MASTER_SITES= https://aur.archlinux.org/cgit/aur.git/plain/${PORTNAME:C/-.*//}.1.gz?h=${PORTNAME:C/-.*//}-git&id=5c150a5&/:manpage
-DISTFILES= ${PORTNAME:C/-.*//}.1.gz:manpage
-EXTRACT_ONLY= ${DISTFILES:N*\:manpage:C/:.*//}
MAINTAINER= jbeich@FreeBSD.org
COMMENT= Scale and denoise images using convolutional neural networks
@@ -35,7 +32,6 @@ LDFLAGS+= -Wl,--as-needed # avoid overlinking (opencv deps)
TEST_TARGET= test ARGS="-V"
USE_LDCONFIG= yes
PLIST_FILES= bin/${PORTNAME} \
- man/man1/${PORTNAME}.1.gz \
include/w2xconv.h \
lib/libw2xc.so
PORTDATA= *
@@ -47,23 +43,10 @@ OPTIONS_DEFAULT=SIMD
DOCS_CMAKE_ON= -DINSTALL_DOCS=on
SIMD_CMAKE_OFF= -DARMOPT=off -DX86OPT=off
-post-extract:
- @${GZCAT} ${_DISTDIR}/${DISTFILES:M*\:manpage:C/:.*//} \
- >${WRKDIR}/${PORTNAME}.1
-
post-patch:
@${REINPLACE_CMD} -e '/Darwin/,/FLAGS_RELEASE/d' \
-e 's,".*\(-m[^[:space:]]*\).*","\1",' \
-e 's/$${TS}/${DISTVERSIONFULL}/' \
${WRKSRC}/CMakeLists.txt
-# Undo AUR rename and use version from |git describe --tags|
- @${REINPLACE_CMD} -e '/AUTHORS/,$$! { /\.B mai/! \
- s,${PORTNAME:C/-.*//},${PORTNAME},; }' \
- -e '1s,\(version\) [^"]*,\1 ${DISTVERSIONFULL},' \
- ${WRKDIR}/${PORTNAME}.1
-
-post-install:
- ${INSTALL_MAN} ${WRKDIR}/${PORTNAME}.1 \
- ${STAGEDIR}${MAN1PREFIX}/man/man1
.include <bsd.port.mk>