aboutsummaryrefslogtreecommitdiff
path: root/graphics/waylandpp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2019-01-09 10:19:49 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2019-01-09 10:19:49 +0000
commit0fcf8df9b4aa73de0cac2cabebc787b91d9e31a1 (patch)
tree30ea63619026062e0839fd5bb48258b56a93b8ec /graphics/waylandpp
parent89057b75f8ad6cec7fdfc9d0d342099bf5e1ed59 (diff)
downloadports-0fcf8df9b4aa73de0cac2cabebc787b91d9e31a1.tar.gz
ports-0fcf8df9b4aa73de0cac2cabebc787b91d9e31a1.zip
graphics/waylandpp: Update to 0.2.4
- Mark the port as needing C++11 - Add missing USE_LDCONFIG Changes: https://github.com/NilsBrause/waylandpp/releases/tag/0.2.4
Notes
Notes: svn path=/head/; revision=489764
Diffstat (limited to 'graphics/waylandpp')
-rw-r--r--graphics/waylandpp/Makefile6
-rw-r--r--graphics/waylandpp/distinfo6
-rw-r--r--graphics/waylandpp/files/patch-CMakeLists.txt15
-rw-r--r--graphics/waylandpp/pkg-plist21
4 files changed, 42 insertions, 6 deletions
diff --git a/graphics/waylandpp/Makefile b/graphics/waylandpp/Makefile
index 99e5fd10eafb..93773b97ed9b 100644
--- a/graphics/waylandpp/Makefile
+++ b/graphics/waylandpp/Makefile
@@ -1,8 +1,7 @@
# $FreeBSD$
PORTNAME= waylandpp
-DISTVERSION= 0.2.3
-PORTREVISION= 1
+DISTVERSION= 0.2.4
CATEGORIES= graphics
MAINTAINER= tobik@FreeBSD.org
@@ -13,10 +12,11 @@ LICENSE_FILE= ${WRKSRC}/LICENSE
LIB_DEPENDS= libwayland-egl.so:graphics/wayland
-USES= cmake localbase pkgconfig
+USES= cmake compiler:c++11-lang gl pkgconfig
USE_GITHUB= yes
GH_ACCOUNT= NilsBrause
USE_GL= egl
+USE_LDCONFIG= yes
CMAKE_OFF= BUILD_DOCUMENTATION BUILD_EXAMPLES
diff --git a/graphics/waylandpp/distinfo b/graphics/waylandpp/distinfo
index 68db07d983ba..591ee0c06b99 100644
--- a/graphics/waylandpp/distinfo
+++ b/graphics/waylandpp/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1528023181
-SHA256 (NilsBrause-waylandpp-0.2.3_GH0.tar.gz) = ebd4a8447bb65f288cad0e04538f6ec704e155213fc2b9cc1a851534c70aacac
-SIZE (NilsBrause-waylandpp-0.2.3_GH0.tar.gz) = 180539
+TIMESTAMP = 1547021548
+SHA256 (NilsBrause-waylandpp-0.2.4_GH0.tar.gz) = 392e5f06c0d6a0ad3f0743d8c3ea9067beb68f575ae4d3e9b41971bcd1eb318d
+SIZE (NilsBrause-waylandpp-0.2.4_GH0.tar.gz) = 240718
diff --git a/graphics/waylandpp/files/patch-CMakeLists.txt b/graphics/waylandpp/files/patch-CMakeLists.txt
new file mode 100644
index 000000000000..15652a2e386a
--- /dev/null
+++ b/graphics/waylandpp/files/patch-CMakeLists.txt
@@ -0,0 +1,15 @@
+Add missing ${PROTO_FILES_EXTRA} dependency to ${PROTO_FILES_UNSTABLE}
+
+https://github.com/NilsBrause/waylandpp/pull/52
+
+--- CMakeLists.txt.orig 2019-01-09 08:54:47 UTC
++++ CMakeLists.txt
+@@ -91,7 +91,7 @@ if(BUILD_LIBRARIES)
+ add_custom_command(
+ OUTPUT ${PROTO_FILES_UNSTABLE}
+ COMMAND "${WAYLAND_SCANNERPP}" ${PROTO_XMLS_UNSTABLE} ${PROTO_FILES_UNSTABLE} "-x" "wayland-client-protocol-extra.hpp"
+- DEPENDS "${WAYLAND_SCANNERPP}" ${PROTO_XMLS_UNSTABLE})
++ DEPENDS "${WAYLAND_SCANNERPP}" ${PROTO_XMLS_UNSTABLE} ${PROTO_FILES_EXTRA})
+
+ # library building helper functions
+ function(define_library TARGET CFLAGS LDFLAGS HEADERS)
diff --git a/graphics/waylandpp/pkg-plist b/graphics/waylandpp/pkg-plist
index 55fb07af08be..84508a1600de 100644
--- a/graphics/waylandpp/pkg-plist
+++ b/graphics/waylandpp/pkg-plist
@@ -19,7 +19,28 @@ libdata/pkgconfig/wayland-client-extra++.pc
libdata/pkgconfig/wayland-cursor++.pc
libdata/pkgconfig/wayland-egl++.pc
libdata/pkgconfig/wayland-scanner++.pc
+%%DATADIR%%/protocols/fullscreen-shell-unstable-v1.xml
+%%DATADIR%%/protocols/idle-inhibit-unstable-v1.xml
+%%DATADIR%%/protocols/input-method-unstable-v1.xml
+%%DATADIR%%/protocols/input-timestamps-unstable-v1.xml
+%%DATADIR%%/protocols/keyboard-shortcuts-inhibit-unstable-v1.xml
+%%DATADIR%%/protocols/linux-dmabuf-unstable-v1.xml
+%%DATADIR%%/protocols/linux-explicit-synchronization-unstable-v1.xml
+%%DATADIR%%/protocols/pointer-constraints-unstable-v1.xml
+%%DATADIR%%/protocols/pointer-gestures-unstable-v1.xml
%%DATADIR%%/protocols/presentation-time.xml
+%%DATADIR%%/protocols/primary-selection-unstable-v1.xml
+%%DATADIR%%/protocols/relative-pointer-unstable-v1.xml
+%%DATADIR%%/protocols/tablet-unstable-v1.xml
+%%DATADIR%%/protocols/tablet-unstable-v2.xml
+%%DATADIR%%/protocols/text-input-unstable-v1.xml
+%%DATADIR%%/protocols/text-input-unstable-v3.xml
%%DATADIR%%/protocols/viewporter.xml
%%DATADIR%%/protocols/wayland.xml
+%%DATADIR%%/protocols/xdg-decoration-unstable-v1.xml
+%%DATADIR%%/protocols/xdg-foreign-unstable-v1.xml
+%%DATADIR%%/protocols/xdg-foreign-unstable-v2.xml
+%%DATADIR%%/protocols/xdg-output-unstable-v1.xml
+%%DATADIR%%/protocols/xdg-shell-unstable-v6.xml
%%DATADIR%%/protocols/xdg-shell.xml
+%%DATADIR%%/protocols/xwayland-keyboard-grab-unstable-v1.xml