aboutsummaryrefslogtreecommitdiff
path: root/graphics/waylandpp
diff options
context:
space:
mode:
authorTobias Kortkamp <tobik@FreeBSD.org>2018-03-25 15:33:51 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2018-03-25 15:33:51 +0000
commitb060cc6c56a27b07388c69221ac6af9025e98bcc (patch)
tree632e2d18a08954258a90c2a281efff59f6f8554b /graphics/waylandpp
parentc77df12705a0d829f1e161acfeed0ebe7ef43da0 (diff)
downloadports-b060cc6c56a27b07388c69221ac6af9025e98bcc.tar.gz
ports-b060cc6c56a27b07388c69221ac6af9025e98bcc.zip
New port: graphics/waylandpp
Wayland is an object oriented display protocol, which features request and events. Requests can be seen as method calls on certain objects, whereas events can be seen as signals of an object. This makes the Wayland protocol a perfect candidate for a C++ binding. The goal of this library is to create such a C++ binding for Wayland using the most modern C++ technology currently available, providing an easy to use C++ API to Wayland. WWW: https://github.com/NilsBrause/waylandpp This port is ignored by default because it requires a build of graphics/mesa-libs with WAYLAND=on which is off by default.
Notes
Notes: svn path=/head/; revision=465523
Diffstat (limited to 'graphics/waylandpp')
-rw-r--r--graphics/waylandpp/Makefile28
-rw-r--r--graphics/waylandpp/distinfo3
-rw-r--r--graphics/waylandpp/pkg-descr10
-rw-r--r--graphics/waylandpp/pkg-plist25
4 files changed, 66 insertions, 0 deletions
diff --git a/graphics/waylandpp/Makefile b/graphics/waylandpp/Makefile
new file mode 100644
index 000000000000..80d3b1a62ce0
--- /dev/null
+++ b/graphics/waylandpp/Makefile
@@ -0,0 +1,28 @@
+# $FreeBSD$
+
+PORTNAME= waylandpp
+DISTVERSION= 0.2.2
+CATEGORIES= graphics
+
+MAINTAINER= tobik@FreeBSD.org
+COMMENT= Wayland C++ bindings
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= cmake:outsource localbase pkgconfig
+USE_GITHUB= yes
+GH_ACCOUNT= NilsBrause
+USE_GL= egl
+
+CMAKE_OFF= BUILD_DOCUMENTATION BUILD_EXAMPLES
+
+OPTIONS_DEFINE= WAYLAND
+
+WAYLAND_DESC= Requires graphics/mesa-libs with WAYLAND on
+
+WAYLAND_IGNORE_OFF= Cannot be built without Wayland support
+WAYLAND_LIB_DEPENDS= libwayland-client.so:graphics/wayland \
+ libwayland-egl.so:graphics/mesa-libs
+
+.include <bsd.port.mk>
diff --git a/graphics/waylandpp/distinfo b/graphics/waylandpp/distinfo
new file mode 100644
index 000000000000..49130ac17ae9
--- /dev/null
+++ b/graphics/waylandpp/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1516380478
+SHA256 (NilsBrause-waylandpp-0.2.2_GH0.tar.gz) = e0c9012f3a5fb69922d5ecabdfbef739f1e0db3e68048b3f63537468ad5c4acd
+SIZE (NilsBrause-waylandpp-0.2.2_GH0.tar.gz) = 180313
diff --git a/graphics/waylandpp/pkg-descr b/graphics/waylandpp/pkg-descr
new file mode 100644
index 000000000000..4885b1be776a
--- /dev/null
+++ b/graphics/waylandpp/pkg-descr
@@ -0,0 +1,10 @@
+Wayland is an object oriented display protocol, which features request
+and events. Requests can be seen as method calls on certain objects,
+whereas events can be seen as signals of an object. This makes the
+Wayland protocol a perfect candidate for a C++ binding.
+
+The goal of this library is to create such a C++ binding for Wayland
+using the most modern C++ technology currently available, providing an
+easy to use C++ API to Wayland.
+
+WWW: https://github.com/NilsBrause/waylandpp
diff --git a/graphics/waylandpp/pkg-plist b/graphics/waylandpp/pkg-plist
new file mode 100644
index 000000000000..55fb07af08be
--- /dev/null
+++ b/graphics/waylandpp/pkg-plist
@@ -0,0 +1,25 @@
+bin/wayland-scanner++
+include/wayland-client-protocol-extra.hpp
+include/wayland-client-protocol.hpp
+include/wayland-client.hpp
+include/wayland-cursor.hpp
+include/wayland-egl.hpp
+include/wayland-util.hpp
+include/wayland-version.hpp
+lib/libwayland-client++.so
+lib/libwayland-client++.so.0.2
+lib/libwayland-client-extra++.so
+lib/libwayland-client-extra++.so.0.2
+lib/libwayland-cursor++.so
+lib/libwayland-cursor++.so.0.2
+lib/libwayland-egl++.so
+lib/libwayland-egl++.so.0.2
+libdata/pkgconfig/wayland-client++.pc
+libdata/pkgconfig/wayland-client-extra++.pc
+libdata/pkgconfig/wayland-cursor++.pc
+libdata/pkgconfig/wayland-egl++.pc
+libdata/pkgconfig/wayland-scanner++.pc
+%%DATADIR%%/protocols/presentation-time.xml
+%%DATADIR%%/protocols/viewporter.xml
+%%DATADIR%%/protocols/wayland.xml
+%%DATADIR%%/protocols/xdg-shell.xml