aboutsummaryrefslogtreecommitdiff
path: root/graphics/wdune
diff options
context:
space:
mode:
authorMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:19:54 +0000
committerMuhammad Moinur Rahman <bofh@FreeBSD.org>2023-07-21 19:57:52 +0000
commit5ad6ea91650a0c5c58f33164c9decf75b6581980 (patch)
treeca09310e1214ce919ea2c44c67a0965a7243394d /graphics/wdune
parent489227db292b9d7426c04a8226edac4e5292dfb1 (diff)
downloadports-5ad6ea91650a0c5c58f33164c9decf75b6581980.tar.gz
ports-5ad6ea91650a0c5c58f33164c9decf75b6581980.zip
graphics/wdune: Fix build with llvm16
- Pet portclippy Approved by: portmgr (blanket) Sponsored by: The FreeBSD Foundation
Diffstat (limited to 'graphics/wdune')
-rw-r--r--graphics/wdune/Makefile13
1 files changed, 8 insertions, 5 deletions
diff --git a/graphics/wdune/Makefile b/graphics/wdune/Makefile
index ef034c9e2a7d..1b3ca9f0722c 100644
--- a/graphics/wdune/Makefile
+++ b/graphics/wdune/Makefile
@@ -20,22 +20,25 @@ LIB_DEPENDS= libcurl.so:ftp/curl \
libpng.so:graphics/png \
libswresample.so.3:multimedia/ffmpeg4
-USES= compiler:c++11-lang gl jpeg motif sdl tar:bzip2 xorg
-USE_XORG= x11 xft xi xmu xext xt
+USES= compiler:c++11-lang gl jpeg localbase:ldflags motif sdl tar:bzip2 xorg
+USE_CXXSTD= c++14
USE_GL= gl glu glut
USE_SDL= sdl
+USE_XORG= x11 xft xi xmu xext xt
+
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-optimization \
--without-devil \
--with-cgalheaders \
--with-helpurl="${DOCSDIR}/index.html"
+
+ALL_TARGET= dune
+
CPPFLAGS+= -I${LOCALBASE}/ffmpeg4/include -I${LOCALBASE}/include/freetype2 -D__FREEBSD__
-LDFLAGS+= -L${LOCALBASE}/ffmpeg4/lib -L${LOCALBASE}/lib
+LDFLAGS+= -L${LOCALBASE}/ffmpeg4/lib
CONFLICTS_INSTALL= ocaml-dune
-ALL_TARGET= dune
-
OPTIONS_DEFINE= DOCS
do-install: