aboutsummaryrefslogtreecommitdiff
path: root/graphics/win32-codecs/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-09-19 16:18:15 +0000
committerAde Lovett <ade@FreeBSD.org>2000-09-19 16:18:15 +0000
commit10e47807a1d038e4b0f7e9e1f46393da665b9147 (patch)
tree9470f49512ab8f02f69961dfa064e28db7df9228 /graphics/win32-codecs/Makefile
parentf67c6ae4c3ee3572733af4e9f35e6b876373d091 (diff)
downloadports-10e47807a1d038e4b0f7e9e1f46393da665b9147.tar.gz
ports-10e47807a1d038e4b0f7e9e1f46393da665b9147.zip
Notes
Diffstat (limited to 'graphics/win32-codecs/Makefile')
-rw-r--r--graphics/win32-codecs/Makefile38
1 files changed, 38 insertions, 0 deletions
diff --git a/graphics/win32-codecs/Makefile b/graphics/win32-codecs/Makefile
new file mode 100644
index 000000000000..e217d78c8ded
--- /dev/null
+++ b/graphics/win32-codecs/Makefile
@@ -0,0 +1,38 @@
+# New ports collection makefile for: avifile
+# Date created: 16 September 2000
+# Whom: Holger Lamm
+#
+# $FreeBSD$
+#
+
+PORTNAME= avifile
+PORTVERSION= 0.47.1
+CATEGORIES= graphics
+MASTER_SITES= http://divx.euro.ru/
+DISTFILES= avifile-${PORTVERSION}${EXTRACT_SUFX} binaries.zip
+EXTRACT_ONLY= avifile-${PORTVERSION}${EXTRACT_SUFX}
+
+MAINTAINER= holger@eit.uni-kl.de
+
+LIB_DEPENDS= qt2.4:${PORTSDIR}/x11-toolkits/qt22 \
+ SDL-1.1.2:${PORTSDIR}/devel/sdl-devel
+BUILD_DEPENDS= unzip:${PORTSDIR}/archivers/unzip
+
+ONLY_FOR_ARCHS= i386
+USE_GMAKE= yes
+USE_XLIB= yes
+HAS_CONFIGURE= yes
+
+SDL_CONFIG?= ${LOCALBASE}/bin/sdl11-config
+MOC?= ${X11BASE}/bin/moc2
+
+CONFIGURE_ENV= SDL_CONFIG="${SDL_CONFIG}" \
+ MOC="${MOC}"
+CONFIGURE_ARGS= --enable-mmx \
+ --with-qt-includes=${X11BASE}/include/qt2 \
+ --with-win32-path=${LOCALBASE}/lib/win32
+
+pre-install:
+ unzip ${DISTDIR}/binaries.zip -d ${LOCALBASE}/lib/win32
+ strip ${WRKSRC}/bin/aviplay ${WRKSRC}/bin/benchmark
+.include <bsd.port.mk>