aboutsummaryrefslogtreecommitdiff
path: root/graphics/wxsvg
diff options
context:
space:
mode:
authorMichael Johnson <ahze@FreeBSD.org>2007-09-04 01:13:11 +0000
committerMichael Johnson <ahze@FreeBSD.org>2007-09-04 01:13:11 +0000
commit02d3c089cdd1c04d0806b619028dc6a611ef66a8 (patch)
tree677c375baa6dbe514118853c6d3d0c8ee9de8583 /graphics/wxsvg
parentc45973ad476865c3305d3e650b34fcf0b2e46b47 (diff)
downloadports-02d3c089cdd1c04d0806b619028dc6a611ef66a8.tar.gz
ports-02d3c089cdd1c04d0806b619028dc6a611ef66a8.zip
Notes
Diffstat (limited to 'graphics/wxsvg')
-rw-r--r--graphics/wxsvg/Makefile3
-rw-r--r--graphics/wxsvg/distinfo6
-rw-r--r--graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp49
3 files changed, 4 insertions, 54 deletions
diff --git a/graphics/wxsvg/Makefile b/graphics/wxsvg/Makefile
index c9e654f9d296..f6beee10792d 100644
--- a/graphics/wxsvg/Makefile
+++ b/graphics/wxsvg/Makefile
@@ -6,8 +6,7 @@
# $MCom: ports/graphics/wxsvg/Makefile,v 1.1 2006/09/22 01:48:33 ahze Exp $
PORTNAME= wxsvg
-DISTVERSION= 1.0b7
-PORTREVISION= 1
+DISTVERSION= 1.0b7_2
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= ${PORTNAME}
diff --git a/graphics/wxsvg/distinfo b/graphics/wxsvg/distinfo
index 9a881ccab5e0..f37ac97f7e5c 100644
--- a/graphics/wxsvg/distinfo
+++ b/graphics/wxsvg/distinfo
@@ -1,3 +1,3 @@
-MD5 (wxsvg-1.0b7.tar.gz) = 38a1caf8cb69037226c240b53f0e3509
-SHA256 (wxsvg-1.0b7.tar.gz) = e88c946637e3c124aee131ef66ebb235f9808b50d8c0e66b23ae8a0dc8b954d6
-SIZE (wxsvg-1.0b7.tar.gz) = 473402
+MD5 (wxsvg-1.0b7_2.tar.gz) = 5700d30555a6459377c87b817b3276d7
+SHA256 (wxsvg-1.0b7_2.tar.gz) = 463ae9b3bbc4a67bc206885c7522c072ab38c0293553cbf0f9b981e94d9b1360
+SIZE (wxsvg-1.0b7_2.tar.gz) = 592442
diff --git a/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp b/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp
deleted file mode 100644
index 0504527220e5..000000000000
--- a/graphics/wxsvg/files/patch-src_freetype_SVGCanvasTestFreetype.cpp
+++ /dev/null
@@ -1,49 +0,0 @@
---- src/freetype/SVGCanvasTextFreetype.cpp.orig Thu Jul 20 18:46:14 2006
-+++ src/freetype/SVGCanvasTextFreetype.cpp Thu Feb 22 18:42:55 2007
-@@ -163,7 +163,7 @@
- }
- }
-
--static gint moveto(FT_Vector* to, gpointer data)
-+static gint moveto(const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
-
-@@ -179,7 +179,7 @@
- return 0;
- }
-
--static gint lineto (FT_Vector* to, gpointer data)
-+static gint lineto (const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
-@@ -192,7 +192,7 @@
- return 0;
- }
-
--static gint conicto(FT_Vector* ftcontrol, FT_Vector* to, gpointer data)
-+static gint conicto(const FT_Vector* ftcontrol, const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
-@@ -207,8 +207,8 @@
- return 0;
- }
-
--static gint cubicto(FT_Vector* ftcontrol1, FT_Vector* ftcontrol2,
-- FT_Vector* to, gpointer data)
-+static gint cubicto(const FT_Vector* ftcontrol1, const FT_Vector* ftcontrol2,
-+ const FT_Vector* to, gpointer data)
- {
- wxSVGCanvasTextFreetype* canvasText = (wxSVGCanvasTextFreetype*) data;
- if (!canvasText->m_endpath)
-@@ -225,7 +225,7 @@
- return 0;
- }
-
--static const FT_Outline_Funcs outline_funcs =
-+static FT_Outline_Funcs outline_funcs =
- {
- moveto, lineto, conicto, cubicto, 0, 0
- };