aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos
diff options
context:
space:
mode:
authorJoseph Koshy <jkoshy@FreeBSD.org>2007-07-05 06:22:19 +0000
committerJoseph Koshy <jkoshy@FreeBSD.org>2007-07-05 06:22:19 +0000
commit02cc50a98928ade0ef82f1adabc7105ed674aace (patch)
treeb9b0676c6e064bd05dc227e1c5b166e551618e56 /graphics/xaos
parent3de5a84967cf1b6c2bafc9d4f6edc71fded26de4 (diff)
downloadports-02cc50a98928ade0ef82f1adabc7105ed674aace.tar.gz
ports-02cc50a98928ade0ef82f1adabc7105ed674aace.zip
- Upgrade to v3.2.3.
Upstream changes from the prior version of the port include: - New fractal types including the Spidron hornflake, Sierpinski, Koch and many others from the fractint formula database. - New tutorial movies, new examples. - Improved fonts for large screen sizes. - Improvements to translations, a romanian translation, and many bugfixes. - Build knobs for the port have been trimmed to ease port maintenance. The one remaining knob, "PTHREADS", switches on experimental support for multi-cpu machines. - The port now adopts the system default for CFLAGS and does not hardcode compiler switches for aggressive optimization.
Notes
Notes: svn path=/head/; revision=194969
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile41
-rw-r--r--graphics/xaos/distinfo6
-rw-r--r--graphics/xaos/files/patch-ai49
-rw-r--r--graphics/xaos/files/patch-aj17
-rw-r--r--graphics/xaos/files/patch-ak20
-rw-r--r--graphics/xaos/files/patch-configure19
-rw-r--r--graphics/xaos/files/patch-src_include_aconfig.h.in8
-rw-r--r--graphics/xaos/files/patch-src_ui_ui.c11
-rw-r--r--graphics/xaos/pkg-plist12
9 files changed, 62 insertions, 121 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index ee64b3a6e06f..4a912896d2bd 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -6,8 +6,7 @@
#
PORTNAME= xaos
-PORTVERSION= 3.1.2
-PORTREVISION= 1
+PORTVERSION= 3.2.3
CATEGORIES= graphics
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
MASTER_SITE_SUBDIR= xaos
@@ -22,18 +21,15 @@ USE_XLIB= yes
USE_GETTEXT= yes
GNU_CONFIGURE= yes
-OPTIONS= SVGALIB "Enable svgalib support" off \
- AALIB "Enable aalib support" off \
- PTHREAD "Enable experimental threads support" off
+OPTIONS= PTHREAD "Enable experimental SMP support" off
-CONFIGURE_ENV= LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
-CONFIGURE_ARGS= --with-dga-driver=no
-
-CFLAGS= -DHAVE_SYS_PARAM_H \
- -I${LOCALBASE}/include \
- -I${PREFIX}/include \
- -pipe -O6 -fstrength-reduce -ffast-math -fomit-frame-pointer\
- -fforce-mem -fforce-addr -funroll-loops
+CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
+ LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
+CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
+ --with-ggi-driver=no --with-svga-driver=no \
+ --with-included-gettext=yes \
+ --with-x --with-png=yes \
+ --with-mit-shm=yes
MAN6= xaos.6
INFO= xaos
@@ -42,20 +38,6 @@ PLIST_SUB+= XAOSDIR="share/XaoS"
.include <bsd.port.pre.mk>
-.if defined(WITH_SVGALIB)
-LIB_DEPENDS+= vga.1:${PORTSDIR}/graphics/svgalib
-CONFIGURE_ARGS+= --with-svga-driver=yes
-.else
-CONFIGURE_ARGS+= --with-svga-driver=no
-.endif
-
-.if defined(WITH_AALIB)
-LIB_DEPENDS+= aa.1:${PORTSDIR}/graphics/aalib
-CONFIGURE_ARGS+= --with-aa-driver=yes
-.else
-CONFIGURE_ARGS+= --with-aa-driver=no
-.endif
-
.if defined(WITH_PTHREAD)
CONFIGURE_ARGS+= --with-pthread=yes
CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
@@ -64,11 +46,6 @@ CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
CONFIGURE_ARGS+= --with-pthread=no
.endif
-# GCC 3.4.2 alleges prototype mismatches with __attribute__((regparm))
-.if ${OSVERSION} >= 502125
-CFLAGS+= -DNOREGISTERS
-.endif
-
post-install:
${STRIP_CMD} ${PREFIX}/bin/xaos
diff --git a/graphics/xaos/distinfo b/graphics/xaos/distinfo
index 9153ae4fecf5..efd16f2e874d 100644
--- a/graphics/xaos/distinfo
+++ b/graphics/xaos/distinfo
@@ -1,3 +1,3 @@
-MD5 (XaoS-3.1.2.tar.gz) = be908bc603461b76ba9628c9d4638852
-SHA256 (XaoS-3.1.2.tar.gz) = b8ec7c235c0021ef8306219ca81ab62c6d9a6982e2ed076a3916d6b4c0e49b00
-SIZE (XaoS-3.1.2.tar.gz) = 1430487
+MD5 (XaoS-3.2.3.tar.gz) = f1d9a9f3d2097906754b8824ba925e64
+SHA256 (XaoS-3.2.3.tar.gz) = b15420bcfafeca09eb29e5961cedbbe0572d0fc7912f6c545458a346188516c1
+SIZE (XaoS-3.2.3.tar.gz) = 1399068
diff --git a/graphics/xaos/files/patch-ai b/graphics/xaos/files/patch-ai
deleted file mode 100644
index 0ea1907ea838..000000000000
--- a/graphics/xaos/files/patch-ai
+++ /dev/null
@@ -1,49 +0,0 @@
---- configure.orig Fri Feb 11 15:18:52 2005
-+++ configure Sun Jul 10 20:38:20 2005
-@@ -10139,7 +10139,7 @@
-
- use_cc_g_flag=no
- DRIVERDIRS=""
--LOCALEDIR="/usr/share/locale"
-+LOCALEDIR="${prefix}/share/locale"
- DRIVERLIBS="lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a"
- CFLAGS="$CCOPTS"
- # Find a good install program. We prefer a C program (faster),
-@@ -13597,7 +13597,7 @@
-
- if $search_aalib
- then
-- if test -f /usr/include/aalib.h
-+ if /usr/bin/true
- then
- LIBS1="$LIBS"
- if test "x$no_x" = x; then
-@@ -13670,8 +13670,8 @@
- fi
-
- if test "x$ac_cv_lib_aa_aa_init" = xyes; then
-- echo "$as_me:$LINENO: result: Found aalib on /usr/include/aalib.h" >&5
--echo "${ECHO_T}Found aalib on /usr/include/aalib.h" >&6
-+ echo "$as_me:$LINENO: result: Found aalib on ${PREFIX}/include/aalib.h" >&5
-+echo "${ECHO_T}Found aalib on ${PREFIX}/include/aalib.h" >&6
- echo "$as_me:$LINENO: checking whether aalib version >= 1.4" >&5
- echo $ECHO_N "checking whether aalib version >= 1.4... $ECHO_C" >&6
- if test "${ac_aalib_ver_ok+set}" = set; then
-@@ -13687,7 +13687,7 @@
- */
- #endif
- }' > conftest.c
--if test -z "`${CC-cc} -c conftest.c 2>&1`"; then
-+if test -z "`${CC-cc} ${CFLAGS} -c conftest.c 2>&1`"; then
- ac_aalib_ver_ok=yes
- else
- ac_aalib_ver_ok=no
-@@ -17607,7 +17607,7 @@
- #define SVGA_DRIVER 1
- _ACEOF
-
-- STICKY='chmod +s $(bindir)/xaos; chown root $(bindir)/xaos; chgrp root $(bindir)/xaos'
-+ STICKY='chmod +s $(bindir)/xaos; chown root $(bindir)/xaos; chgrp wheel $(bindir)/xaos'
- DRIVERDIRS="$DRIVERDIRS ui/ui-drv/svga"
- DRIVERLIBS="$DRIVERLIBS lib/libuisvga.a"
- if test "x$ac_cv_func_pthread_sighandler" = xyes; then
diff --git a/graphics/xaos/files/patch-aj b/graphics/xaos/files/patch-aj
deleted file mode 100644
index 8458d7f889bb..000000000000
--- a/graphics/xaos/files/patch-aj
+++ /dev/null
@@ -1,17 +0,0 @@
---- src/ui/ui-drv/aa/ui_aa.c-- Wed Nov 28 15:41:11 2001
-+++ src/ui/ui-drv/aa/ui_aa.c Wed Nov 28 15:43:31 2001
-@@ -1,7 +1,14 @@
-+#if defined(HAVE_SYS_PARAM_H)
-+#include <sys/param.h>
-+#endif
- #include "aconfig.h"
- #ifdef AA_DRIVER
- #include <string.h>
-+#if (!defined(BSD) || (BSD < 199506))
- #include <malloc.h>
-+#else
-+#include <stdlib.h>
-+#endif
- #include <aalib.h>
- #include <ui.h>
- #include <unistd.h>
diff --git a/graphics/xaos/files/patch-ak b/graphics/xaos/files/patch-ak
deleted file mode 100644
index d17ced5bddf9..000000000000
--- a/graphics/xaos/files/patch-ak
+++ /dev/null
@@ -1,20 +0,0 @@
---- src/ui/ui-drv/svga/ui_svga.c-- Thu Mar 5 03:19:12 1998
-+++ src/ui/ui-drv/svga/ui_svga.c Wed Nov 28 15:48:12 2001
-@@ -19,10 +19,17 @@
- * along with this program; if not, write to the Free Software
- * Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
- */
-+#if defined(HAVE_SYS_PARAM_H)
-+#include <sys/param.h>
-+#endif
- #include "aconfig.h"
- #ifdef SVGA_DRIVER
- #include <stdio.h>
-+#if (!defined(BSD) || (BSD < 199506))
- #include <malloc.h>
-+#else
-+#include <stdlib.h>
-+#endif
- #include <vga.h>
- #include <vgagl.h>
- #include <vgamouse.h>
diff --git a/graphics/xaos/files/patch-configure b/graphics/xaos/files/patch-configure
new file mode 100644
index 000000000000..3951e017d0bd
--- /dev/null
+++ b/graphics/xaos/files/patch-configure
@@ -0,0 +1,19 @@
+--- configure.orig Sun Nov 12 22:49:50 2006
++++ configure Wed Jul 4 22:41:37 2007
+@@ -10653,7 +10653,7 @@
+
+ use_cc_g_flag=no
+ DRIVERDIRS=""
+-LOCALEDIR="/usr/share/locale"
++LOCALEDIR="${prefix}/share/locale"
+ DRIVERLIBS="lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a"
+ CFLAGS="$CCOPTS"
+ # Find a good install program. We prefer a C program (faster),
+@@ -16237,6 +16237,7 @@
+ eval datadir2=$datadir
+ cat >>confdefs.h <<_ACEOF
+ #define DATAPATH "${datadir2}/XaoS"
++#define PREFIX "${prefix}"
+ _ACEOF
+
+
diff --git a/graphics/xaos/files/patch-src_include_aconfig.h.in b/graphics/xaos/files/patch-src_include_aconfig.h.in
new file mode 100644
index 000000000000..b8f072f70c21
--- /dev/null
+++ b/graphics/xaos/files/patch-src_include_aconfig.h.in
@@ -0,0 +1,8 @@
+--- src/include/aconfig.h.in.orig Wed Jul 4 22:26:52 2007
++++ src/include/aconfig.h.in Wed Jul 4 22:26:58 2007
+@@ -55,4 +55,5 @@
+ #undef SIZEOF_LONG
+ #undef HAVE_GETTEXT
+ #undef NO_MALLOC_H
++#undef PREFIX
+ #endif
diff --git a/graphics/xaos/files/patch-src_ui_ui.c b/graphics/xaos/files/patch-src_ui_ui.c
new file mode 100644
index 000000000000..7b6723072732
--- /dev/null
+++ b/graphics/xaos/files/patch-src_ui_ui.c
@@ -0,0 +1,11 @@
+--- src/ui/ui.c.orig Sun Nov 12 22:49:51 2006
++++ src/ui/ui.c Wed Jul 4 22:43:49 2007
+@@ -1207,7 +1207,7 @@
+ )
+ #endif
+ #else
+- "/usr/share/locale")
++ PREFIX "/share/locale")
+ #ifdef DEBUG
+ )
+ #endif
diff --git a/graphics/xaos/pkg-plist b/graphics/xaos/pkg-plist
index 885c053ed683..7b3c6d5807c3 100644
--- a/graphics/xaos/pkg-plist
+++ b/graphics/xaos/pkg-plist
@@ -4,6 +4,7 @@ share/locale/de/LC_MESSAGES/xaos.mo
share/locale/es/LC_MESSAGES/xaos.mo
share/locale/fr/LC_MESSAGES/xaos.mo
share/locale/hu/LC_MESSAGES/xaos.mo
+share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/catalogs/README
%%XAOSDIR%%/catalogs/cesky.cat
%%XAOSDIR%%/catalogs/deutsch.cat
@@ -11,6 +12,7 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/catalogs/espanhol.cat
%%XAOSDIR%%/catalogs/francais.cat
%%XAOSDIR%%/catalogs/magyar.cat
+%%XAOSDIR%%/catalogs/romanian.cat
%%XAOSDIR%%/doc/AUTHORS
%%XAOSDIR%%/doc/PROBLEMS
%%XAOSDIR%%/doc/README
@@ -56,6 +58,7 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/edge2.xpf
%%XAOSDIR%%/examples/edge3.xpf
%%XAOSDIR%%/examples/eifell.xpf
+%%XAOSDIR%%/examples/fract0.xpf
%%XAOSDIR%%/examples/fract1.xpf
%%XAOSDIR%%/examples/galaxy.xpf
%%XAOSDIR%%/examples/gamma.xpf
@@ -64,6 +67,8 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/head.xpf
%%XAOSDIR%%/examples/head2.xpf
%%XAOSDIR%%/examples/head3.xpf
+%%XAOSDIR%%/examples/hornflake1.xpf
+%%XAOSDIR%%/examples/hornflake2.xpf
%%XAOSDIR%%/examples/impulzus.xpf
%%XAOSDIR%%/examples/incolor1.xpf
%%XAOSDIR%%/examples/incolor2.xpf
@@ -161,9 +166,13 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/zsigapro.xpf
%%XAOSDIR%%/help/xaos.hlp
%%XAOSDIR%%/tutorial/3dtutor.xaf
+%%XAOSDIR%%/tutorial/Bclosing.xaf
+%%XAOSDIR%%/tutorial/Bintro.xaf
+%%XAOSDIR%%/tutorial/Bolyai.xaf
%%XAOSDIR%%/tutorial/anim.xaf
%%XAOSDIR%%/tutorial/anim.xhf
%%XAOSDIR%%/tutorial/barnsley.xaf
+%%XAOSDIR%%/tutorial/classic.xaf
%%XAOSDIR%%/tutorial/coast.xhf
%%XAOSDIR%%/tutorial/dimension.xaf
%%XAOSDIR%%/tutorial/escape.xaf
@@ -177,6 +186,7 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/tutorial/flake5.xhf
%%XAOSDIR%%/tutorial/flaketh.xhf
%%XAOSDIR%%/tutorial/fmath.xaf
+%%XAOSDIR%%/tutorial/fourfr.xaf
%%XAOSDIR%%/tutorial/fractal.xaf
%%XAOSDIR%%/tutorial/head.xhf
%%XAOSDIR%%/tutorial/incolor.xaf
@@ -192,6 +202,7 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/tutorial/newton.xaf
%%XAOSDIR%%/tutorial/octo.xaf
%%XAOSDIR%%/tutorial/other.xaf
+%%XAOSDIR%%/tutorial/otherfr.xaf
%%XAOSDIR%%/tutorial/outcolor.xaf
%%XAOSDIR%%/tutorial/outnew.xhf
%%XAOSDIR%%/tutorial/palette.xaf
@@ -205,6 +216,7 @@ share/locale/hu/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/tutorial/render.xaf
%%XAOSDIR%%/tutorial/square.xhf
%%XAOSDIR%%/tutorial/tree.xhf
+%%XAOSDIR%%/tutorial/trice.xaf
%%XAOSDIR%%/tutorial/truecol.xaf
%%XAOSDIR%%/tutorial/truecol.xhf
@dirrm %%XAOSDIR%%/catalogs