aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-06-05 22:30:51 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-06-05 22:30:51 +0000
commit6856ad9540b2633d99891ee5b4a8919f03819efc (patch)
tree8fe7e08e0cbae2dd30c83a5e0b8bb055e2dd1dbc /graphics/xaos
parent976b369298e72caa43a9abb33f48bab81541f44d (diff)
downloadports-6856ad9540b2633d99891ee5b4a8919f03819efc.tar.gz
ports-6856ad9540b2633d99891ee5b4a8919f03819efc.zip
- Update to 3.4
PR: 124285 Submitted by: Max Brazhnikov <makc@issp.ac.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=214387
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile14
-rw-r--r--graphics/xaos/distinfo6
-rw-r--r--graphics/xaos/files/patch-src__Makefile.in2
-rw-r--r--graphics/xaos/files/patch-src_include_aconfig.h.in6
-rw-r--r--graphics/xaos/files/patch-src_ui_ui.c16
-rw-r--r--graphics/xaos/pkg-plist2
6 files changed, 23 insertions, 23 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 88426380839b..da3ed63ca009 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -6,8 +6,8 @@
#
PORTNAME= xaos
-PORTVERSION= 3.3
-CATEGORIES= graphics
+PORTVERSION= 3.4
+CATEGORIES= graphics math
MASTER_SITES= SF
DISTNAME= XaoS-${PORTVERSION}
@@ -16,27 +16,25 @@ COMMENT= A real-time fractal browser for X11 and ASCII terminals
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-USE_XORG= x11 xt x11 xau xdmcp xext
-USE_GETTEXT= yes
+USE_XORG= x11 xau xdmcp xext
GNU_CONFIGURE= yes
USE_GMAKE= yes
USE_AUTOTOOLS= autoconf:261
-OPTIONS= PTHREAD "Enable experimental SMP support" off
+OPTIONS= PTHREAD "Enable SMP support (experimental)" off \
+ NLS "Native Language Support" on
CONFIGURE_ENV= CFLAGS="${CFLAGS} -I${LOCALBASE}/include" \
LDFLAGS="-L${PREFIX}/lib -L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
--with-ggi-driver=no --with-svga-driver=no \
- --with-included-gettext=yes \
- --with-x --with-png=yes \
- --with-mit-shm=yes \
--with-sffe=no
MAN6= xaos.6
INFO= xaos
PLIST_SUB+= XAOSDIR="share/XaoS"
+
DESKTOP_ENTRIES="XaoS" "Fractal zoomer" "" "xaos" "" false
.include <bsd.port.pre.mk>
diff --git a/graphics/xaos/distinfo b/graphics/xaos/distinfo
index b6071475f643..a694a0d51105 100644
--- a/graphics/xaos/distinfo
+++ b/graphics/xaos/distinfo
@@ -1,3 +1,3 @@
-MD5 (XaoS-3.3.tar.gz) = c1156044a54638df32b1b163e051e3e0
-SHA256 (XaoS-3.3.tar.gz) = 02399eeb49f4e5fe43cd97195525ec5c603709a4a49998986402dc37ca76420f
-SIZE (XaoS-3.3.tar.gz) = 1638245
+MD5 (XaoS-3.4.tar.gz) = 366fd8151e9642a0d9afce889912e388
+SHA256 (XaoS-3.4.tar.gz) = 2cdba9b356f725b278b20eaf925b54478ba24b722b1ddda3879a84ddc16a8c00
+SIZE (XaoS-3.4.tar.gz) = 1977108
diff --git a/graphics/xaos/files/patch-src__Makefile.in b/graphics/xaos/files/patch-src__Makefile.in
index 647c7c0726b4..943f1c22681f 100644
--- a/graphics/xaos/files/patch-src__Makefile.in
+++ b/graphics/xaos/files/patch-src__Makefile.in
@@ -1,5 +1,5 @@
--- ./src/Makefile.in.orig 2008-03-05 16:00:12.000000000 +0300
-+++ ./src/Makefile.in 2008-04-11 01:36:56.000000000 +0400
++++ ./src/Makefile.in 2008-06-04 22:29:31.000000000 +0400
@@ -1,6 +1,6 @@
CC = @CC@
CFLAGS = @CFLAGS@
diff --git a/graphics/xaos/files/patch-src_include_aconfig.h.in b/graphics/xaos/files/patch-src_include_aconfig.h.in
index b8f072f70c21..ebc1d881deb1 100644
--- a/graphics/xaos/files/patch-src_include_aconfig.h.in
+++ b/graphics/xaos/files/patch-src_include_aconfig.h.in
@@ -1,6 +1,6 @@
---- src/include/aconfig.h.in.orig Wed Jul 4 22:26:52 2007
-+++ src/include/aconfig.h.in Wed Jul 4 22:26:58 2007
-@@ -55,4 +55,5 @@
+--- ./src/include/aconfig.h.in.orig 2008-05-22 00:23:37.000000000 +0400
++++ ./src/include/aconfig.h.in 2008-06-04 22:29:31.000000000 +0400
+@@ -56,4 +56,5 @@
#undef SIZEOF_LONG
#undef HAVE_GETTEXT
#undef NO_MALLOC_H
diff --git a/graphics/xaos/files/patch-src_ui_ui.c b/graphics/xaos/files/patch-src_ui_ui.c
index 7b6723072732..bdc0d7ec64c8 100644
--- a/graphics/xaos/files/patch-src_ui_ui.c
+++ b/graphics/xaos/files/patch-src_ui_ui.c
@@ -1,11 +1,11 @@
---- src/ui/ui.c.orig Sun Nov 12 22:49:51 2006
-+++ src/ui/ui.c Wed Jul 4 22:43:49 2007
-@@ -1207,7 +1207,7 @@
- )
- #endif
+--- ./src/ui/ui.c.orig 2008-05-22 00:23:37.000000000 +0400
++++ ./src/ui/ui.c 2008-06-04 22:36:27.000000000 +0400
+@@ -1243,7 +1243,7 @@
+ #ifdef USE_LOCALEPATH
+ localepath)
#else
-- "/usr/share/locale")
-+ PREFIX "/share/locale")
+- "/usr/share/locale")
++ PREFIX "/share/locale")
+ #endif
#ifdef DEBUG
)
- #endif
diff --git a/graphics/xaos/pkg-plist b/graphics/xaos/pkg-plist
index 42de2241b23d..e22cdea34ef1 100644
--- a/graphics/xaos/pkg-plist
+++ b/graphics/xaos/pkg-plist
@@ -5,6 +5,7 @@ bin/xaos
%%XAOSDIR%%/catalogs/english.cat
%%XAOSDIR%%/catalogs/espanhol.cat
%%XAOSDIR%%/catalogs/francais.cat
+%%XAOSDIR%%/catalogs/italiano.cat
%%XAOSDIR%%/catalogs/magyar.cat
%%XAOSDIR%%/catalogs/romanian.cat
%%XAOSDIR%%/doc/AUTHORS
@@ -228,6 +229,7 @@ bin/xaos
%%NLS%%share/locale/es/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/fr/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/hu/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/it/LC_MESSAGES/xaos.mo
%%NLS%%share/locale/ro/LC_MESSAGES/xaos.mo
@dirrm %%XAOSDIR%%/tutorial
@dirrm %%XAOSDIR%%/help