aboutsummaryrefslogtreecommitdiff
path: root/graphics/xaos
diff options
context:
space:
mode:
authorMartin Wilke <miwi@FreeBSD.org>2008-04-29 19:06:44 +0000
committerMartin Wilke <miwi@FreeBSD.org>2008-04-29 19:06:44 +0000
commite543536c709e02d045e4c8d0f6aa3c9753451f3f (patch)
treec22c9a4c0fae90c56f253f0acd98ff345d1a198e /graphics/xaos
parent9db2a2a83248c221f10a727eb41928ec92b62a5d (diff)
downloadports-e543536c709e02d045e4c8d0f6aa3c9753451f3f.tar.gz
ports-e543536c709e02d045e4c8d0f6aa3c9753451f3f.zip
- Update to 3.3
PR: 122892 Submitted by: Max Brazhnikov <makc@issp.ac.ru> (maintainer)
Notes
Notes: svn path=/head/; revision=212281
Diffstat (limited to 'graphics/xaos')
-rw-r--r--graphics/xaos/Makefile22
-rw-r--r--graphics/xaos/distinfo6
-rw-r--r--graphics/xaos/files/patch-configure19
-rw-r--r--graphics/xaos/files/patch-configure.in27
-rw-r--r--graphics/xaos/files/patch-src__Makefile.in10
-rw-r--r--graphics/xaos/pkg-descr2
-rw-r--r--graphics/xaos/pkg-plist28
7 files changed, 76 insertions, 38 deletions
diff --git a/graphics/xaos/Makefile b/graphics/xaos/Makefile
index 79f64c36e40a..88426380839b 100644
--- a/graphics/xaos/Makefile
+++ b/graphics/xaos/Makefile
@@ -6,10 +6,9 @@
#
PORTNAME= xaos
-PORTVERSION= 3.2.3
-PORTREVISION= 3
+PORTVERSION= 3.3
CATEGORIES= graphics
-MASTER_SITES= SF/xaos
+MASTER_SITES= SF
DISTNAME= XaoS-${PORTVERSION}
MAINTAINER= makc@issp.ac.ru
@@ -17,9 +16,11 @@ COMMENT= A real-time fractal browser for X11 and ASCII terminals
LIB_DEPENDS= png.5:${PORTSDIR}/graphics/png
-USE_XORG= x11 xt
+USE_XORG= x11 xt x11 xau xdmcp xext
USE_GETTEXT= yes
GNU_CONFIGURE= yes
+USE_GMAKE= yes
+USE_AUTOTOOLS= autoconf:261
OPTIONS= PTHREAD "Enable experimental SMP support" off
@@ -29,12 +30,14 @@ CONFIGURE_ARGS= --with-aa-driver=no --with-dga-driver=no \
--with-ggi-driver=no --with-svga-driver=no \
--with-included-gettext=yes \
--with-x --with-png=yes \
- --with-mit-shm=yes
+ --with-mit-shm=yes \
+ --with-sffe=no
MAN6= xaos.6
INFO= xaos
PLIST_SUB+= XAOSDIR="share/XaoS"
+DESKTOP_ENTRIES="XaoS" "Fractal zoomer" "" "xaos" "" false
.include <bsd.port.pre.mk>
@@ -46,7 +49,12 @@ CONFIGURE_ENV+= LIBS="${PTHREAD_LIBS}" \
CONFIGURE_ARGS+= --with-pthread=no
.endif
-post-install:
- ${STRIP_CMD} ${PREFIX}/bin/xaos
+.if !defined(WITHOUT_NLS)
+USE_GETTEXT= yes
+PLIST_SUB+= NLS=""
+.else
+CONFIGURE_ARGS+=--disable-nls
+PLIST_SUB+= NLS="@comment "
+.endif
.include <bsd.port.post.mk>
diff --git a/graphics/xaos/distinfo b/graphics/xaos/distinfo
index efd16f2e874d..b6071475f643 100644
--- a/graphics/xaos/distinfo
+++ b/graphics/xaos/distinfo
@@ -1,3 +1,3 @@
-MD5 (XaoS-3.2.3.tar.gz) = f1d9a9f3d2097906754b8824ba925e64
-SHA256 (XaoS-3.2.3.tar.gz) = b15420bcfafeca09eb29e5961cedbbe0572d0fc7912f6c545458a346188516c1
-SIZE (XaoS-3.2.3.tar.gz) = 1399068
+MD5 (XaoS-3.3.tar.gz) = c1156044a54638df32b1b163e051e3e0
+SHA256 (XaoS-3.3.tar.gz) = 02399eeb49f4e5fe43cd97195525ec5c603709a4a49998986402dc37ca76420f
+SIZE (XaoS-3.3.tar.gz) = 1638245
diff --git a/graphics/xaos/files/patch-configure b/graphics/xaos/files/patch-configure
deleted file mode 100644
index 3951e017d0bd..000000000000
--- a/graphics/xaos/files/patch-configure
+++ /dev/null
@@ -1,19 +0,0 @@
---- configure.orig Sun Nov 12 22:49:50 2006
-+++ configure Wed Jul 4 22:41:37 2007
-@@ -10653,7 +10653,7 @@
-
- use_cc_g_flag=no
- DRIVERDIRS=""
--LOCALEDIR="/usr/share/locale"
-+LOCALEDIR="${prefix}/share/locale"
- DRIVERLIBS="lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a"
- CFLAGS="$CCOPTS"
- # Find a good install program. We prefer a C program (faster),
-@@ -16237,6 +16237,7 @@
- eval datadir2=$datadir
- cat >>confdefs.h <<_ACEOF
- #define DATAPATH "${datadir2}/XaoS"
-+#define PREFIX "${prefix}"
- _ACEOF
-
-
diff --git a/graphics/xaos/files/patch-configure.in b/graphics/xaos/files/patch-configure.in
new file mode 100644
index 000000000000..fdc7ffa082d2
--- /dev/null
+++ b/graphics/xaos/files/patch-configure.in
@@ -0,0 +1,27 @@
+--- ./configure.in.orig 2008-03-13 20:23:57.000000000 +0300
++++ ./configure.in 2008-04-10 22:34:25.000000000 +0400
+@@ -284,7 +284,7 @@
+
+ use_cc_g_flag=no
+ DRIVERDIRS=""
+-LOCALEDIR="/usr/share/locale"
++LOCALEDIR="${prefix}/share/locale"
+ DRIVERLIBS="lib/libui.a lib/libui-hlp.a lib/libengine.a lib/libutil.a lib/libfilter.a"
+ CFLAGS="$CCOPTS"
+ AC_PROG_INSTALL
+@@ -429,6 +429,7 @@
+ fi
+ fi
+ case $target_os in
++*freebsd*) CMPLX_O_TARGET=elf;;
+ *linux*) CMPLX_O_TARGET=elf;;
+ *cygwin*) CMPLX_O_TARGET=coff;;
+ *darwin*) CMPLX_O_TARGET=macho;;
+@@ -735,6 +736,7 @@
+ eval datadir3=$datadir2
+ # This is a madness! eval can evaluate only one level of variable...
+ AC_DEFINE_UNQUOTED(DATAPATH,"${datadir3}/XaoS")
++AC_DEFINE_UNQUOTED(PREFIX,"${prefix}")
+
+ AC_CHECK_SIZEOF(short)
+ AC_CHECK_SIZEOF(int)
diff --git a/graphics/xaos/files/patch-src__Makefile.in b/graphics/xaos/files/patch-src__Makefile.in
new file mode 100644
index 000000000000..647c7c0726b4
--- /dev/null
+++ b/graphics/xaos/files/patch-src__Makefile.in
@@ -0,0 +1,10 @@
+--- ./src/Makefile.in.orig 2008-03-05 16:00:12.000000000 +0300
++++ ./src/Makefile.in 2008-04-11 01:36:56.000000000 +0400
+@@ -1,6 +1,6 @@
+ CC = @CC@
+ CFLAGS = @CFLAGS@
+-LIBS = @LIBS@
++LIBS = @LIBS@ @LTLIBINTL@
+ LFLAGS = @LDFLAGS@
+ AR = @AR@
+ RANLIB = @RANLIB@
diff --git a/graphics/xaos/pkg-descr b/graphics/xaos/pkg-descr
index 5a4396a70914..6b56861d48c9 100644
--- a/graphics/xaos/pkg-descr
+++ b/graphics/xaos/pkg-descr
@@ -10,3 +10,5 @@ Features:
- saving to GIF files
- palette rotation
- random dot stereograms
+
+WWW: http://xaos.sf.net
diff --git a/graphics/xaos/pkg-plist b/graphics/xaos/pkg-plist
index 7b3c6d5807c3..42de2241b23d 100644
--- a/graphics/xaos/pkg-plist
+++ b/graphics/xaos/pkg-plist
@@ -1,10 +1,4 @@
bin/xaos
-share/locale/cs/LC_MESSAGES/xaos.mo
-share/locale/de/LC_MESSAGES/xaos.mo
-share/locale/es/LC_MESSAGES/xaos.mo
-share/locale/fr/LC_MESSAGES/xaos.mo
-share/locale/hu/LC_MESSAGES/xaos.mo
-share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/catalogs/README
%%XAOSDIR%%/catalogs/cesky.cat
%%XAOSDIR%%/catalogs/deutsch.cat
@@ -31,6 +25,7 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/3d8.xpf
%%XAOSDIR%%/examples/3d9.xpf
%%XAOSDIR%%/examples/README
+%%XAOSDIR%%/examples/alien.xpf
%%XAOSDIR%%/examples/axe.xpf
%%XAOSDIR%%/examples/barnsl1.xpf
%%XAOSDIR%%/examples/barnsl2.xpf
@@ -45,7 +40,10 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/beatle2.xpf
%%XAOSDIR%%/examples/bolygo.xpf
%%XAOSDIR%%/examples/brown.xpf
+%%XAOSDIR%%/examples/burnship.xpf
+%%XAOSDIR%%/examples/butterfly.xpf
%%XAOSDIR%%/examples/checker.xpf
+%%XAOSDIR%%/examples/circle.xpf
%%XAOSDIR%%/examples/crone.xpf
%%XAOSDIR%%/examples/csiga2.xpf
%%XAOSDIR%%/examples/csiga3.xpf
@@ -58,6 +56,7 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/edge2.xpf
%%XAOSDIR%%/examples/edge3.xpf
%%XAOSDIR%%/examples/eifell.xpf
+%%XAOSDIR%%/examples/eyes.xpf
%%XAOSDIR%%/examples/fract0.xpf
%%XAOSDIR%%/examples/fract1.xpf
%%XAOSDIR%%/examples/galaxy.xpf
@@ -67,6 +66,8 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/head.xpf
%%XAOSDIR%%/examples/head2.xpf
%%XAOSDIR%%/examples/head3.xpf
+%%XAOSDIR%%/examples/heart.xpf
+%%XAOSDIR%%/examples/helloween.xpf
%%XAOSDIR%%/examples/hornflake1.xpf
%%XAOSDIR%%/examples/hornflake2.xpf
%%XAOSDIR%%/examples/impulzus.xpf
@@ -131,6 +132,7 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/palace.xpf
%%XAOSDIR%%/examples/pavaszem.xpf
%%XAOSDIR%%/examples/pavaszem2.xpf
+%%XAOSDIR%%/examples/pentafrac.xpf
%%XAOSDIR%%/examples/pepita.xpf
%%XAOSDIR%%/examples/perb1.xpf
%%XAOSDIR%%/examples/perb2.xpf
@@ -144,6 +146,7 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/redmand2.xpf
%%XAOSDIR%%/examples/rocks.xpf
%%XAOSDIR%%/examples/shell.xpf
+%%XAOSDIR%%/examples/skullfrm.xpf
%%XAOSDIR%%/examples/something.xpf
%%XAOSDIR%%/examples/spiral.xpf
%%XAOSDIR%%/examples/spiral2.xpf
@@ -163,6 +166,7 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/examples/truecol6.xpf
%%XAOSDIR%%/examples/truecol7.xpf
%%XAOSDIR%%/examples/ufo.xpf
+%%XAOSDIR%%/examples/warriormask.xpf
%%XAOSDIR%%/examples/zsigapro.xpf
%%XAOSDIR%%/help/xaos.hlp
%%XAOSDIR%%/tutorial/3dtutor.xaf
@@ -219,9 +223,15 @@ share/locale/ro/LC_MESSAGES/xaos.mo
%%XAOSDIR%%/tutorial/trice.xaf
%%XAOSDIR%%/tutorial/truecol.xaf
%%XAOSDIR%%/tutorial/truecol.xhf
-@dirrm %%XAOSDIR%%/catalogs
-@dirrm %%XAOSDIR%%/examples
+%%NLS%%share/locale/cs/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/de/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/es/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/hu/LC_MESSAGES/xaos.mo
+%%NLS%%share/locale/ro/LC_MESSAGES/xaos.mo
@dirrm %%XAOSDIR%%/tutorial
-@dirrm %%XAOSDIR%%/doc
@dirrm %%XAOSDIR%%/help
+@dirrm %%XAOSDIR%%/examples
+@dirrm %%XAOSDIR%%/doc
+@dirrm %%XAOSDIR%%/catalogs
@dirrm %%XAOSDIR%%