aboutsummaryrefslogtreecommitdiff
path: root/graphics/xcftools
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2017-06-25 21:07:58 +0000
commit5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf (patch)
tree3291541f3b73432c893dec35f4f23770dd07732a /graphics/xcftools
parent9c92503171817f96d944009b9ea88d3c083c9a45 (diff)
downloadports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.tar.gz
ports-5e373eaa92fd3a243e1bc7a8e3eaf114ab1eeabf.zip
Make ninja opt-out in cmake.mk
Using ninja instead of make (1) can lead to significant speed ups while building. Therefore switch from having the ninja generator opt-in to having it opt-out. Previously cmake-ports that wanted to use ninja could set CMAKE_NINJA=yes now, ports that do not work with ninja can set cmake:<existing args>,noninja Note, that needing this should be an exception and most often points to a broken cmake of the port. The ports using cmake were modified * removed USES=gmake, if ninja is used * removed MAKE_ARGS, if ninja is used * added the cmake-argument noninja if necessary PR: 219629 PR: 213331 Exp-run by: antoine Reviewed by: rakuco Differential Revision: https://reviews.freebsd.org/D10748
Notes
Notes: svn path=/head/; revision=444324
Diffstat (limited to 'graphics/xcftools')
-rw-r--r--graphics/xcftools/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/graphics/xcftools/Makefile b/graphics/xcftools/Makefile
index 4ff156aba260..3ecc6fda755c 100644
--- a/graphics/xcftools/Makefile
+++ b/graphics/xcftools/Makefile
@@ -18,7 +18,7 @@ GH_ACCOUNT= j-jorge
GH_TAGNAME= d72ba82
# option NLS (for gettext) is wrong as this port allways needs NLS:
-USES= libtool cmake gmake iconv pkgconfig perl5 gettext
+USES= libtool cmake:noninja gmake iconv pkgconfig perl5 gettext
USE_PERL5= build run
GNU_CONFIGURE= yes
USE_LDCONFIG= yes