aboutsummaryrefslogtreecommitdiff
path: root/graphics/xd3d/Makefile
diff options
context:
space:
mode:
authorThierry Thomas <thierry@FreeBSD.org>2014-04-21 09:58:05 +0000
committerThierry Thomas <thierry@FreeBSD.org>2014-04-21 09:58:05 +0000
commit575463b2c46f6452d389f446585b0bbfc431c9f2 (patch)
tree8ee982dd791fe9e15ef9faf908ba81192f7a20b9 /graphics/xd3d/Makefile
parent0c654fdf2320cb5c7ca470697ddd918b27e0b752 (diff)
downloadports-575463b2c46f6452d389f446585b0bbfc431c9f2.tar.gz
ports-575463b2c46f6452d389f446585b0bbfc431c9f2.zip
Notes
Diffstat (limited to 'graphics/xd3d/Makefile')
-rw-r--r--graphics/xd3d/Makefile30
1 files changed, 15 insertions, 15 deletions
diff --git a/graphics/xd3d/Makefile b/graphics/xd3d/Makefile
index 949d08704c66..6534c0ac3cf5 100644
--- a/graphics/xd3d/Makefile
+++ b/graphics/xd3d/Makefile
@@ -10,8 +10,9 @@ MASTER_SITES= http://www.cmap.polytechnique.fr/~jouve/xd3d/
MAINTAINER= thierry@FreeBSD.org
COMMENT= A simple scientific visualization tool
+LICENSE= GPLv2
+
#--------------------------------------------------------------------------
-NO_STAGE= yes
# You may define these options:
#
# - WITHOUT_IMAGEMAGICK : if you don't need to export bitmap images
@@ -35,7 +36,7 @@ RUN_DEPENDS+= gifsicle:${PORTSDIR}/graphics/gifsicle
MASTER_SITES_BACKUP= http://pompo.net/ports/
REINPLACE_ARGS= -i ""
-FETCH_CMD= /usr/bin/fetch
+FETCH_ARGS=
FETCH_BEFORE_ARGS= -R -o ${DISTDIR}/${DISTFILES}
USES= fortran
@@ -61,11 +62,11 @@ do-fetch:
|| ${FETCH_CMD} ${FETCH_BEFORE_ARGS} ${MASTER_SITES_BACKUP}${DISTFILES}
.endif
-post-patch:
- @${CP} ${WRKSRC}/RULES.freeBSD ${WRKSRC}/RULES
- @${REINPLACE_CMD} -e "s|%%WRKSRC%%|${WRKSRC}|" \
+pre-configure:
+ ${CP} ${WRKSRC}/RULES.freeBSD ${WRKSRC}/RULES
+ ${REINPLACE_CMD} -e "s|%%WRKSRC%%|${WRKSRC}|" \
-e "s|%%PREFIX%%|${PREFIX}|" \
- -e "s|%%X11BASE%%|${LOCALBASE}|" \
+ -e "s|%%X11BASE%%|${LOCALBASE}|" \
-e "s|%%LANG%%|${XD3D_LANG}|" \
-e "s|%%MEMORY_XD3D%%|${MEMORY_XD3D}|" \
-e "s|%%F77%%|${F77}|" \
@@ -76,15 +77,14 @@ post-patch:
post-install:
.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
-.for FILE in ${DOCS}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
-.endfor
- @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
- @${MKDIR} ${EXAMPLESDIR}
- @${CP} -Rp ${WRKSRC}/Examples/* ${EXAMPLESDIR}
- @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
- @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+. for FILE in ${DOCS}
+ ${INSTALL_DATA} ${WRKSRC}/${FILE} ${STAGEDIR}${DOCSDIR}
+. endfor
+.endif
+.if !defined(NOPORTEXAMPLES)
+ ${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
+ ${CP} -Rp ${WRKSRC}/Examples/* ${STAGEDIR}${EXAMPLESDIR}
.endif
.include <bsd.port.post.mk>