aboutsummaryrefslogtreecommitdiff
path: root/graphics/xd3d/Makefile
diff options
context:
space:
mode:
authorKirill Ponomarev <krion@FreeBSD.org>2003-09-30 14:47:16 +0000
committerKirill Ponomarev <krion@FreeBSD.org>2003-09-30 14:47:16 +0000
commit7bed26d486beae936b94a7c3b27f0b791e52cd4b (patch)
treee4a5aba350352808ec8587ec2998d11411482aa7 /graphics/xd3d/Makefile
parent534da3531bbde0b38604652311b8b1d20cbe9a59 (diff)
downloadports-7bed26d486beae936b94a7c3b27f0b791e52cd4b.tar.gz
ports-7bed26d486beae936b94a7c3b27f0b791e52cd4b.zip
Add xd3d 8.0.2, a simple scientific visualization tool.
It can plot 2d and 3d meshes, with shadowing, contour plots, vector fields, iso-contour (3d), as well as 3d surfaces z=f(x,y) defined by an algebraic expression or a cloud of points. It generates high quality vector PostScript files for scientific publications and still or animated bitmap images. It includes the graph plotter xgraphic. PR: 56986 Submitted by: thierry@pompo.net
Notes
Notes: svn path=/head/; revision=89903
Diffstat (limited to 'graphics/xd3d/Makefile')
-rw-r--r--graphics/xd3d/Makefile91
1 files changed, 91 insertions, 0 deletions
diff --git a/graphics/xd3d/Makefile b/graphics/xd3d/Makefile
new file mode 100644
index 000000000000..76f79318aa00
--- /dev/null
+++ b/graphics/xd3d/Makefile
@@ -0,0 +1,91 @@
+# New ports collection makefile for: xd3d
+# Date created: Tue Sept. 16 2003
+# Whom: thierry@pompo.net
+#
+# $FreeBSD$
+#
+
+PORTNAME= xd3d
+PORTVERSION= 8.0.2
+CATEGORIES= graphics math
+MASTER_SITES= http://www.cmap.polytechnique.fr/~jouve/xd3d/
+
+MAINTAINER= thierry@pompo.net
+COMMENT= A simple scientific visualization tool
+
+#--------------------------------------------------------------------------
+# You may define these options:
+#
+# - WITHOUT_IMAGEMAGICK : if you don't need to export bitmap images
+# in gif or png format;
+#
+# - WITHOUT_GIFSICLE : if you want to generate some nice animated
+# gifs;
+#
+# - MEMORY_XD3D : Max memory for xd3d (MBytes, 64 by default)
+#
+# - F77 : don't use the default fortran compiler;
+# - FFLAGS : fortran compiler's flags (-O by default).
+#--------------------------------------------------------------------------
+
+.if !defined(WITHOUT_IMAGEMAGICK)
+RUN_DEPENDS= convert:${PORTSDIR}/graphics/ImageMagick
+.endif
+.if !defined(WITHOUT_GIFSICLE)
+RUN_DEPENDS+= gifsicle:${PORTSDIR}/graphics/gifsicle
+.endif
+
+USE_XLIB= yes
+USE_REINPLACE= yes
+REINPLACE_ARGS= -i ""
+FETCH_CMD= /usr/bin/fetch
+FETCH_BEFORE_ARGS= -R -o ${DISTDIR}/${DISTFILES}
+
+F77?= f77
+FFLAGS?= -O
+MEMORY_XD3D?= 64
+
+.if defined(LANG) && ${LANG:M${fr}*} != ""
+XD3D_LANG= FRANCAIS
+.else
+XD3D_LANG= ENGLISH
+.endif
+
+DOCS= BUGS FAQ INSTALL README Manuals/formats.txt \
+ Manuals/xd3d_doc.pdf Manuals/xgraphic_doc.pdf
+
+.include <bsd.port.pre.mk>
+
+do-fetch:
+.if !exists(${DISTDIR}/${DISTNAME}${EXTRACT_SUFX})
+ ${FETCH_CMD} ${FETCH_BEFORE_ARGS} \
+ ${MASTER_SITES}download.php?file=${DISTFILES}
+.endif
+
+post-patch:
+ @${CP} ${FILESDIR}/RULES.FreeBSD ${WRKSRC}/RULES
+ @${REINPLACE_CMD} -e "s|%%WRKSRC%%|${WRKSRC}|" \
+ -e "s|%%PREFIX%%|${PREFIX}|" \
+ -e "s|%%X11BASE%%|${X11BASE}|" \
+ -e "s|%%LANG%%|${XD3D_LANG}|" \
+ -e "s|%%MEMORY_XD3D%%|${MEMORY_XD3D}|" \
+ -e "s|%%F77%%|${F77}|" \
+ -e "s|%%FFLAGS%%|${FFLAGS}|" \
+ -e "s|%%CC%%|${CC}|" \
+ -e "s|%%CFLAGS%%|${CFLAGS}|" \
+ ${WRKSRC}/RULES
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+.for FILE in ${DOCS}
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
+.endfor
+ @${ECHO_MSG} "===> Documentation installed in ${DOCSDIR}."
+ @${MKDIR} ${EXAMPLESDIR}
+ @${CP} -Rp ${WRKSRC}/Examples/* ${EXAMPLESDIR}
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
+ @${ECHO_MSG} "===> Examples installed in ${EXAMPLESDIR}."
+.endif
+
+.include <bsd.port.post.mk>